J AUTE ST E

Quick Start Guide Version 9.0.2

CarMaker

SOLUTIONS FOR VIRTUAL TEST DRIVING



The information in this document is furnished for informational use only, may be revised
from time to time, and should not be construed as a commitment by the
IPG Automotive Group. IPG Automotive Group assumes no responsibility or liability for any
errors or inaccuracies that may appear in this document.

This document contains proprietary and copyrighted information and may not be copied,
reproduced, translated, or reduced to any electronic medium without prior consent, in writ-
ing, from IPG Automotive Group.

© 1999 - 2020 by IPG Automotive Group — www.ipg-automotive.com
All rights reserved.

FailSafeTester, IPGCar, IPGControl, IPGDriver, IPGEngine, IPGGraph, IPGKinematics,
IPGLock, IPGMotorcycle, IPGMovie, IPGRoad, IPGRoaddata, IPGTire, IPGTrailer,
IPGTruck, RealtimeMaker, Xpack4 are trademarks of the IPG Automotive Group.

CarMaker, TruckMaker, MotorcycleMaker, MESA VERDE are
registered trademarks of IPG Automotive Group.

All other product names are trademarks of their respective companies.

IPG Automotive Group means any corporate body of which IPG Automotive GmbH has a
majority stake.

CarMaker Quick Start Guide Version 9.0.2



Contents 3

Contents

1 About This Quick Start Guide 6
2 CarMaker Installation 7
3 Starting CarMaker 8
4 Running Example TestRuns 10
4.1 Loading a Predefined Virtual Vehicle Environment ... .............. 11

4.2 Runningthe Simulation . ........ ... ... ... . . . . 12
4.2.1 Interactive View of the Current Simulation ................ 13

4.3 Animation with IPGMovie . ........ ... 16

4.4 Data Analysis . ... e e 18
441  IPGControl . ... .. 18

4.4.2 Alternative Methods ............ .. .. . . .. ... 23

5 Creating Your First TestRun 25
5.1 TestRun with Main Focus: Vehicle Dynamics ..................... 25
5.1.1 Building a Road Network Using the Scenario Editor . .. ... ... 25

5.1.2 Definingthe Maneuver ............ ... .. i .. 28

5.1.3 Selecting a Vehicle and Simulating ...................... 29

514 SavingYourTestRun ............ .. ... 31

5.2 TestRun with Main Focus: ADAS . ....... ... ... . . . .. 32
5.2.1 Building a Road Network Using the Scenario Editor . .. ... ... 32

5.2.2 DefiningaManeuver . ............. .. 36

523 Adding Traffic ........... ... . . . . . . e 38

5.2.4 Collision Detection . ..........c...nnn.. 40

CarMaker Quick Start Guide Version 9.0.2



Contents 4

5.25 Settingupan AEB System ......... ... .. ..., 41

5,26 UsingNamedValues ..............ciiiinnnnn.. 43

5.2.7  Executing Multiple TestRun Variations using the TestManager . 45

5.3 TestRun with Main Focus: Powertrain .. ......................... 46
5.3.1 Creatingthe 48V HybridP1 ......... ... ... ... .. ... ....... 46

5.3.2 ImportingtheRoad ............ ... .. 49

5.3.3  Maneuver and Driver Parameters ....................... 51
5.3.4 Implementing Speed Limits . . ......... ... .. ..., 53

5.3.5 Creatingthe 48V P2 Hybrid ......... ... ... .. .. ......... 56

5.3.6  Test Automation using the Test Manager ................. 58

5.4 TestRun with Main Focus: Scenario Editor . ...................... 62
5.4.1 Building a Road Network using the Scenario Editor ......... 62

5.4.2 Definingthe Maneuver ............. ... 80

6 Vehicle Model Parameterization 89
6.1 WhatisaData Set? ........ ... 89
6.2 CreatingaNew VehicleDataSet .............................. 89
6.2.1  Using the Vehicle Data Set Generator ................... 90

6.2.2 UsingthelmportFeature ............................. 91

6.3 Vehicle Submodels . ........ .. .. 91
6.3.1  Assembly . ... 92

6.3.2 Body ......... 95

6.3.3  SUSPENSIONS . ..ot 98

6.3.4  Steering System . .. ... 105

6.3.5  TIrES .o e 106

6.3.6 Brake System ........ ... 106

6.3.7 Powertrain . ....... ... 107

6.3.8  SeNSOIS . ... 111

6.3.9 Vehicle Control ......... ... ... . . . . 112
6.3.10 Additional ........... ... 112

6.4 SaveasaNewDataSet ......... ... ..., 113
6.5 CreatingaNew TrailerDataSet ............ ... ..., 113
6.6 CreatingaNewTireDataSet ......... ... ..., 114
6.6.1 Overviewof TireModels ........... ... ... .. ......... 114

6.6.2 Tire Model EXercises . .. .......... i, 115

CarMaker Quick Start Guide Version 9.0.2



Contents 5

7 CarMaker for Simulink 116
7.1 Starting CarMaker for Simulink .. ....... ... ... ... ... ... ... ... 116
7.2 First simulation with CarMaker for Simulink . .................... 118
7.3 Description of the CarMaker Environment in Simulink . ............ 120
7.4 Advantages and Disadvantages of using CarMaker for Simulink . . . .. 121
8 Features of the CarMaker for Simulink blockset 122
8.1 General Information . ......... ... .. 123
8.1.1 BIloCK Properties . ........c.uiiiiiiii i 123
8.1.2 Modeling Principles .. ..., 123
8.1.3  Purpose of the Sync_Inand Sync_ OutPorts ............. 124
8.2 Ultility BIOCKS ... 124
8.21 CarMaker GUI . ... ... 124
8.3 CarMaker Dictionary Blocks . ......... ... ..., 125
831 ReadCMDICt ... ... 125
8.3.2 WIrite CMDICt ... . 125
8.3.3 DefineCMDICt .........0 i 126
8.3.4 Dictionary Initialization . ........... ... . ... ... 127
9 How to Extend the Simulink Model 128
9.1 Overview of the CarMaker Simulink Structure ................... 128
9.2 EXample ... 130
9.21 CONtENIS .. 130
9.2.2 Create anew Simulink Model ......................... 130
9.2.3 Preparethe extension ..............c.uiiiriirennnnn.. 130
9.24 ConnectInputs . ...... ..o 131
9.25 Demonstration Examples . ..............ciiiii... 134
10 Additional Information About CarMaker 135
10.1 What are the Differences between each CarMaker Version? ........ 135
10.2 Typical TeStS .. .. i 135
10.3 Feature List . .. ...t e 137

CarMaker Quick Start Guide Version 9.0.2



About This Quick Start Guide 6

Chapter 1

About This Quick Start Guide

This document is intended to give a first impression of CarMaker and how it can be used to
perform simulations, either in form of a stand-alone application (for e.g. when being run "as
is", without further software), or as an embedded environment in Simulink.

The Quick Start Guide can be seen as a tutorial, providing shallow insight into the powerful
world of virtual test driving with CarMaker. That the software is much more complex than
this document may lead to believe, can be seen in the many other documents, that can be
found in the CarMaker Help section. Other CarMaker manuals and documentations
describe the software in much greater detail, seeing as they contain all aspects of using,
adapting and programming the CarMaker software package.

All paragraphs in this format contain instructions on how to proceed.
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Chapter 2
CarMaker Installation

To install CarMaker, the user needs administrative privileges and extract the downloaded
installation package (.zip archive). The IPG Installer can be started via double clicking on
the executable ipg-install.exe.

In case the user has received an installation CD, this needs to be inserted into the CD-ROM
drive of the computer. If AutoRun is activated, IPGInstall should start automatically. Other-
wise, the executable file ipg-install.exe must be opened manually.

Once CarMaker has been installed, the user must contact the IPG License Team to apply
for a valid license. To apply for a license, a license key request form can be found in the
support area of the IPG website http://www.ipg-automotive.com/. The form needs to be
filled out completely. Subsequently, the user receives a valid license file from the IPG
License Team. The license file must be saved in the <InstallationDirectory>\etc folder. Now
the software is activated and ready to use.

Please find more detailed information about the IPG Installer or about e.g. using a floating
license or installing a HIL system in the Installation Guide, available in the Help menu of the
CarMaker main GUI.

CarMaker Quick Start Guide Version 9.0.2
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Chapter 3

Starting CarMaker

Start CarMaker in Windows: Start > Programs > IPG > CarMaker Version No. > Car-
Maker.

Starting CarMaker in Linux: Open console > enter “CM”

a4
&

—

Figure 3.1: Opening CarMaker using Windows
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Once the final CarMaker executable has been selected, the CarMaker software opens.

|t CarMaker 9.0 i B
Eile Application Simulation Earametsls Sefiings Help J IPG

Car:
CarMaker 9.0 s
VIRTUAL TEST DRIVING
Trailer: -
Select
Tires: Select
Load: Okg Select
Maneuver
B Simulation Storage of Results 1
| Pert: X max Mode: #|collectanly Start
Status: Buffer:
= | Stop
Time:
= Distance: Jave Siop Ahart

Figure 3.2: CarMaker main GUI

The first thing the user sees is the CarMaker main GUI (main Graphical User Interface), as
displayed in the figure above. This is CarMaker’s control center, with which all functionalities
and sub windows are accessed.

Now, CarMaker is ready to work and can be used right away.

CarMaker Quick Start Guide Version 9.0.2
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Chapter 4
Running Example TestRuns

Performing a simulation in CarMaker requires similar definitions to when carrying out a real
test drive. The type of vehicle, tires, driver, test track and a maneuver, that the driver is to
perform, need to be defined. CarMaker provides several predefined models for each of
these requirements. A combination of these models and settings form what is called a
TestRun.

What exactly is a TestRun?

CarMaker is based on fixed models (vehicle, suspension, tires, etc.) whose properties (e.qg.
values for the mass of each body or spring stiffness) can be varied.

This means that the number of bodies and the DOF (degrees of freedom) between them
are already defined and the user doesn’t need to model these on his own. If the user wishes
to extend a model, CM4SL is recommended. For further information on this topic, please
refer to section 'CarMaker for Simulink’.

The models themselves are already defined, but they still need to be parameterized accord-
ing to their environment. For this, a so called data set is manually implemented or loaded
for each of the models. Parameterizing includes selecting a vehicle, selecting or designing
aroad, defining a type of driver and defining a maneuver. After all of these components are
set, CarMaker has the information necessary to control the virtual vehicle environment
(VVE) and simulate.

All of these settings are stored in a file used by the VVE during simulation. Said file, which
can be saved, loaded or edited, is what we call the TestRun definition. Loading and execut-
ing this file results in the simulation of that specific test.The TestRun files have the format
of a regular text file and can be viewed with an editor.

In summary: a TestRun represents a test scenario in which all parameters of the virtual
environment (vehicle, driver, tires, etc.) are sufficiently defined.

The standard CarMaker installation includes a variety of example TestRuns containing all
the data required to describe each of these models. This makes it possible for a new user
to work with CarMaker and get to know the other main features of the program right away.

CarMaker Quick Start Guide Version 9.0.2
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Loading a Predefined Virtual Vehicle Environment

Loading a Predefined Virtual Vehicle
Environment

When starting CarMaker for the first time, a project folder that will contain all the TestRun
data, needs to be created. This is done by selecting File > Project Folder > Create Project
in the CarMaker main GUI. When you start CarMaker again in the future, you can then
either keep using the same project folder or create a new one. Either way, a project directory

must be defined.
™ CarMaker 9.I_J

Eile | 5 Help 41PG
= _ £ar : Select
. IVING o CarMaker - New Project b
Trailer: -
New Project
——
Project Folder I Create Project... - | ProjectFolder
I b Update Project... lies I ‘@
: Date Select... -
Included Features
Load: Okg . .
[ Sources / Build Enviranment

| [~ Sources: Extra Models

| s [~ FMIExamples

t ] [ CarMaker for Simulink Extras

= Selectall
Perf & max I~ Simulink Coder (RTW) Examples 4
Etlips= Wotkst Status: I~ Concerto Work Environment Default
Quit Ctrl-q Time:
| Ok Cancel
7 Distance J J

Figure 4.1: Creating a new project folder

In the field labelled Project Folder a path is selected where the project directory will be
placed. The additional features that are available can be activated optionally by ticking the
appending boxes. For this tutorial, none of the available features needs to be selected.

Now, after a project directory has been defined, a TestRun can be loaded.

Load the TestRun "HandlingCourse”:
In the CarMaker GUI, click on File > Open, select the Product Examples , then Exam-
ples > BasicFunctions > Driver > HandlingCourse.

| CarMaker 9.0

E\\E‘i_\ppll:atmn Simulation Parameters Seftings Help
New Car: - | CarMaker - Browser.
open ciiro @
IVING
sl s . Load TestRun
Save gs Trailer: -
Broject Folder - @ @ O b |Examples/BasicFunctions/DriveriHandlingCourse _vJ o 0K |
Data Pools. — Tires: - - ; Name ©
Encrypt Data. —— - . ) & Product Isfop NinuxB4-8.1/DatalTe % Cancel
- Load: Okg M ([ESExamples
IPGMavis Project [&BasicFunctions
IPGCantrol (ESDriver
IPGControl 118 - - * ‘BackAndFarth
Instruments £ | --|_ChanginglLanes
7 - Perl;  ¥|realime UECERE e Product " Drifing
Ef”‘-‘”axa'::‘ Status: Examples - [F1GearShifing ts
Sl e ~ |E“”E' [ GeneralSettings.ts
[/ GGDiagram.ts
Quit £l e ~/HandbrakeUTum
7 Distance S HandlingCourse
Overtaking
+~["IRaceDriver
_SnailsPace
ISteeringByTorque
TrafficStopAndGao —
f
[ Information about selected item
[Vehicle: Examples/DemoCar 4 File
Artificial handling track for demonstration of IPGDriver 7.7 KBytes
functions.
Read more... ??1[]%110 2L
7 root

Figure 4.2: Loading "SegmentBasedClosedTrack"
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Running the Simulation

Looking into the CarMaker main GUI, it is now filled with all the data sets that are required
to execute a simulation. The TestRun is now ready for simulation.

ITM CarMaker - Test: Examples/BasicFunctions/Driver/HandlingCourse

File Application Simulation Parameters Settings Help Rl =]

Car: Examples/DemoCar Select
Typical, unvalidated data for passengercar
with Front Wheel Drive
Trailer: - Select |
Tires:

- P : .. Select
Load: 0 kg Selact

T Simulation 1 Storage of Results ——————————
Perf.: X max Mode: | collect only

Start
Status: Buffer:
o= | Stop
Time:
Distance: 10} bart |

Maneuver
0

Figure 4.3: CarMaker GUI containing relevant data sets

4.2 Running the Simulation

Now, since there is a TestRun loaded in CarMaker, all the data necessary to successfully
perform a simulation is already at hand.

Start the simulation: Click on the green “Start” button in the CarMaker GUI.

The simulation begins. This can be recognized by noticing the following points:

* In IPGMovie: The animation of the current simulation is running and can be viewed by
the user. After the simulation has ended, it is possible to replay the simulation in various
speeds.

* Inthe CarMaker GUI: In the box labelled Simulation a timer, an indicator for the dis-
tance covered by the car, as well as the current status of the simulation are displayed.

* InInstruments: The operating displays, especially the tachometer, can be viewed in
real time.

Note: If IPGMovie and Instruments do not automatically pop up when CarMaker is started,
these can be opened by clicking File > IPGMovie and File > Instruments in the main GUI.

CarMaker Quick Start Guide Version 9.0.2
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Running the Simulation

o | CarMaker - Test: Examples/BasicFunctions/Driver/HandlingCourse =

2 instruments - eslinux-soleng0dt online =%

Eile Applicaion Simulation Parameters Sgftings Add-ons Help JIPG

Car:  ExamplesDemoCar
Typical, unvalidated data for passenger car pEIET:

N with Front Whez| Drive
@ @ Trailer: - e

= ires: £ E g
g Thes: £ g Selsct
l, ) Load: 0kg Selact - —
Gearhox
,, T
e VSRR s v s s e R135

I [ " [l

Perl:  ¥reaime | | Mode: ¥|collect only S Cluteh Brake Gas I ? J T
)x) B 100 B 100 B 100
s .09 Buffer: 336 MB, 559 s ] - =
Running | sw a 3 ]
Time: 86 5 s :
. % %

| Lo o o
Distance: 22.02 Save ‘ ‘ o 2 4
[ 1PGMavie - wstinux salengl01* online =%
File View Scene Camera Help 4 IF’G‘

] 4]0 b WG 556 s s |

Figure 4.4: Running simulation displayed in the main GUI, Instruments and IPGMovie

Stop the simulation: Click on the red “Stop“ button in the CarMaker GUI.

The IPGMovie animation ends, the Instruments slowly come to a stand still and all other
displays in the CarMaker GUI are stopped.

The Stop button is used when it is desired to abort the TestRun before completion. Other-
wise, when the TestRun comes to an end on it's own, the simulation also stops and returns
to idle state, the user does not need to manually end it.

The following chapters will describe what happens during the simulation in further detail.

Click the green “Start* button in order to start the TestRun again.

Now you can observe the CarMaker GUI, IPGMovie, the Instruments window and IPGCon-
trol to find out what these display during an active simulation.

Interactive View of the Current Simulation

CarMaker offers various methods to observe a simulation. A few of these will be described
briefly in this chapter. The most important ones will be picked up again in later chapters e.qg.
section 4.4.1 'IPGControl’.

Version 9.0.2
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Running the Simulation

IPGMovie

IPGMovie enables the user to watch an animation of the current simulation.

@ IPGMovie - ‘wslinux-appl009° online

File Wiew Scene Camera Help

W 4B M| ix [ 5638 s [ | Start |

Figure 4.5: Online view of a simulation in IPGMovie

During the animation, different points of view and background scenery can be selected.
Despite the view and design settings available, IPGMovie is much more than just an anima-
tion tool. For instance, current animations can be exported to a file for further use in pre-
sentations or advertising.

A more detailed explanation on using IPGMovie is given in section 4.3 'Animation with IPG-

.
Movie’.
| v CarMaker - Test: Examples/BasicFunctions/Driver/HandlingCourse X
File Application Simulation Parameters Settings Help | IPG
Car: Examples/DemoCar Selact
Typical, unvalidated data for passenger car
with Front Wheel Drive
%' Trailer: - Select
=Y Tires: Ex /RT_195 65R15 Ex./RT_195 85R15 o
J Ex. /RT_185 B5R{D Ex. /RT_195.85R15
Loa: kg Select
Maneuver
Storage of Results 1
Perf.  J/realtime Mode: | collect only Start
£k, ] Buffer: 336 MB, 558 s
Running I Stop
Time: 0.0
Distance: §1.79 Save Jd Abort

© © o

Figure 4.6: The CarMaker GUI
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Running the Simulation

* Box (A): Storage of Results

The results generated by CarMaker are usually saved to a buffer in the computer RAM.
They can, however, also be saved to a file for further analysis by selecting the mode option
save all instead of collect only. This box helps to control and define the saving strategy. For
further information, please refer to the User's Guide which can be found under Help in the
CarMaker main GUI.

* Box (B): Simulation

In this box the user can define the speed of the simulation: real time or slower/faster than
real time. The max option enables simulation speeds that are as fast as the current PC
hardware and active software will allow. This can be up to 40 times real time and remember
that opening IPGMovie will have an effect on the PC performance, just like all other appli-
cations.

Speeding up the simulation saves time, especially when working with automated TestRuns
where often a very large number is carried out in sequence. Another feature is that the sim-
ulation speed can be altered during the simulation.

Additionally, in this box the time and distance of the current simulation are displayed. The
user also receives information regarding the status of the simulation: Idle when no simula-
tion is running, Preparing during the start phase or Running while the simulation is being
carried out.

Observe changes in IPGMovie when the Simulation Speed is 2x, Max and Realtime .

e Box (C) Maneuver

As will be further described in section 'Creating Your First TestRun’, several maneuver
steps can be defined that are all displayed in this section. The current maneuver step is
highlighted in blue so that it is clear which step is currently being simulated.

Instruments

Instruments is an additional display that is used to quickly, visually check the most important
data and gives an overview of the driver’s actions. The content of Instruments is very similar
to what can be seen in the dashboard of a real vehicle!

120 140
100 .y 00y, 16
N ,.

rprm
%1000

=

B U U ¥

Figure 4.7: The Instruments GUI
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What is displayed in Instruments can optionally be individualized and extended by the user.
In order to do so, CarMaker features an interface using tcl/tk script language that enables
each user to build an individual GUI. Further information regarding this topic can be found

in the Programmer’s Guide.

IPGControl

IPGControl is an embedded tool that is used to plot various diagrams of the simulation

results online.

Running Example TestRuns

Animation with IPGMovie

Open IPGControl: File > IPGControl

[ [ IPGControl 3.0.5 (Window 0)

File Diagram Sgttings Help
R —

=i
B. Ix. x. # & & sPc
£  patasources (v) &
Key | Description F
‘ ‘
=
.| =
_Y_ | Quantities (7%
Search |a X =
Quantity Name Tz [
= Car (9685, 2 selected)
@ Aero )
“alHori m/sr2
“atHori m/s"2
fax m/s"2
; -
a1 1¥]
| #r | cursor R
¥y | Preset Manager (7] &
Name \F‘—_;
|51 Project Directory ‘_
fdl
=] 213

Figure 4.8: IPGControl Window

Plot the speed and lateral acceleration of the vehicle:

IPGControl Sidebar> "Quanti-

ties" field > left-click on the variables "Car.v" and "Car.ay".

In the CarMaker GUI, start the simulation.

area.

After a while, select Fittotally in order to fit the diagram within the available diagram

IPGControl usage is explained in further detail in section 4.4.1 'IPGControl’.

Animation with IPGMovie

Click the green Start button to simulate the TestRun

HandlingCourse again.

CarMaker Quick Start Guide

Version 9.0.2
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Animation with IPGMovie

IPGMovie offers the functionality of an online animation. This means that the current simu-
lation data is provided without delay - the virtual world is pictured directly during the simu-
lation. Additionally, by loading external result files, the animations of TestRuns that have
previously been carried out can still be shown in IPGMovie. This is called offline animation.

The first IPGMovie feature to be explained here is that using the mouse, the user can
change the point of view and zoom in and out during the simulation.

Change the point of view: Push the left mouse button and move t he cursor in the
desired direction.

Zoom: Keep the middle mouse button pressed and move the cursor up and down or
use the mouse wheel.

DI S

[ Giil=

PPN

Figure 4.9: Different points of view in IPGMovie

Abort the Testrun: Click the red  Stop button in the CarMaker main GUI.

After a simulation has ended (when the TestRun is over or after the user clicks the Stop but-
ton in the CarMaker main GUI), the animation can be replayed in IPGMovie using the cursor
in the Control Bar. The camera’s point of view can still be modified at all times.

Watch the movie from the last simulation in IPGMovie again by using the cursor in
the Control Bar. Change the point of view.

CarMaker Quick Start Guide Version 9.0.2
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Data Analysis

Furthermore, IPGMovie offers a whole variety of useful functionalities:

« Comparing the animations of two different simulations: two simulations with different
settings are carried out and can then be played simultaneously in IPGMovie, allowing
quick, visual analysis of the results.

» A variety of options accessible via right-click within the IPGMovie window.

» Different Camera options that can be selected in the IPGMovie window by clicking
Camera in the top menu. Additionally, multiple personalized camera views can be
defined.

» Various options that can be selected via the Scene option in the top menu.

» Exporting videos or pictures from the animation: File > Export (DivX is one possibility
that is only possible if the codec is installed on the current system).

» Viewing tire forces: View > Show > Forces. The colored bars at the contact points of
each tire represent the forces in each of the three directions or the coordinate system.

All modifications that are made to the road definition will be displayed in IPGMovie. Howev-
er, the animation needs to be updated first. That means the simulation needs to be started
and stopped at least once. Further information regarding IPGMovie can be found in the
Movie manual.

Data Analysis

There are several ways to analyze the data that is generated during a CarMaker simulation.
IPG offers it's own tool called IPGControl that was developed for viewing and analyzing pur-
poses and can also be used standalone. Apart from this, a wide variety of third party tools
like Excel or Matlab can be used for data analysis.

IPGControl

This chapter will explain how to analyze and plot simulation results using IPGControl.

IPGControl offers the functionalities of an online result management application. This
means that the current simulation data is provided without delay. Diagrams can be dis-
played directly during the simulation. By loading external result files, the user also has the
possibility to display the results of previous TestRuns. This is called offline result manage-
ment. Each new source of results is displayed in the Data Sets list in the selection window.
The data saved in these files can be plotted in another diagram.

The figure below makes clear that there is a very high number of quantities (simulation vari-
ables) that can be plotted. IPGControl allows the user to manipulate the plotted quantities
and change scaling of the axis so that the results can be analyzed more efficiently and
effectively.

CarMaker Quick Start Guide Version 9.0.2
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Data Analysis

Opening IPGControl

IPGControl is opened via the File menu in the CarMaker main GUI.
Diagram window

2nd diagram

[ - IPGControl 304 Windown) [

Eile Diagram Seftings Help

(985, 2 selected)
1 Aero 1)

+-alHori mfs?
atHori m/s?

N mis
a /s

-az m/s?

[zl BufferFL

~CamberFL

~CamberFR rad
CamberRL rad

~CamberRR rad

& CFL (129)

+-CFR (129)

[ Con (18)

1 ConA @

1 CRL (125

=CRR (125

1. Main menu
2. Diagram
3. Sidebar

Figure 4.10: IPGControl Window

Using the Data Sources in the Sidebar, the result files can be selected that are to be dis-
played in the Diagram.

CarMaker Quick Start Guide Version 9.0.2
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Data Analysis

Selecting the Quantities to be plotted

- ox
PG
o%

Snapshot of C1 - 12:42:57
Examples_VehicleDynamics_Brakin..

IX Reference Quantity an

Search | x =

-UserOut_00
~UserOut_01
~UserOut_02
i-UserQut_03
+UserOut_04
UserQut_05 m
i-UserOut_06

Ia ¥
Reference quantity offset o s q{/l

iy cursor G

al
£ Sync Cursor il
5 10 5 20 5 30 35 0 s Tirne B [~ Show Cursor
................... A S R 2 d

— =i

Figure 4.11: Choosing quantities to plot

First and foremost, if more than one diagram is present in the Data window, one has to be
activated for editing. Only then quantities can be selected for plotting. Therefor, the desired
diagram is left-clicked once.

The quantities and reference quantity can either be chosen from a quantity list in the sidebar
or by using the Quantity browser. The Quantity browser can be opened by clicking and hold-
ing the X or Y buttons in the main menu. By clicking just once on the X/Y buttons in the top
menu, the quantity list on the sidebar swaps between usage for the vertical or horizontal
axis (see figure 4.11). The Search field applies a filter to the quantity list in the sidebar. The
filter can be unapplied by clicking on the red cross next to the entry field.

Quantities can be removed from the diagram by reselecting them in the previously men-
tioned lists (Quantity and Ref. Quantity), by undisplaying them in the Quantity browser using
the red cross sign or by double-clicking the quantity itself in the list on the right side of the
diagram.

The quantities displayed in IPGControl can also be referred to as User Accessible Quanti-
ties (UAQ). For an explanation of each UAQ available for plotting in IPGControl, please refer
to the Reference Manual, section User Accessible Quantities.

Using the main menu

Using the drop-down menu under Data Sources, the user can choose the source from
which the data should be displayed. This can be either the current simulation or a loaded
result file from previous simulations.

Furthermore, the sample rate of the data can be defined via Settings > Sampling rate.
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With the option Diagram > Add window, more Diagram windows can be added to the dis-
play.

| ile Diagram | Seftings Hel| @- -_I.. [X__ ﬂ‘.v &- @.
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Figure 4.12: Adding additional Diagram windows

The separate windows can each have the same or independent view settings and data
sources compared to the main window. The sidebar configuration, data sources and signal
selection is managed entirely independent of the main view.

With the option Diagram > Add/Delete Diagram you can add or remove a diagram in the
data window.
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Figure 4.13: Changing the sampling rate on a diagram with white diagram background

The background color of the diagrams can be changed from black (default) to white via Set-
tings > Diagram background > White.
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Functionalities of the Diagram Window
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Figure 4.14: Diagram Window functionalities

Functionalities for adapting the Diagram:

Right-clicking in the middle of the diagram > Fit options: Fits the selected curves (or all
of them, if no specific curve is selected) to the available space in the diagram in the
desired manner.

Pressing Shift + x or only x on the keyboard: Changes the scale of the x-axis.

Pressing Shift + y or only y: Changes the scale of all y-axes. To scale only one y-axis,
the desired curve needs to be selected first.

Pressing Ctrl +y or Ctrl + z: Zooms all y-axes

Left-clicking in the diagram + move the mouse: Moves the diagram along all diagram
axes

Pressing Shift + Mouse wheel: Zooms active y-axes (if no active axis: zoom all)
Pressing Ctrl + Mouse wheel: Zooms x-axis
Pressing Shift + Ctrl + Mouse wheel: Zoom all y-axes

Pressing the up and down keys: Shifts all y-axes simultaneously. To move only one y-
axis, the desired curve needs to be selected first.

Pressing shift and the up or down keys: Shifts all y-axes at a smaller step size. To move
only one y-axis, the desired curve needs to be selected first.

Pressing PageUp and PageDown: Shifts the x-axis.

Pressing Home or End: Jumps to the beginning / end of the plot.

Clicking left on a diagram: Activates the diagram.

Clicking left on a quantity name: Selects the quantity.

Clicking left on a y-axis: Selects the y-axis and all quantities attributed to it.

Pressing Ctrl and left-clicking on a y-axis or quantity name: Allows you to select multi-
ple quantities at the same time.

Pressing Ctrl + a: Selects all graphs
Pressing Ctrl + o/l:+/- Offsets the reference quantity

Pressing Ctrl + r: Reconnects/Reloads/Updates the selected data source (depending
on it’s type)
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« Clicking right: Opens a diagram/quantity related context menu.

» Clicking left on a quantity name, holding the mouse button, dragging the quantity
across the diagram and dropping it on another quantity of the same unit kind (mouse
cursor: |<-): Displays the quantity on the same y-axis as the quantity targeted on a y-
axis of the same unit kind.

» Clicking left on a quantity name that uses the same axis as another one, holding the
mouse button, dragging the quantity across the diagram and dropping it on a free area
in the diagram (mouse cursor: _|_): Displays the quantity on its own (new) y-axis.

« Double-left-clicking on a y-axis: Opens an axis parameters dialog window.
» Double-left-clicking on a quantity name: Undisplays the selected quantity.

» Right-clicking on a selected quantity > Colors / Unit: changes the color or the unit of the
selected quantity.

Exercise:

1.) Open the CarMaker GUI and load the TestRun  SteadyStateCircular42m :
CarMaker GUI > File > Open > Product Examples > Examples > VehicleDynamics >
Handling > SteadyStateCircular42m

2.) Perform the first simulation
CarMaker GUI > Start

3.) Open IPGControl. Add a diagram:
Main menu > Diagram > Add diagram

4.) Select the upper diagram:
Click once in the middle of the diagram

5.) In the selected diagram, select time for the x-axis and vehicle speed and wheel
speeds for the y-axis:

- Main menu > X Ref. quantity browser > Time

- Main menu > Y quantity browser > Car[S..Y] > Car.v

- Sidebar > Y Quantities> Search > write "WheelSpd" > pressing "Enter"

6.) Select the lower diagram:
Click once in the middle of the diagram

7.) Select lateral acceleration for the x-axis and steering angle for the y-axis:
- Sidebar > X Ref. Quantity > Car[A..G] > Car.ay
- Sidebar > Y Quantity > Steer > Steer.WhlAng

8.) Start the simulation again:
CarMaker GUI > Start

Now the curves are being plotted online, which means simultaneously to the simulation.
After the TestRun is complete, the diagrams can be scaled individually and the curves can
be moved around within the window. Try using two different axes for the wheel speeds.

Alternative Methods

In addition to IPGControl, CarMaker features an interface to other result management tools:
e.g. Excel and Matlab.
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Microsoft Excel

Result files can be saved directly as ASCII files. The data, separated by a tabulator, can be
easily imported to an Excel sheet.

Another possibility is to write the data plotted in a diagram directly to an Excel file using the
right mouse button in the diagram window and clicking Export to File. Excel file formats, as
well as ASClIs are available.

MathWorks MATLAB

After running a MATLAB script for CarMaker, a special command in Matlab (cmread) can
be used to load the content of the result file into a matrix.

Thus, the content of a result file can be directly read and plotted in Matlab.

Other formats

Besides the above mentioned output file formats ERG and ASCII, CarMaker can store the
simulation results directly in MDF format. This popular data exchange format is accepted
by many postprocessing tools.

Further information on post-processing CarMaker simulation results can be found in the
User’s Guide.
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Chapter 5
Creating Your First TestRun

This chapter will describe how to build an individual TestRun and have the possibility to
choose a preferred example, depending on the field of interest.

5.1 TestRun with Main Focus: Vehicle Dynamics
In this chapter an example of how to build up a mu-split braking test will be described.

5.1.1 Building a Road Network Using the Scenario Editor

In this chapter the user will learn how to build a road with a friction stripe.

Open the Scenario Editor: In top bar of the CarMaker main GUI, click on Parameters
> Scenario / Road .

Using the mouse, navigate to the Road section of the tab on the left side of the Sce-
nario Editor window. Click and hold the first icon called Road segment until a drop-
down menu opens. Select the Road segment type  Straight .
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Figure 5.1: Choosing the Straight segment option

Use the cursor to navigate into the design area of the Editor (the middle window) and
click once to define the starting point of the straight segment. The first point that is

set is also the origin of the global coordinate system. Hold shift and click again to
create a horizontal, straight road segment that is 1500m long.
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Figure 5.2: Implementing the Straight segment

Make the right lane wider: In the Road tab, select the Lane option and click the right
lane of the road that you just implemented. In the tab on the right side, change both
parameters Width at start and Width at end to 30m.

Delete the left lane by clicking on it while the Lane mode is still active and then click-
ing the red "X" in the top right corner of the tab on the right-hand side.
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Figure 5.3: Changing the lane width and deleting lanes

Add a friction stripe: Inthe  Road tab, left-click and hold the Bumps icon. In the drop-
down menu, select the option  Friction .

Click once on the Link (Straight road segment) to select it and then place two points
anywhere on the Link to define beginning and end of the friction stripe. Alter these
points in the tab on the right hand side so that the stripe starts 800m from Link start
and ends 1300m from Link start .

Set Lat. offset to -15m from Center of the road and make the stripe  10m wide . The
friction coefficient should be 0.5.

See the settings and what the stripe looks like in the figure below. Edit the Road road
marking, if you wish.
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15 [Reference Line o
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Ty axis
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Figure 5.4: Adding a friction stripe
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Now, in order for the vehicle to be able to drive on the road, a route is necessary.

Since this is a single lane on the right side of the road, the vehicle will drive along

the center, as long as the Driving side is Right-hand traffic . You can check the active
driving side by clicking on the gear icon in the top bar of the Scenario Editor and hav-

ing a look at the specification.  Left-hand traffic will work just fine, too. Just remember
that the driving side can only be changed prior to the road being built.

Add a Route to the road: In the toolbar on the left side of the Editor, in the Traffic tab,
select the Route icon. Using the cursor, click once on the predefined Path tha t's
marked in green to select it and click again to confirm that you want to start gener-

ating the Route on this Path. It will become highlighted in or ange. Since we don't
want to select further Paths, double-click anywhere outsid e of the road to end the
Route definition.

Hint: To simplify the selection of the predefined Path, it is useful to zoom up the road.

Now the road is complete. If you need to, open the solution in the product examples to be
able to move on. The TestRun including the solution Stepl_Scenario can be found in Prod-
uct Examples > Examples > VehicleDynamics > _QuickStartGuide.

Defining the Maneuver

For this type of driving experiment, the vehicle first needs to accelerate to a specific speed
and then brake as soon as it reaches the friction stripe. Then, while braking, the two left
wheels will be on the more slippery side of the road and the two right wheels will be on the
side of the road with more grip.

This means that two maneuver steps are required which both also need an end condition.

Define the first maneuver step  Accelerating : In the CarMaker main GUI, open Param-
eters > Maneuver and highlight the last line in the list ( END) by clicking on it. Now
select New to insert a maneuver step.

Write "Accelerating” in the  Description , change the Duration to 999s (to make sure
the maneuver runs long enough) and give it a proper End condition :

Car.Road.sRoad >= 800

| o CarMaker - Maneuver

Maneuver Close
Mo Start Dur Long Lat LabellDescription — Specification of M Step
==== Glohal Settings / Preparation ==== = | Label [

Arcelarati I
Accelerating Description \Accelerating

1 999.0 ==== END ==== e T
End Condition \Car.Road.sRoad == 800
Durafion (timefdisy | 999 s | m ist
— Longitudinal Dynamics — Lateral Dynamics
&/ IPGDriver &/ IPGDriver
Speed Tkmih] | Track Offset [m | ]
v Manual Gear Shifting
[~ Manumatic

(optional, overrides
global driver parameter)

Figure 5.5: Defining the accelerating maneuver step
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The end condition is in what is called Realtime Expressions. The end condition is depen-
dent of the value of a specific quantity. In this case the quantity is Car.Road.sRoad which
represents the vehicle’s road coordinate. That means the s-coordinate of the vehicle’s cur-
rent position.

Since the friction stripe on the previously built road begins at 800m from Link start, the driv-
er should stop accelerating at this point and start braking. That's why the first maneuver
step ends here.

Define the second maneuver step
again by clicking on it. Now select
first one.

Braking : highlight the last line in the list (  END)
New to insert a second maneuver step below the

Note that new maneuver steps are always inserted above the highlighted row in the
list of maneuver steps.

Call this maneuver step "Braking", change the Duration to 999s and the End condi-

tion to:
Car.v <= 0.001

Furthermore: Selectthe Longitudinal Dynamics option Manual and set the values of
Brake and Clutch to 1.
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Figure 5.6: Defining the braking maneuver step

The end condition that is implemented here means that when the vehicle speed becomes
lower than 0.001 m/s, the maneuver step is over and since this is the last step, the simula-
tion will accordingly come to an end.

For the solution to the exercises up until now, open the TestRun Step2_Maneuver that can
be found via Product Examples > Examples > VehicleDynamics > _QuickStartGuide.

Selecting a Vehicle and Simulating

The only relevant component that is still missing for the Testrun to be sufficiently parame-
terized is a vehicle. CarMaker offers a wide variety of example vehicles that can be selected
in the product examples.
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Select a vehicle: In the Carmaker main GUI, left-click on

Car.

In the browser that opens, navigate to the Product Examples a

DemoCar.
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Figure 5.7: Selecting the CarMaker DemoCar

Now that the road is defined, a maneuver has been implemented that instructs the driver to
accelerate until he reaches the friction stripe and then brake and a vehicle has been select-
ed, the TestRun is complete and the simulation can be started.

Start the simulation: Click on the green

To watch an animation of the simulation, open

> File > IPGMovie.

Start button in the CarMaker GUI.

IPGMovie via the CarMaker main GUI
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Figure 5.8: Animation of the mu-split braking test in IPGMovie

For the solution to the exercises up until now, open the TestRun Step3_Vehicle that can be
found via Product Examples > Examples > VehicleDynamics > _QuickStartGuide. Alterna-
tively, you can also have a look at the TestRun Step4_VehicleDynamics which is basically
the same as Step3_Vehicle, but contains a few 3D objects for beautification of the scenario.

5.1.4  Saving Your TestRun

Save the TestRun, so that you can retrieve your work: In the CarMaker GUI, click on
File > Save as and choose Project on the left bar in the dialog. With right-click, create
a new folder "My_TestRuns". Double-click on the new folder and enter any name for
the TestRun, e.g. My_TestRun_VehicleDynamics > OK

| CarMaker - Browser.

Load TestRun

@@—Q My_TestRuns/My_TestRun_VehicleDynamics v ok |

1 Name ©
’ & Project [DataiTestRun] Gancel
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Figure 5.9: Saving the TestRun
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5.2 TestRun with Main Focus: ADAS

The following example will demonstrate how to implement an autonomous emergency brak-
ing (AEB) TestRun. This example may be more interesting for users with an interest in
ADAS applications.

5.2.1 Building a Road Network Using the Scenario Editor

In this chapter you will build a T-junction using the Scenario Editor.

Open the Scenario Editor via the CarMaker main GUI: Left-click Parameters > Scenar-
io / Road or use the shortcut crtl +r.

Add road segments: Inthe Road tab on the left hand side, left-click once on the first
icon Road segment in the Road tab and then right-click in the drawing area of the
Scenario Editor to open a small drop-down menu. Left-click once on Road segment
to open up another drop-down menu with all the options for road segments.

Left-click to choose Junction.
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Figure 5.10: Selecting the road type Junction
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Implement the Junction: Using the cursor, left-click once in the drawing area to set

the middle of the junction.
Note that the first point you define in the Scenario Editor also initializes the XV,Z -
coordinate system and is set with the values (0,0,0).

Move the cursor to the left and holding  shift (shift makes the cursor lock on to spe-
cific values) click again to create the first junction arm at an angle of 180 ° with a
length of 10m.

Now move the cursor to the right and, holding shift, click to implement the second
junction arm with a length of 10m, at an angle of 0  °

Finally, move the cursor to the bottom and hold shift. When the cursor is at the right
spot to define the last junction arm with a length of 10m, at an angle of 270 °, double-
click to finish building a junction with the last arm.
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Figure 5.11: Implementing the Junction
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Add a road to the first Junction arm: Click and hold the Road segment icon in the
Road tab on the left hand side. In the drop-down menu, select the Road segment type
Straight .

Move the cursor to the end of the first junction arm (Junction arm 0) and hover over

the middle until an orange circle appears and the cursor lock s onto the reference
line. Left-click once to start drawing the straight segment here, move the cursor to

the left and click again to implement the straight. In the tab on the right hand side you

can edit the Length of this straight segment.

Set the length of this straight segment to 500m.
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Figure 5.12: Adding a Straight to Junction arm 0

Analogously, add the other two Junction arms: Both on the right side and to the bot-
tom, add a straight segment with a length of 500m (right) and 300m (bottom).

The road network should now look like in the figure below.
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Figure 5.13: Finished T-junction

In order for the vehicle to know in which order he is to drive on the links, a route must be
defined.
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Click on the Route icon on the bottom left hand side of the Scenario editor.

Route_0: Click on the predefined path on the right lane of Link 1 (as labelled in the
figure below) to select this path. As soon as a broken, orange line appears, click
again to confirm that this is the correct path on which to begin the route definition.

Now, click on the path that goes directly across the junction and then the one going
straight forward on Link 2 to extend the Route by these two paths. To finish imple-
menting the Route, double click somewhere on the Link.

Route_1: First, select the path on the right lane of Link 3 and confirm as previously
described, then select the path that takes a left turn over the junction to extend the
Route. Lastly add the path segment on the left lane of Link 1. Double click to finish.
Now the Route comes from below and makes a left turn at the junction.
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Figure 5.14: Finished Route

Within the Scenario Editor the user has the possibility to generate Terrain for his road net-
work. The terrain’s height profile is generated randomly by CarMaker and cannot be indi-
vidualized by the user, only a minimum and maximum height value can be defined.
Furthermore, the user can select a geometry file (.obj file) for the terrain’s surface that is
chosen after generation in the tab on the right hand side. If no file is selected in this field,
the CarMaker default image is used. Terrain is added using the Terrain Generator.
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Generate terrain: Click on the icon labelled  Terrain generation in the Scenery tab on
the left hand side of the Scenario Editor and click Generate in the tab on the right
side.
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Figure 5.15: Terrain Generator of the Scenario Editor

5.2.2 Defining a Maneuver

After configuration of the road, a test car can be selected.

Select a vehicle: In the Carmaker main GUI, left-click on Select in the field labelled
Car.

In the browser that opens, navigate to the  Product Examples and choose the
DemoCar.

Now a maneuver needs to be defined to tell the driver how to handle the vehicle.

Open the Maneuver Dialog via the CarMaker main GUI > Parameters > Maneuver or
by using the shortcut  crtl + m.

Add a new maneuver step to the list of maneuvers (that is still empty at the moment)
and change the Duration to 60s. The duration of the maneuver step can be altered on
the right side by editing the entry in the field labelled Duration.

In the field labelled Longitudinal dynamics , make sure that IPGDriver is the active
option and change the Speed to 70km/h.
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Figure 5.16: New maneuver step

Additionally, by clicking the item at the very top of the maneuver list Global Settings / Prep-
aration the user can define various start values and additional commands.

Click on Global Settings / Preparation , setthe Start value Velocity to 70 km/h and the
gear that is to be active at the beginning of the simulation to the 5th gear.

Ci {RTexpr)

o | CarMaker - Maneuver — Ox
Maneuver Close
— Start Values
! | Velocity [kmin] | 70 SteerAngle  [deg]| 0
000 &0 70
1 600 ====END==== Gear | 5 TrackOffset  [m]| 0
Wehicle Operator g IPG Operator v active
Operator State #| drive
Global Settings
(S:HptComro\ File | @ |

¥
] New | =3 Copy | [ Paste | 5 Delete | =3 Import

Figure 5.17: Maneuver Global Settings / Preparation

Now the road, a vehicle and maneuver are defined, the TestRun can be started.
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Start the simulation: Select Route_0 as Active Route (Route on which the vehicle will
drive) by clicking on  Scenario Settings in top menu, then Vehicle start position >
Active route . In the CarMaker main GUI, press the green  Start button.

Open IPGMovie to observe the simulation.

5.2.3 Adding Traffic

Now a traffic object will be included in the simulation to show how the object detection in
CarMaker works. This is necessary for the AEB system to become active. There is a very
wide variety of available traffic objects and possible functions and maneuvers which are
described in further detail in the User's Guide in the Traffic chapter. The following example
will demonstrate only one possibility to integrate a traffic object.

Open the Traffic dialog: CarMaker main GUI > Parameters > Traffic and click on New
to insert a new traffic object. Per default, this object is called TOO.

Set the Start position (s and t coordinates)  to 285m and Om on Route 1 (the Route
that takes the left turn).

\_w CarMaker - Traffic

Traffic 3D Preview Close
Mo Name Movie Geometry Description Dimension | xwx R Start Position
VW_Beetle_2012_Blue.mohj Traffic Object ] 8 8 ] ) New
r ] Cu;ﬂ
[T Paste
¢ Delete ‘
i es
— & Import
¥
_ Traffic Object T00 +* ¥
General Parameters | Motion Model I Maneuver I Autonomous Briving | Channelin FI\E‘
Object mode / Traffic object class gMovable ohject X/ Car
Mame
Movie geametry + Object parameters mali Q
Box color RGB
Description fTraﬂ‘\c O_bjé'ct o
Attributes |
Detectable by ¥ Bensors v Autonomous traffic
Radar cross section #|car RCS Maps |
Dimension length x width x height [m] | -i."z"si 182 i"_'w"ﬁ'i's I~ 2D Contour ;"J
Orientation x/y/z [deg] [ 00| 00 0.0
Basic offsetx/z [m] | 0.9,
Center of mass x [m] [ 215
Path mode #|Route path
Route name [ "I Use reference line Speed unit
Start position s/t [m] rz's'ﬁfbh_ib_.é I~ kmih
& mis
— Input from File
Input filz | M Time channel |

Figure 5.18: Traffic object configuration (1)
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Add two maneuvers to the traffic object:

1. Duration -> Time 300 s and long. Motion

-> Velocity 0 km/h, End Condition

Car.Road.s2nextJunc < 60 (See maneuver step 1 definition in the figure on the top).

2. Duration ->Time 5 s and long. Motion -> Acceleration 3 m/s"2 (See maneuver step
2 definition in the figure on the bottom).

Now, in the Global Setting / Start Conditions

for this Traffic object, set

to freeze velocity.

Action at end

CarMaker Quick Start Guide

| CarMaker - Traffic

3D Preview. Close

Traffic

Mo Name Mavie Geometry Description Dimension | xwx h  Start Position
VW_Bestle_2012_Blue.maohj Traffic Objec 2 8 22 5 [y

— Traffic Object T00

General Parameters | Motion Model I MlﬂEINEf] Autonomous Briving ] Channelin File

Update rate \ iﬁ'u"-g Hz T Velocity dependent
Lat Sup Hidden

+ Maneuver  Free Motion

Start Long Long Sup Lat

=== G|obal Settings / Start Conditions ===

A

1 Paste
Delete
N

L4
-

Duration X|Time 300 s | Hidden

Longitudinal motion g\/e_lumy Velocity 0 mis

Lateral motion E3) |

Long. superimposed g 0g 1 & it

eed uni

Lat supefimposed ¥/ 0.0 0a : s
End condition ‘ |Car.Road s2nextJunc = 60 ‘ & mis

— Input from File

Input file | i 1| Time channel |

| CarMaker - Traffic - %

Traffic 3D Preview. Close
Mo Name Movie Geometry Description

Dimension | xwxh  Start Pasition
VW_Bestle_2012_Blue.maohj Compact car 4.28 8 .28 2 C Al = New
=3 Copy
[T Paste
¢ Delete ‘
Pl

{5 Import

i e

i

»
.

— Traffic Object T00

General Parameters | Motion Model I MlﬂEINEf] Autonomous Briving ] Channelin File

‘= Maneuver  Free Motion Update rate \ iﬁ'u"-g Hz T Velocity dependent
Start Long Long Sup Lat Lat Sup Hidden
=== Global Seftings / Start Conditions === L 9 New
=300 V=0 0 !
2 Copy
2y Paste
% Delete
S 4
Duration &|Time [ 5s [ Hiddan
Longitudinal motion gn::aleratmn Acceleration 3 mis®
Lateral motion * T
Long. superimposed g 0g 1 & it
peed uni
Lat d X () oa
al superimpose * e
End condition | i
— Input from File
Input file | @ Time channel |

Figure 5.19: Traffic object configuration (2)
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The driver will consider the traffic object by default. For the AEB test, IPGDriver should not
consider any traffic objects.

Turn off the traffic consideration: deselect the Consider Traffic checkbox inthe Main-
GUI > Parameters > Driver > Traffic interface

_W CarMaker - Driver

Driver Presets Close

Mode: & User parameterized Driver  ( Racing Driver

Standard Parameters | Trafﬁc} Race Driver | Misc./ Additional Parameters ‘

| Consider Traffic

— Following Leading Vehicle —

1

Figure 5.20: Driver parameter Consider Traffic

Start the TestRun and observe the animation in IPGMovie.

Collision Detection

In this step, an automatic collision detection system is added to the simulation. For this,
modifications need to be made to the vehicle, as well as the maneuver.

Activate the option General in MainGUI > Parameters > Car > Sensors > Collision.

By default the collision detection uses the Vehicle Bounding Box, defined in MainGUI >
Parameters > Car > Body > Outer Shell. If a outer shell with more detail is necessary, 2D
Contour can be selected.

Furthermore, the collision detection also needs to be defined within the Maneuver.

In the Maneuver dialog, click on the defined maneuver  Maneuver Step 0 . On the right
side, in the field labelled End Condition , type: Sensor.Collision.Vhcl.Frl.Count >=1

For notification that a collision has taken place, a log message can be delivered. If the
detection counter is greater or equal to 1, the maneuver control will continue to produce the
error log. In order to do so, the following Real Time Expression needs to be added to the
Minimaneuver Commands dialog:

Eval (Sensor.Collision.Vhcl.Fr1.Count>0) ? LogErr ("Collision detected!")

The function LogErr will stop the simulation and print "Collision detected!" to the session
log.
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. CarMaker - Vehicle Data Set: Examples/DemoCar_SensorCollision

Vehicle Data Set File w closs |

Assammy] Bndyl suspansmns} Steering ‘ Tires | Erake] Powertrain ‘Sensnrs‘ Vehitle Control }Aunmnnaﬂ

Slip Angle Collision Sensor |Zf
PG 1
Inertial
I~ Detection vehicle wheels
Object Envelops Mode &) 2D Contour
Free Space Ximl|  ¥[mi[" ¥ Goordinate [m]
- 00 0.0 —J il
Traffic Sign il iEl
Line 0.1 a7
03] L2 =
Road 06| 09

5 1.3 [} ; ; y . ; . ; % Courdnate ]
Object 27 o085 i
by Lang 2.75 09

04
Global 375 04
_ Navigation | 428 045
Radar 4.28| 00 R
B m—
Camera 2 = —
v Mirroring Basic offsetx/z [m] [ 0.0 0.2
Radar RSI Contour height (m] [ 1.28
Ultrasonic
RSl
Lidar RSI
Camera RSI
| CarMaker - Maneuver — 00X
Maneuver Closs
MNo  Start Dur Long Lat LabeliDescription i ion of M Step
= Glohal Settings / Preparation ==== 2 | Label I
1 B0.0 — = END === Description
End Condition Sensar.Callision.Vhel Fr1.Count>=1 f |
Duration timeldist) B0 s ‘ m tljust
—L itudinal Dy i — Lateral [
X/ IPGDriver X/ IPGDriver
Speed Temih] | 70 Track Offsst [m]| o
v Manual Gear Shifting
[~ Manumatic

(optional, overrides
global driver parameter)

Driver Parameter... Driver Parameter. .

— Mini C
iEval (Sensor.Collision, Vhcl.Frl.Count=0) ? LogErr ("Collision detected!")y

] Mew | 43 Copy | (4 Paste | 9% Delete | =3 Import ‘ ‘

Figure 5.21: Implementing the collision detection

5.2.5 Setting up an AEB System

Currently you are using the CarMaker DemoCar. This vehicle is often chosen for simple
examples when no extended features are required. For specific testing scenarios a different
vehicle can be used or the DemoCar needs to be adjusted.

For the AEB experiment an AEB system is required. Since the DemoCar isn’'t equipped with
one of these, the following exercises will demonstrate how to add a sensor and controller to
the vehicle to emulate an AEB system.

Define a sensor for the longitudinal control of the vehicle: CarMaker main GUI >
Parameters > Car > Sensors > Object

Click on Add to add an object-sensor and name it  Radar. Edit the rest of the sensor
parameters so they match those in the figure below.
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em CarMaker - Vehicle Data Set: Examples/DemoCar AEB

Vehicle Data Set File v | close |
ﬂ\ssembl\rl Bod\r] Suspensions] Steering] Tires] Brake] Powertrain ] Sensors | Yehicle Control ] Additional]
slip Angle | Object Sensors L4
~— | rListof S s
Inertial e
i Sensor.Object. [Radar
e i
Free Space
Traffic Sign
Line
Road
i
Collision
e Add Delete
Object
by Lane
Global — All Object Sensors — Radar
Navigation Observation radius [m]| 500.0 Positionx/y/z [m] [ 38 0.0 0.8
Radar Orientation x/y/z [deg] | 0.0 0.0
Field of view h /v [deg] [ 10 10.0 (max 180)
Camera Range min / max [m] 50
Update [Hz] - Cycle offset [- 252 i}
Radar RSI ey L =l
Target selection g Mearest
Uﬂr;;ll:lmc Calculation class &| NearestPaint
Visualization color *| Blue
Lidar RSI o R
Body mounting F Fr1A
Camera RSI [ External sensor motion [~ Traffic object quantities

Figure 5.22: Definition of the Object sensor named "Radar"

Implement a controller:  CarMaker main GUI > Parameters > Car > Vehicle Control

For Control Model 0 , select Generic Longitudinal Control  and set the Referenced
ObjectSensor to Radar (the object sensor created before).

Fill in the other parameters according to the figure below.

em CarMaker - Vehicle Data Set: Examples/DemoCar AEB

Vehicle Data Set File w Close |
ﬂ\ssembl\rl Bod\r] Suspensions] Steering] Tires] Brake] Powertrain ] Sensors] Vehicle (:ontrol} Additional]
Control :
Model 0 Control 0 embiedded Mods) W
Model g Generic Longitudinal Control Edif
Control
Model 1 [w Autonomous emergency braking
Control Referenced object sensor Radar .
Model 2 Maximal deceleration [m/s?] 6.0
Control Acceleration controller factor P [-] . 0(391
Model 3 Acceleration controller factor | [-] | 30
Minimal distance [m] [ 50
Control : t , 1 e
Model 4 Time braking after standstill [s] | 50
S TR Time brake reacts [s] | 0.2
Control
Model 5 v Forward collision warning
Control Time first warning level [s] | 2.0
Model 6 Time second warning level [s] | 1.0

Figure 5.23: Controller for longitudinal vehicle control
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The last step is to extend the maneuver end condition by another option. The aim is to stop
the simulation if a collision is detected or the car brakes to stand still.

The extension for the end condition is the command:

Sensor.Collision.Vhcl.Fr1.Count>=1 || Car.v < 0.01

Start the simulation and observe the function of the AEB system at the intersection.

Using NamedValues

In this step, NamedValues are introduced. These allow the user to carry out variations of
the TestRun using different parameter sets.

The first NamedValue will be set in the IPGDriver maneuver control. NamedValues can be
used for parameter variations, but at first, they need to be given a default value. In this case
the IPG Driver Target Velocity will be defined by a NamedValue.

Open the Maneuver dialog and click on maneuver Step O . In the Longitudinal Dynam-
ics field, change the entry for the  Speed to $Speed=70.

Now the Quantity for the IPGDriver’s Target Speed has been named "Speed" and has been
preset to 70 km/h. Now, also the traffic object’s end condition will be adapted.

In the Traffic GUI, change the end condition of the traffic object’s first maneuver to
Car.Road.s2nextJunc<$JunctionDistance=60

$JunctionDistance is a NamedValue with a default value of 60. The value of $JunctionDis-
tance determines the distance of the test car to the intersection at which the traffic object
begins driving onto the intersection.

| CarMaker - Maneuver

Maneuver Closs
e ol S LR rge LRl T = i oL M Ll
| ==== Global Settings / Preparation ==== I: Lahel |
S Description [
1 600 ==== END==== i ! I
End Condition |Sensar.Collision Vhel. Fr1.Count>=1
Duration (time/dist) | B0 s ‘ m I
—L itudinal Dy i — Lateral Dy
X/ IPGDriver X/ IPGDriver
|| | Track Offset m]| 0
[~ Manumatic
(optional, overrides
global driver parameter)
Driver Parameter.. Driver Parameter.. ‘

=
;IEval (Sensor.Collision. Vhel.Frl.Count=0) ? LogErr (C’j

|ollision detected!")

7 MNew | =3 Copy | [ Paste | 9% Delete | =3 Import ‘ |

Figure 5.24: TestRun modification using NamedValues (1)
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| CarMaker - Traffic

Traffic 3D Preview Clo

VW_Beetle_2012_Blue.mohj Traffic Object % 0-1.5

‘= Maneuver  Free Motion Update rate | 55-0-'-;7 Hz T Velocity dependent
Start Long Long Sup Lat Lat Sup Hidden

=== G|obal Settings / Start Conditions ===

Duration X|Time 300 s | Hidden

%

se

Longitudinal motion g\/e_lumv Velocity 0 mis

Lateral motion *

Long. superimposed g 0.0 il 5 it

peed uni

Lat superimposed &/ 0.0 0,0 e
End condition |Car.Road s2nextJunc < $JunctionDistance=60 | & mis

— Input from File

Input file | i 1| Time channel |

Figure 5.25: TestRun modification using NamedValues (2)

Additionally, the horizontal aperture of the object sensor is set to another NamedVal-
ue $RadarHoriz=10 , as shown in the figure below. This will allow the user to vary the

detection area.

Save the vehicle via File > Save in the Vehicle Data Set Editor and then save the
TestRun via File > Save in the CarMaker main window.
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| CarMaker - Vehicle Data Set: Examples/DemoCar_ AEB

Vehicle Data Set Fil w Closs |

Assemb\v} Budy] Su.ﬁpensmns] Sleermg]T\ras] Erake] Powertrain l SE!"!WTS| Vehicle Control ] Admlmna\]

siipAngle | Object Sensors
| [ Listof Sensors
rtial ETrE—
Inartis Sensor.Object. [Radar
Free Space
Traffic Sign
Line
Road
——t i
Collision
R Add Delete
Object
by Lane
Global — All Object Sensors — Radar
Navigation Obsevation radius [m]| 500.0 Positionxfy fz[m] 38 0.0] 08
Radar Orientation x/y/z [deq] 0.0 0.0 \ 0.0
— 1 Field of view hiv [deg] F$RadarHo 10.0 (max 180) |
Camera Range min/ max [m] a0
Update [H2] - Cycle offsetl] | 253 0
Radar RSI
b = Target selection g MNearest
Um;:.‘l’"'c Calculation class #| NearestPaint
e Visualization calor #| Blue
o Body mounting gfﬁm\
Camera RSI | External sensor motion [~ Traffic object guantities

Figure 5.26: TestRun modification using NamedValues (3)
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Executing Multiple TestRun Variations using the
TestManager

In this last step, the user will create multiple variations of the driving experiment using the
NamedValues that were defined in the previous chapter.

Open the Test Manager: CarMaker main GUI > Simulation > Test Manager and add a
TestRun to the TestSeries by left-clicking Add > TestRun . Select the TestRun that
you've built up until now by clicking on the folder icon right of the file labelled
TestRun . This opens a browser where you can navigate to the according TestRun file.

The figure below shows how to add parameters (Step 1) to a variation using the type:
NamedValue (NValue) and how to create the variation itself (Step 2) by clicking on Add >
Variation.

I w CarMaker - Test Manager

Test Manager Execution mode; #| Sequential 2 | Clase |
ltem Description | Par1| Par2 | Par3 | Par4 | Res.Date [Result [  Fiz
-4, Global Settings
£ ... /Step5_SetupNamedValues Speed JunctionDisi Radartbriz M
=@ Criteria
-B Collision Detection
" Variation 0 (T 5
- b Variation 1 70 60 10
o b Variation 2 70 65 5
| b Variation 3 70 65 10
b Variation 4 80 60 10 Q Add =
| b Variation & a0 60 30 :
b Variation 6 80 65 10 @
| » variation 7 80 65 30 Copy |
] > Delete |
— TestRun Descyjption
TestRun = | Variation 0 o
a
Parameters Type |Narne Value 1_ x
NValue ~ Speed |70 -
MYalue = JunctionDistance 60 op =
MNValue +RadarHoriz vl
5 || | Report

Figure 5.27: Variation with TestManager (1)

Furthermore, a condition for successful completion of the TestRun is added. For this, select
the TestRun and then go to Add > Criteria. A successful completion good is defined on the
tab Evaluation by the condition stated below.

[get Sensor.Collision.Vhcl.Frl.Count] < 1

In this statement, the function get is used to access a CarMaker quantitiy.
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I?M CarMaker - Test Manager

Test Manager Execution mode; #| Sequential 2 | Clase |
| tem Description | Par1|  Par2| Par3|  Par4|ResDate|Result|" iz w
-4, Global Settings
£ ... /Step5_SetupNamedValues Speed JunctionDisi Radartbriz M
e-@ Criteria
@ collisian Deteetion

- Wariation 0 70 60 5
- b Variation 1 70 60 10
- Wariation 2 70 65 §
- b Variation 3 70 65 10
- b Variation 4 80 60 10 @ Add w
- b Variation § 80 60 30
- Variation 6 80 65 10 @
L p Variation 7 a0 65 30 Copy

e |

= Delete

Criterion ] Evaluation ]

Evaluation Result Congition | i

@ good [oet Sensor.CollisionVhel.Fri.Count] < 1

7
-]
=

op

e

Report

Figure 5.28: Variation with TestManager (2)

In the variations created, the NamedValues previously defined in the TestRun can be mod-
ified. Here, the test vehicle’s speed, the triggering condition for the traffic object to enter the
intersection and the horizontal aperture of the sensor are varied.

TestRun with Main Focus: Powerirain

This chapter explains how to build a 48V P1 and P2 hybrid and how to compare their fuel
consumption on an RDE track.

Creating the 48V Hybrid P1

This chapter shows, how to create a 48V P1 hybrid out of a conventional vehicle, in this
case: the DemoCar.

Load the DemoCar: Main GUI > Car > Select, Select ProductExamples > Examples >
DemoCar.

Change the powertrain layout from conventional to P1 hybrid . Parameters > Car >
Powertrain . Right-click anywhere in the window and select Parallel Hybrid -> P1 ->
Automated Manual Transmission

We want to keep the conventional engine and just add a stronger starter generator.
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Go to Drive Source and select Starter Motor . The Ratio is set in the General tab,
change it to 1 (directly on the crank shaft).

Change the Mechanical power to 12 kW in the tab labelled Torque, the Maximum
torque to 130 Nm and the Maximum rot. speed to 8000 rpm.

Iz CarMaker - Vehicle Data Set: Examples/DemoCar

Vehicle Data Set File w Close |

.ﬂ\ssembl\rl Bod\r| Suspensions] Steering | Tires | Brake] Powertrain | Sensors | Yehicle Control ] Additional]

Powertrain Sl e Model w |L,r
Model ®| Parallel Hybrid BT

General Engine ;
General " Torque" Efficlancy |

Motor srilkadded | Model ' w

Clutch ‘ Gearbox

Driveline
Model &| Starter
:::“:I; ilenlkams] | 0'001_ Fowertrain: Parallel Hybrid
I e ) Ratio [-] 1
cﬁ?.,ti;o' i pma-ts] el RL [ Powertrain Conirol | FL
Friction coeffigient [Nmaiad 1. 0e=d Sro E@u MQU i

oltage level:

+ Low Voltage
" High Voltage 1
" High Voltage 2

RR

Driveline: Front drive

Figure 5.29: Parameterizing the Starter Motor

After defining the hardware of the drive sources, we adapt the control strategy. Since we
have higher torque using the electric motor, we have to change the gas pedal-to-torque con-
verter. The maximum torque at full gas should now be 315 Nm (185 Nm from the combus-
tion engine and 130 Nm from the electric motor).
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Click on Control Unit , then PT Control and in the tab labelled Gas, change the Max
torque at full gas to 315 Nm.

o] CarMaker - Vehicle Data Set: Examples/DemoCar

Vehicle Data Set File w | Close

!\ssemblv| Bod\r] Suspensionsl Steering] Tires] Brake | Powenrainl Sensors | Vehicle Control | Additional |

Powertrain ledied Model w IZ'
Mode| ®| Parallel Hybrid

General ECU ‘ TCU ‘ Mcu ‘ BCU

52?::9 General " Gas " Battery

| StartiStop " Coasting " Assistapce | Regensration " Elgctrie Driving

Mode: ®| Characteristic Value

Driveline

Max. torque at full gas [Nm] | 350
Power Min: torque atzero gas [Nm] | -10.0
Supply

Control
Unit

Figure 5.30: Parameterizing PTControl

The created vehicle has an automatic transmission. For realistic shifting behavior, we must
adapt a few values.

Go to the TCU tab and then to Shifting Limit s. Change the Shifting Limits from 1D
Look-Up Table to 2D Lookup Table so that the gas pedal position influences the shift-
ing strategy.

Now the minimum rotation speed for gears 4 and 5 at 0% gas pedal position are too high,
resulting in oscillating shifting at some velocities so we must change the values for gears 4
and 5 at 0% gas pedal position.

Change the Rot. Speed Min values for gears 4 and 5 at 0.0 Throttle to 1250 rpm.

For a 48 V hybrid vehicle we must change the size and voltage of the high voltage battery.
The electric converter of the vehicle should have 3 kW.

Click onthe Power Supply tab and under General, clickon Converter HV1 LV . Change
the Max. converter power to 3 kW.

The battery itself is parameterized under the  HV Battery tab. Change the Capacity to
10 Ah and the Idle voltage to 48 V. The Maximum power should be 14 kW.

The last step is allowing the brakes to regenerate. This is done in the Brake tab. Click
on the Brake tab, goto Control and setthe Regenerative Brake Mode to Serial.
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'w CarMaker - Vehicle Data Set: Examples/DemoCar

Vehicle Data Set File w Close |
.ﬂ\ssembl\rl Bod\rl| Suspensions] Steeringl| Tiresl| Brake] Powertrain | Sensors | Yehicle Control l Additional]
Powertrain beided Model w Q
Model ®| Parallel Hybrid Edit
LV
General General ‘ Battery ‘
Drive General " Bodies|
Source
Battery Model: ¥/| Chen Edif
Driveline i e e Q
Capacity [Ah] 10.0 Resistance RO [Qhm] ! 0.0012
Power ldle voltage [V] 48.0 Resistance R1 [Ohm] | 0.0004
Supply Initial state of charge [%] 70.0 Resistance R2 [0hm] | 0.0011
Control Minimum state of charge [%] 20.0 Capacity C1 [F] | 40740
Unit Maximum state of charge [%] 80.0 Capacity C2[F] | 820000
[~ State of charge influence to idle voltage
SOC [%]| Factor ][ | Facter []
000 |2 |
0.6
0.2
, Sec
; ’ il =TI n_l_ T 4 a0 B0 00
amplification | 10| 02
Battery Power: g Characteristic Value
Maximum power [kKW] 14.0 Vx| eutrEt Al L0
Figure 5.31: Parameterizing the HV Battery
Now a P1 48V hybrid has been created out of a conventional vehicle. Save it via File

> Save As > DemoCar_48V_P1.

Importing the Road

As we have already created our vehicle, we now need a road. For this, the RDE track which
is already included in CarMaker will be used. Alternatively, the user can import his own
roads, e.g. by using *.kml data or other sources. Nevertheless, to keep it simple, one of the
Product Examples will be used.

Open the Scenario Editor via Parameters > Scenario / Road in the CarMaker main
GUL.

Insert a Road segment Type File by clicking and holding Road segment in the Road
tab and choosing File. Now, click anywhere in the drawing area to set the first point.
This point also becomes the origin for the X, y, z coordinate system.

After confirming the direction vector with a second click (the direction doesn't play
a role in this example) a browser opens where you can select the file Product Exam-
ples/Examples/'IPG_RDE_KA_Route.bin".
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Figure 5.32: Adding a Road segment type File

By pressing OK the route is imported. We have the road now, but we have to define a route
where the vehicle should drive, too. A further (optional) step is connecting the road’s ends
to turn it into a closed loop circuit. This way the vehicle will continue driving in the loop until
the maneuver comes to an end. Otherwise, the simulation is aborted as soon as the vehicle
reaches the end of the road. In this case the user may receive an error notifying that the
vehicle has left the road.

Optional: Select the Connect Road segment type and connect the open ends of the
road to generate a closed loop circuit.
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Select the Route symbol in the Traffic tab: Click on the predefined Path on the right
lane of the Link. When a broken, orange line appears, click again to confirm that this

is the Path we want to drive on. To finish implementing the Route double-click any-
where close to the Link.

o CarMaker - Scenario Editor
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Figure 5.33: Adding a Route

Now the vehicle, road and route are finished. In order for the TestRun to be complete, a
maneuver, that tells the driver which actions to proceed, is still missing.

Save the TestRun as PT_QuickStartGuide_BasicRoad.

5.3.3 Maneuver and Driver Parameters

In this example, a simple maneuver will be created where the driver model - IPGDriver -
controls the vehicle in both longitudinal and lateral direction.

Open the Maneuver GUI via Parameters > Maneuver and click on New to add a new
Maneuver Step. The default maneuver step that is added is sufficient for our exam-

ple.

Give the driver a defensive characteristic: In the Maneuver GUI, click on Driver
Parameter. Alternatively you can click on  Parameters > Driver in the main GUI. Right-

click anywhere in the Driver GUI and choose  Parameter Set "defensive” to select the
preset for a defensive driver.
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| CarMaker - Maneuver

Maneuver Close

Mo Stat  Dur Long Lat  LabeliDescription — Specification of M Step
==== Glohal Settings / Preparation ==== | Lakel |

Description
End Condition
Duration {timeldist) | 300 s | m

1 30.0 ==== END ====
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&/ IPGDriver | IPGDriver

Speed Tkmih] Track Offset i | ]
v Manual Gear Shifting
[~ Manumatic

(optional, overrides
global driver parameter)

Driver Farameter.., Driver Parameter...

— Minimaneuver C:

i
9 New | &3 Copy | [ Paste | S¢ Delete | |59 Impart |

i — |

Figure 5.34: Adding a default maneuver step

| CarMaker - Driver

Driver Presets Close

Mode: i Userparameter'ized Driver F] Rac'ing Driver

Standard Pﬂrﬂﬂ“ﬂef!} Traffic ] Race Dri\rer] Misc. | Additional Parameters ]

— General
Cruising Speed 150 kmih  dtChange of Pedals | 05§
Corner Cutting Coefficient | 0.5 Min. dt Accel /Decel. [ 45
[ Use Handhbrake for Driveaway
Driveaway Options Import Driver Parameters  lce throttle if wheelspin occurs
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— Accelerations, g-g Diag)
Max. Long. Acceleration | Parameter Set"defensive” |

Max. Long. Deceleration  Parameter Set"normal”
Max. Lat. Acceleration FParameter Set"aggressive"

(E_xx;;onﬁnt.of%-g_.Di?gram Reset all Driver Parameters De‘*H |
axlay dependenc ]
it :f Clear Knowledge -

oo T 1.0

— Declutching / Gear Shifting
Time for Shifting 1.0 s
Engine Speeds [RPM] Gear| min m idle up| acc down|
1 1500 4000 2000 3000|—
4 %

Figure 5.35: Choosing the defensive driver preset

Now all necessary components have been implemented and the TestRun can be simulated
for the first time. First, save the TestRun.
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Save the TestRun as PT_QuickStartGuide_Maneuver .

Start the simulation: In the main GUI, set the Simulation Perf. to realtime and then
press the green Start button. Watch the simulation in IPGMovie.

If you choose Speed and Powertrain in the menu View > Overlay Left , you can
observe the different operating strategies.

5.3.4 Implementing Speed Limits

watching the simulation, it can be seen that there is no speed limit on the road. This means
that the driver would usually try to reach the desired speed he is given by the user in the
Maneuver step. In this case, 100 km/h are already preset by the defensive driver model.

The next step is to set up a speed limit. First, the TestRun should be saved again as
PT_QuickStartGuide_SingleSpeedLimit.

Set a speed limit: In the Scenario Editor, navigate to the beginning of the track. Look
for the x- and y-values (0,0) or right-click in the drawing area and select Default View .

Click and hold the Markers icon and in the dropdown-menu, select  Driver speed .
Click on the road to select the Link and then click once to defi ne the starting and
once to define the end point of the road section with the speed limit.

<« Cartaker - Scenario Editor

EBE S «2 B0 %

Paramters | ObjeciList|

Ty o @ Marker: Driver speed G ER
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Speed limit jé“tirl _.J

unit }»fmm _1}
Speed fkmih] 100

I~ Valid for all lanes

"zg Height profile | Messages
4o : :
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Ga—— M 51833848 2 13258.67

Figure 5.36: Setting a Marker, type: Driver speed
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After setting the start and end points for the speed limit, the user has the possibility to
change various settings afterwards as well. This can be done in the small tab that opens up
on the right-hand side of the Scenario Editor after the speed limit has been selected by left-
click in Selection mode. The figure below shows which parameters can be set.

‘ @i Marker: Driver speed. Lo @%%i

Offset  [m]| 364.679 [Startpaint =l
5 r P

Speed limit |Start 2

Unit [kmih ﬂ

Speed [kmih] | 100

[ Valid for all lanes

Figure 5.37: Driver speed parameters

for beautification purposes. The driver will not react to these, as they can only be detected
by Traffic Sign Sensors. For signs that have an influence on the driver’s behavior, markers
must be chosen.

c Please note that Traffic signs allow the user to add traffic signs to the road network ONLY

Set the Speed for the speed limit to 30 km/h.

Save the TestRun by clicking the Save symbol in the Scenario editor and start th e
simulation.

The driver will now only drive at a maximum of 30 km/h because he always tries to follow
the guidelines.

File View Scene Camera Help

(30)

Vhel.sRoad! 8m

o

mmﬂmﬂmsm

Figure 5.38: Driver passing the starting point of the speed limit

Since the considered TestRun is about 90 km long, it isn’t very efficient to set all the speed
limits manually. Here, we have the option of importing speed limits from other TestRuns. For
this case, the speed limits will be exported from an example TestRun.
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First, the TestRun should be saved as PT_QuickStartGuide_RDE_Speedlimits.

Open the Scenario Editor, click and hold the

Import road definition

icon in the top bar

and choose | mport from TestRun . Select the TestRun Product Examples > Examples/
Powertrain/DrivingScenarios/Karlsruhe_RDE_Track

Now all the traffic signs and traffic lights from the RDE TestRun should have been
imported. Save the TestRun in the Scenario Editor.

“on CarMaker - Scenario Editor

L@

| ® Import fram road file
[#] Impaort from TestRun
[# Import fram HD Live Map

SRR T

-

Accessories

Figure 5.39: Importing components from another TestRun

Open the Maneuver GUI and change the Duration of the Maneuver step: Delete the
30s time condition and instead, define a restriction of 5000 m regarding the distance.

o CarMaker - Maneuver

Maneuver

Mo Start Dur Long Lat Label/Description

==== (lobal Settings / Preparation ====

1 30.0

==== END ====
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Lakel i
Description |
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Speed Tkrnih] | | Track Offset [mj | 0
v Manual Gear Shifting
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— Minimaneuver C d
.

T

Figure 5.40: Changing the duration of the maneuver step
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Additionally, the fuel consumption is to be logged. In order to do so, a maneuver step that
must have a duration of 0 s needs to be added. These types of maneuver steps (Duration
= 0s) are a special kind of step where the actions defined here are always carried out at the
end of a TestRun, no matter at which point the simulation ended. Mostly, this kind of step is
used to initiate post-processing actions.

Create a new Maneuver step by highlighting the last line in th e Maneuver step list
(END) and clicking New.

Set the Duration to 0 s and add the following command to the Minimaneuver Com-
mands field:

Eval first() ? Log("Average fuel consumption: %.1f I/200km ",PT.Control.Con-
sump.Fuel.Avg)

This command will show the average fuel consumption at the end of each simulation in the
Session Log (Main GUI > Simulation > Session Log).

Save the TestRun and start the simulation.

The vehicle drives through the RDE scenario with different speed limits and traffic lights on
it's way. At the end of the TestRun, the session log shows the average fuel consumption.
You can speed up the simulation in the Main GUI by selecting the desired speed in the Car-
Maker main GUI.

Creating the 48V P2 Hybrid

Now the 48V P2 hybrid, that can drive purely electrical, can be created. The 48V P1 hybrid
that was created in the first chapter can be used as a base to make parameterizing easier.
First of all, the powertrain architecture needs to be adapted:

Open the Vehicle Data Set and go to the Powertrain > General tab. Right-click any-
where in the dialog window and select  Parallel hybrid -> P2 -> Automated Manual
Transmission.

As the P2 hybrid has a conventional starter motor, we’ll have to change power and torque
from the P1 hybrid. Furthermore, the electric motor has to be defined.

Under Drive Source > Starter Motor , go to the General tab and set the Ratio to 4.
Under the Torque tab, setthe Mechanical power to 3 kW and the Maximum torque to
50 Nm.

Under Electric Motor > Torque , set the following performance data for the electric
Motor Model : Mechanical power =12 kW, Maximum torque = 130 Nm. For simplicity
reasons, apply the same parameters for the  Generator Model beneath.
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Iz CarMaker - Vehicle Data Set: Examples/DemoCar_48V._P2

Vehicle Data Set File w Close |

.ﬂ\ssembl\rl Bod\r| Suspensions] Steering | Tires | Brake] Powertrain | Sensors | Yehicle Control ] Additional]

Powertrain Sl e Model w |L,r
Model ®| Parallel Hybrid BT

General Engine ‘ Sn;z;};r ‘ Clutch ‘ Gearbox ‘

General" Torque" Efficiency " Bodies|

Motor Model: &| Characteristic Value

Driveline
Mechanical power [kKW] | 12 Tor?ueT[Nm]
— i iy &

Power Maximum tarque [Nm] |—1 30 Maxi mum torgue

Supply i F
Maximum rot. speed [rpm] 8000.0 e W e s

Control .

Unit Maximum rot. speed

Rotational speed [rp r;]

Generatar Model: #| Characteristic Value

Mechanical power [KN] | 12 Tor?ueT[Nm]

Maximum targue [Nm] 130 | %}

Maximum rot. speed [rpm] r_éﬁh_[i._ﬁ'

Rot. speed max. torque [rpm] 500.0

Maxi mum torque

T= Power [kW] / Rot.speed [rpm]

Maximum rot. speed

Ret. speed max torque '|' o

Rotational speed [rp r;]

Figure 5.41: Parameterizing the electric motor

The P2 hybrid has a clutch between the engine and the electric motor. With this clutch, it is
possible to activate coasting while the engine is turned off.

Go to Control Unit > PT Control > Coasting  and activate the Coasting option. You can
leave the default values as they are.

In the Electric Driving tab: At the moment, electric driving is only allowed to a limit
of 50% SOC and up to 50 km/h. Please change the SOC limit to 25%, the range to 10%
and the speed limit to 75 km/h (for "Active cruising" with engine off).

Save the vehicle as DemoCar_48V_P2 and the TestRun as
PT_QuickStartGuide_RDE_Speedlimits_P2.
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Powertrain Spbedded Model w g
Model ®| Parallel Hybrid Edit
General
S[;Li\r'(e:e General" Gas" Battery " Start/Stop " Coasting" Assistance " Regeneration" Electric Driving
Iv Electric Driving
Driveline S
SOC limit [%] 25
Power SOC limit range [%] 10.0
Supply Speed limit [kmih] 75
Control Speed limit range [kmih] 5.0
Torque limit [%] 800

Figure 5.42: Parameterizing PT Control

5.3.6 Test Automation using the Test Manager

A powerful tool in the CarMaker program is the Test Manager. In this chapter it will be
described how to create variations of a given TestRun by changing the vehicle or increasing
the payload.

Open the Test Manager : CarMaker main GUI > Simulation > Test Manager .

Add a TestRun: Left-click on Add and select TestRun. Add the created TestRun
PT_QuickStartGuide_RDE_Speedlimits_P2. from the previous chapter by clicking on
the folder icon.

em CarMaker - Test Manager

Test Manager Execution mode: &| Sequential Satlings | Close |

ltem Description | Par1| Par2| Par3| Par4|Res.Date |Result| [z w

“-4, Global Settings

View w

Add w

Test Caonfiguration
Vehicle

TestRun
— E‘-ariation
7] T Characteristic
Criterion
Diagram

Group
Settings
ScriptControl

Barrier

:.—I—

TestRun Description
TestRun |UNKNOWN TESTRUN
Parameters Type Name Value

-

-

-

Figure 5.43: Adding a TestRun to the Test Manager
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Now, the goal is to execute two TestRuns, first with the P1 hybrid, then with the P2. There-
fore, the user must add a Variation. KValues can be used when the user wants to change
an entire parameter set, like the vehicle or tires. You can find more information regarding
KValues (and NValues) in the CarMaker User’s Guide in chapter 14.5 "Variable Types".

Click on Add > Variation and for the Type, select KValue. The Name must be
TestRun:Vehicle which means that you want to change the vehicle file.

For the Value open the vehicle dialog (Main GUI > Car > Select) and choose the vehi-
cle you want to use in this variation: DemoCar_48V_P1. Mark the name and copy it.
Close the browser and insert the path and vehicle name in the Value field in the Test
Manager.

fica CarMaker - Test Manager Testseries1_VehicleVariation.ts

Test Manager Execution mode; #| Sequential Setings | Close |

ttem Description | Par1| Par2| Par3| Par4|Res.Date |Result| [z w

-4, Global Settings

£ .../Step4_RDE_SpeedLimits TestRun Vel VWi
.y Variation 0 DemaoCar_

B B Delete |
— TestRun Description
TestRun Mariation 0
h : Start
Parameters Type Name Value 24

lWalue = TestRunVehicle emoCar_48v_P1

-

-

-

B [
-_-Z i E

Figure 5.44: Vehicle variation in the Test Manager
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Choose a Description for this specific variation (e.g. P11 base) and then copy and
paste the variation once.

The second variation should run with the P2 hybrid, so change the Value of the KVal-
ue to DemoCar_48V_P2 and change the Description of this variation to P2 base.

I CarMaker - Test Manager Testseries1_VehicleVariation.ts

Test Manager Execution mode; #| Sequential Hifgs | Close |
ttem Description | Par1| Par2| Par3| Par4|Res.Date |Result| [z w
-4, Global Settings
TestRun Vel M
Examples) @
Examples) 2
Add w
Copy
7 T Delete |
— TestRun Description
TestRun P2 base S
i a
Parameters Type Name Value [ b
lWalue = TestRunVehicle ExamplesiDemoCar_48Y_P2 J Stop ‘
it / R@ﬁﬂ"v

Figure 5.45: Second vehicle variation in the Test Manager

Click on Start > Run in the Test Manager to initiate the test series.

Now a series of two TestRuns has been started. By opening the Session log, the user can
compare the fuel consumption of the two different cars.

At last, we want to examine the influence of the load. To do so, we have to define a Named-
Value (NValue).

In the CarMaker main GUI, open the example TestRun " Step4_RDE_SpeedLimits"
that you can find in Examples/Powertrain/_QuickStartGuide/ . Make sure that the
DemoCar_48V_P1 vehicle is being used.

In the main GUI, click on Select in the Load field. The Loads dialog opens where you
can define different loads at various positions.

Set the NValue: In the first field where the mass of a load is defined, type $load=0.
Thisis how NValues are initiated. They begin witha  $ sign, followed by a user defined
name that has been chosen for the parameter of this field and must always end with

a default value .
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In this case. The default value is 0 kg. This means that nothing is defined, an extra load of
0 kg, meaning no load, is set. The load can now be varied in the Test Manager.

| o« CarMaker - Loads o) 3
Car/Trailer Loads Close
— Car Loads
x[m]  y[m]  z[m] ot Iyy lzz  rear
[$toad=| kg | | | | [ ] m
|  0kg | | | | [ ] m
| 0Ky | | | | [ ] m
| 0ikg | | | | [ ] m
— Trailer Loads
¥[m]  ylm]  zlm) 18 Iyy Iz
| 0k | | | | | |
| 0k | | | | | |
| 0k | | | | | |
(use negative x values to position mass on trailer)

Figure 5.46: Setting the Named Value

Save the current TestRun as PT_QuickStartGuide_ RDE_Speedlimits_P1.
Open the Test Manager and replace the defined TestRun with the one you just saved.
Add a new variation ( Description: P2 base payload 500 ) by copying and pasting the

P2 base variation. Add a Parameter, for the Type, choose NValue, the Name should
be load and for the Value, set 500.

| CarMaker - Test Manager Testseries2 VehicleLoadVariation.ts

Test Manager Execution mode; #| Sequential Setlings | Clase |
ttem Description | Par1| Par2| Par3| Par4| ResDate |Result|~ Fjz +
-4, Global Settings
= ./Step6_RDE_SpeedLimitsLoad TestRun:Ve load 4\”9\" b
Examples Q
Examples 0 D
Examples 500 @]
Add w
Copy
Pasie
| ] Delete |
— TestRun Description
TestRun P2 base payload 500kg :
- | start
Parameters Type Name Value Al b
lWalue = TestRunVehicle ExamplesiDemoCar_48Y_P2 o
Nvalue = oad ~Eod P

Figure 5.47: Adding a variation with a Named Value
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Save the TestSeries by clicking File > Save as and name it Powertrain_TestSeries .

Run all variations and compare the different fuel consumption levels.

54 TestRun with Main Focus: Scenario Editor

In this chapter the user will be given instructions to create a fully parameterized TestRun
with a main focus on the Scenario Editor. For a TestRun to be sufficiently parameterized,
models for the vehicle, driver, road and maneuver must be defined. Further components are
optional.

54.1 Building a Road Network using the Scenario Editor

Load the prepared TestRun Stepl_ TestRunWithoutScenario

In the CarMaker GUI, click on File > Open, select the product data pool, then click on
Product Examples > Examples > BasicFunctions > Road > _Quick StartGuide >
Stepl_TestRunWithoutScenario

Save the TestRun under a different name, so that you can retrieve your work:

In the CarMaker GUI, click on File > Save as and choose Project on the left bar in the
dialog. With right-click, create a new folder (if you haven't already) “My_TestRuns".
Double-click on the new folder and enter any name for the Test Run,
e.g."My_TestRun_ScenarioEditor " > OK.

Close IPGControl and Instruments for the moment, but keep IPGMovie open.

| CarMaker - Browser

Load TestRun
@ O S My":Tes'iR'unsfMy_Tés‘iR‘un_‘ScenariEE‘d\‘tur -_v_l o 0K |
:Name o X
& Project [DataiTestRun] % Cancel
[EMy_TestRuns fad
iy _TestRun_ScenarioEditor|
_\
A

Product
Examples

= s

I Information about selected item

=

|CarMaker-TestRun 9 File
4.5 KBytes

2020-05-05
15:06

_, fsc

Figure 5.48: Saving the TestRun under a different name

The following chapters will now show how to extend this TestRun, for which only a vehicle
and simple maneuver have been defined for up until now. Work can be saved every now
and then via File > Save in the CarMaker main GUI or by using the shortcut Ctlr + S.
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Scenario Editor Basics

The Scenario Editor is a graphical user interface used to parameterize the road and build
road networks. The road model, called IPGRoad is a 3D model. A road consists of one or
several Links that are connected by Junctions. The user can define the shape of these Links
and Junctions, add a 3D profile (e.g. elevation), define the number of lanes and their widths,
change the road surface’s friction coefficient, add other elements such as road markings
and traffic signs to the scenario and specify the route that the vehicle will drive on.

Generally, there is more than one way to define the course of a track:

» Based on segments (e.g. straights, turns) joint to each other in the Scenario Editor.

* (Measured) road data saved in an ASCII file (text file) that can be loaded into CarMak-
er. These files need to contain cartesian (x, y, z) or geographic (long, lat) coordinates.

* Road data saved in KML-files (Keyhole Markup Language). These files are created by
Google Earth or Google Maps and can be uploaded in CarMaker.

« Combination of segments and road data from ASCII- or KML-files.

All of these options are further described in the User’s Guide.

The following examples will explain how to use the Scenario Editor.

Open the Scenario Editor: In top bar of the CarMaker main GUI, click on Parameters
> Scenario / Road .

[ CarMaker - Scenario Editor
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Tool
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Figure 5.49: Scenario Editor GUI

In this GUI, the road network and road properties are defined. A birds eye view visualization
helps the user see what is currently being modeled.
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* Tabs on the left side of the GUI:

- Tools: In this tab the user can switch to Selection mode for a standard cursor and
measure random distances on the road by clicking the ruler (Measure distance).

- Road: This tab is used to create Road segments (straight, curve, clothoid, etc.),
Lane sections, Lanes, elevation profiles and Bumps (local road surface deforma-
tions). Detailed information regarding all of these components can be found in the
corresponding section of the User’s Guide.

- Accessories: Here, road accessories can be added to the existing roads, such as
road markings, road paintings, traffic signs, traffic barriers and guide posts. Again,
further information can be found in the corresponding section of the User’s Guide.

- Scenery: Bridges, tunnels, signs, geometric objects, trees and terrain can be added
to the simulation to beautify the environment. These components are selected via
this tab and can be added to existing roads.

- Traffic: Here, markers for special maneuvers or measurements and route definitions
for the driver can be set. Further, traffic objects can be randomly distributed on the
road.

» Display Window in the center of the GUI:
- This is the space where the user designs the road networks.

- The 2D preview from a bird’s eye view gives an immediate overview of the road net-
work.

- In selection mode, certain components of the road network are selected in this win-
dow. Selected components are highlighted to show which part of the road is current-
ly activated.

« Tab on the right side of the GUI: In this field, information regarding currently selected
components is listed and corresponding parameters can be edited. For example when
a link or lane is selected, this is where width and coefficient of friction are defined.

« Top menu: In addition to other features, that are further described in the User's Guide,
the designed road network can be viewed using 3D-Preview (the button with the Play-
symbol).

Implementing and Checking the Road Geometry

There are two options for checking the road definition: the bird’s eye view of the road in the
Scenario Editor display window and 3D-preview using IPGMovie. The following exercises
will describe how to implement a few road segments that can then be viewed either in the
Editor or in IPGMovie.
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Using the mouse, navigate to the  Road section of the tab on the left side of the Sce-
nario Editor window. Click and hold the first icon called Road segment until a drop-
down-menu opens. Select the Road segment type  Straight .

i
2 Junction

| ramp
|4 straight
(@F Turn
(& Clothoid
(/' Paintlist
‘ [l connect

91 B Fire
= Al

Figure 5.50: Inserting new road segments

Acces

Use the cursor to navigate into the design area of the Editor (the middle window) and
click once to define the starting point of the straight segment. The first point that is

set is also the origin of the global coordinate system. Hold shift and click again to
create a horizontal, straight road segment that is 100m long.

The segment’s length can be altered by entering the desired value in the field labelled
Length in the tab on the right hand side while the corresponding segment is select-
ed.

To select specific elements in the Scenario Editor, Selection mode is used.

Save the TestRun and open the 3D-Preview in IPGMovie: Click on the button with a
play-symbol in the top panel in the Scenario Editor and select 3D Preview .

© IPGMovie - Preview Step?

o | CarMaker - Scenario Editor,

LIRS CTE ST

= e
L i+ @ = & B oE e ymm

A Helontprofile | Messages |

Figure 5.51: 2D-Preview in Scenario Editor and 3D-Preview in IPGMovie

CarMaker Quick Start Guide Version 9.0.2



Creating Your First TestRun 66

TestRun with Main Focus: Scenario Editor

The display in the Scenario Editor shows the geometry of the road in two dimensions. This
viewing method may not be as detailed as the preview in IPGMovie, but it is very convenient
for implementation and quick-checking during simulation preparation.

IPGMovie shows the road definition in a 3D animation with far more detail. By moving the
slider in the control bar or by pressing the play button, the yellow marker in the road preview
moves along the track, displaying the road and all its features. This feature is only available
after a route has been defined. This will be explained in the course of this example.

At this point, the road is just a straight line with a constant coefficient of friction. The next
section of this document will show that when changes are made in the road definition, they
are immediately updated in the 3D-preview.

This new feature gives the user easy access to different objects present in the road
file. In this tree format the objects are arranged according to the hierarchy and dou-
ble clicking on an object opens the parameters associated with it. This makes it eas-
ier for the user to understand the dependencies of various objects.
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Figure 5.52: Viewing object list in scenario editor

Building a Road Network

Now, two junctions and a few additional links will be added to the previously saved TestRun.
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In the Road tab on the left side of the Scenario Editor, click and hold the first icon
Road segment again.

1. This time, release the mouse button over the

Junction option. Navigate to the end

of the first Segment (Link 0, Segment 0O, the straight) using the cursor and look for a
small, orange circle that appears when the end of the reference line has been cap-
tured. Click once to define the straight as the first junction arm.
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Figure 5.53: Defining the first Junction arm

2. Hold Shift and add three 25m long arms, each 90 degrees to another, to the junc-
tion and confirm by either using a double-click on the last junction arm or by clicking

exactly in the middle of the junction.
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Figure 5.54: Finished Junction

CarMaker Quick Start Guide

Version 9.0.2



Creating Your First TestRun 68
TestRun with Main Focus: Scenario Editor

3. Add a straight segment to each Junction arm. Be sure to capture the right point of
the reference line when adding the new segment.

The segments that go upwards and to the right should be 200m long and the segment
that goes downwards should be only 50m long.
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Figure 5.55: Junction with four Links

4. Add a second Junction at the right end of the road network: Select the road seg-
ment type Junction again in the Road tab on the left side and click once to capture
the correct point at the end of Link 2.

Holding Shift, add one 25m long Junction arm that points to the top right at 40
degrees and one that points downwards at 270 degrees.
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Figure 5.56: Second Junction with three arms
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5. Add a long, curvy road to the top right-hand side of the road network using Point
list : Click and hold the road segment icon again and select Point list in the dropdown-
menu.

Make sure to capture the right point of the reference line at the Junction arm on the
top right-hand side and place as many points as you like to create a Link broadly sim-
ilar to the one in the figure below. Double click on the last point to end this mode.
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Figure 5.57: Point list at the right end of the road network
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6. Add a Route to the road: In the toolbar on the left side of the Editor, in the "Traffic"
tab, select the Route icon. Using the cursor, select the predefined Path on the right
lane of the Link on which the vehicle will start. In this case, that means clicking the
straight, horizontal Path on the bottom lane of Link 0 on the left side.

Now, hover the cursor over this Path again and left-click once again as soon as the
line is marked with an orange, broken line.

Now, all of the following Path segments that are required for our Route need to be
selected one after the other. First, the Path that goes straight across the first junc-
tion, then the right lane Path on Link 2, the Path that goes upwards over the junction
and lastly the right lane Path on Link 4. This sequence of Paths defines our Route.

To set and complete the Route definition, double click onto the Route itself (or any-
where besides the road) until it changes color. In the tab on the right-hand side, name
the Route "Woods".
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Figure 5.58: Defining the Route
CarMaker Quick Start Guide Version 9.0.2



Creating Your First TestRun 71
TestRun with Main Focus: Scenario Editor

Check the road geometry in 3D-Preview using IPGMovie by pres sing the button
marked with the play-symbol again.
Now the slider can be used to move along the Route in the preview.

@ IPGMovie - Preview Stepl_TestRunWithoutScenario
File View Scene Camera Help
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Figure 5.59: Checking the geometry using 3D-Preview

Start the TestRun: Click on the green “Start” button in the CarMaker main GUI.

Watching the simulation in IPGMovie, it is visible that the vehicle stops before it even reach-
es the end of the track. This example shows the dependency between the road and maneu-
ver definition.

To make the vehicle drive to the end of the track, a maneuver needs to be defined that does
not end before the track does. This means that the simulation is over as soon as either the
road or maneuver definition has come to an end.

Edit the maneuver so that the vehicle reaches the end of the track: In the CarMaker
GUI, click on Parameters > Maneuver.

In the field Duration , insert the following value: 9999.
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Figure 5.60: Changing the duration of the maneuver
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Save the TestRun by clicking File > Save in the CarMaker main GUI and start the sim-
ulation again.

Figure 5.61: Vehicle at the end of the road

The vehicle now drives to the end of the road and the simulation is only terminated once
the road has ended. The maneuver definition is explained in further detail in section 5.4.2
'Defining the Maneuver'.

Create a Closed Track with 3D Surface

The previously built road will now be extended in order to build a closed track. To load the
previous TestRun My TestRun_ScenarioEditor, click on File > Open >
My_TestRun_ScenarioEditor > OK in the CarMaker main GUI. For better visualization, IPG-
Movie should be opened, too. In case needed, a solution to the steps up until now is avail-
able in the example TestRuns under Product Examples > Examples > BasicFunctions >
Road > QuickStartGuide > Step2_Woods. In case you are using the solution, be sure to
save it as "My_TestRun_ScenarioEditor" for further use.

For this example, two new segments and an elevation and slope profile with the following
geometries will be added to the previously built track. Following the instructions in the list
below, the closed track that can be seen in figure section 5.62 'Course without elevation pro-
file’ will be built
* Link 3, Segment 1:

- Subsequent to segment O

- Segment type: Turn

- Radius: 100m

- Angle: 180 deg

- Slope profile with a height of 0.5 m on the outer corner
* Link 3, Segment 2:

- Subsequent to segment 1

- Joins the previous turn with the second junction

- Segment type: Connect
» Elevation profile on Link 2 (Link between the two junctions)

- Short section with a height of 8 m at the top
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First, all segments are implemented in the plane with the correct length and curva-
ture. The elevation profile is added to the track in the end.

Link 3, Segment 1: Click and hold the  Road Segment icon in the Road tab again and
select Turn. Click once at the end of the straight and holding shift, click again to cre-

ate a left turn with a 100 m radius and 180 degree angle. If nece  ssary, adjust the
parameters radius and angle in the tab on the right side.

Note that when implementing a turn, the second click defines whether the turn goes

to the right or to the left.

Link 3, Segment 2: Click and hold the  Road segment icon and select Connect . Click
once at the end of the turn and again at the bottom Junction arm of the second Junc-
tion. Be sure to capture the orange point in order to create correct transitions.

The track should now look like displayed in the figure below.
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Figure 5.62: Course without elevation profile

Now, the different height profiles for specific links are implemented. It is important to know
that each link can have only one height profile of each type (elevation, slope and camber).
When adding further height node points to the same link, the user should expand the exist-
ing list instead of trying to add a new one.

Height profiles are defined relative to the s-coordinate which runs along the center of the
road (reference line). There are two ways to define the beginning and end points (limits) for
certain elevations:

» Precise s-coordinates: Beginning and end can be set exactly in the elevation profile,
relative to the beginning of the corresponding Link.

 Intuition: Using the cursor the user can select points in the display window of the Sce-
nario Editor to define plausible beginning and end points for an elevation profile.

In this example the beginning and end points for the elevation profile can be set intuitively
using the cursor in the display window. If desired, the values can be adjusted in the tab on
the right-hand side to fit those in the solution later.
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Add the elevation profile to Link 2: Click and hold the 3 D Surface button in the Road
tab. Choose Elevation profile . Click on the link and define the first point shortly after

the beginning of Link 2. Select the second point shortly after the first one, the third
closer to the end of the Link and the fourth right at the end. The selection is ended

with a double-click on the last point.

Now a list representing the elevation profile values is visible in the right-hand tab. In
case too many points were placed or some points are at the wrong place, this table
can be used to delete or alter the values for each point.

Insert a height of 8m for the two middle points, Om for the others. So that the spline
for the elevation profile is calculated correctly and the re st of the course isn’t
deformed, select O for the grade in each point.

This is what the elevation profile should look similar to

@ Elevation profile @@@ %ﬁ
Object 336
List of nodes:
| offsetfm] | Heightim] | Grade [m/m] [~
40 0 0
70 B8 0
140 B8 0
170 0 0

Figure 5.63: Elevation profile for the longitudinal slope

It doesn’t matter if the points differ slightly since they were selected intuitively. Clicking on
Preview shows what the road now looks like.

Now the lateral slope for Segment 1 on Link 3 can be implemented.

Similar to when defining the elevation profile for the longi tudinal slope, click and
hold the 3D Surface buttoninthe Road tab. Choose Slope profile , select the relevant
Link (the long turn at the bottom) and define four points on segment 1 (the turn).

Point 1: Around the beginning of the curve. As off this point the slope will begin to
gradually reach the desired value.

Point 2: A few meters behind the first point. As off this point the slope will be con-
stant at the set value.

Point 3: Shortly before the end of the curve. As off this point the slope will begin to
decline.

Point 4: End of the curve, shortly after point 3.

Now a list representing the slope profile is visible in the right-hand tab. Insert -0.5 for
the slope of the second and third point, and 0 for the rest. Also, set O for the gradient
of all four points. Whether the slope value needs to be positive or negative depends
on which direction the slope should go in.
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This is what the slope profile should look similar to:

@ Slope profile ﬁ@ @ o %
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Figure 5.64: Slope profile for the lateral slope

Insert a second Route: Click the  Route icon again and first select the right lane Path
on Link O (the first one on the left) and confirm this Path after the orange, broken line
appears. Accordingly, select the Path that goes across the Junction, the right lane
Path on Link 2, the Path that goes downwards over the junction, the right lane Path
on the long turn and then the Paths upwards to Link 1.

Double-click to end the Route definition and name this Route "TestTrack".
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Figure 5.65: Defining route "TestTrack"

To select which route the driver should drive on is defined in the global settings. These can
be accessed using the gear icon in the top bar of the Editor. A field labelled Active Route
on the right side opens a dropdown-menu containing all available routes.

Select "TestTrack" as the active route, save the TestRun and start the simulation
again. You can compare your TestRun to the example TestRun Step3_TestTrack.

In IPGMovie the road characteristics that were just defined are now more noticeable, espe-
cially the longitudinal and lateral slopes.
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Figure 5.66: Longitudinal and lateral slopes

Modifying the Width and Coefficient of Friction

Up until now the designed roads have all had the coefficient of friction and road width that
are predefined in the Scenario Editor. If desired, the user can easily adapt both parameters
individually. How the user must proceed to do so will be described in this chapter.

In this example, again, the saved TestRun My_TestRun_ScenarioEditor is used. Alterna-
tively, the solution to the previous steps can be found under Product Examples > Examples
> BasicFunctions > Road > _QuickStartGuide > Step3_TestTrack. Remember to save as
My_TestRun_ScenarioEditor.

When the width of a lane is set, this applies to the entire lane.

In order to define areas with individual lane widths, a new Lane Section must be defined
(Lane section = section of the road with a constant number of lanes). To do so, Lane section
in the Road tab needs to be selected and using the cursor, the limits for the new Lane Sec-
tion can be defined in the display window by clicking on the road at the desired points. Now,
the lane width within this section can be varied independent of the other Lane Section lane
widths in the known manner. This isn’'t required in the following example.
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Add an area to perform a braking test by changing the lane settings on Link 1 (the
link going upwards from the first Junction):

First, delete the left lane of Link 1. Since we want to drive in the middle of the road
for our braking test, the right lane is sufficient: Click on the Lane icon in the Road tab
and select the left lane. Delete it by clicking the red "X" in the tab on the right side.

Change the lane width of Lane section 1: Click on the Lane icon in the Road tab and
select the single lane of section 1. Set the lane width to 10m in both fields ( Width at
start and Width at end ) in the tab on the right-hand side.

Adapt the Road Markings on the left hand side by selecting the Road Marking tool in
the Accessories tab, clicking on the currently broken line and changing the Line type
to Single line .

Start the simulation and watch how the track has been changed to be wider.

® | IPGMovie - ‘wslinux soleng001° online — 83X
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Figure 5.67: Vehicle dynamics platform

In addition to the lane width, the coefficient of friction can be user-defined using two meth-
ods:

» Change the coefficient of friction for the entire Link (globally): In selection mode, click
on the road and select the desired Link. In the tab on the right side a value can be
assigned to the parameter "Friction". This changes the coefficient of friction for the
entire track.

» Change the coefficient of friction in sections: Click and hold the "Bumps" icon in the
"Road" tab and select "Friction". This tool allows the user to place variable friction
stripes. Click on the desired Link and define the two points that will limit the friction
stripe. In the tab on the right you can now define the lateral offset, width and coefficient
of friction for the friction stripe.
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Add a friction stripe to the vehicle dynamics platform: as pr eviously described,
select the Bumps tool and then pick the Friction option. Click on Link 1 (the Link we
just adapted) and place two points to define beginning and end of the friction stripe.
Alter these points in the tab on the right hand side so that the stripe starts at 120m

and ends at 200m.

Also in the tab on the right, set the Lateral offset to -10m from the Reference Line
(negative value is the right side of the road), the Width to 10m and the Friction to 0.5.
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End offset [m] | 200 |Startpoint =]
Lat offset [m] | 10 |Reference Line |
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Material | Color
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Scaling 1 |
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Figure 5.68: Friction stripe parameters

The friction stripe as it is defined in the figure above creates the following visualization in
IPGMovie:
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Figure 5.69: Defined friction stripe
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Inserting Bumps, Markers and Movie Objects

Changing the road’s track width and friction are only two of the numerous possibilities that
IPGRoad offers. In the tab on the left, there are many options that allow the user to add spe-
cial items to the road and surrounding scenery.
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Figure 5.70: Special items available in Scenario Editor

The selectable features are grouped in Road, Accessories and Scenery:

* Road - Bumps: With this tool the user can choose from beams, cones, friction stripes,
mesh, waves and lateral profiles. These change the road’s 3D appearance and alter
the surface.

» Accessories: Road markings, road paintings, traffic signs, traffic lights, traffic barriers
and guide posts can be implemented in this tab. Some of these components may have
an influence on the driver and vehicle behavior, e.g. the vehicle can be defined to stop
at a stop sign using traffic sign sensors.

» Scenery: These objects do not directly influence the simulation, as they are design ele-
ments. The user can implement bridges, tunnels, geometry objects, sign plates, tree
strips and terrain.

For more information regarding the individual parameters and their elements, please refer
to the Scenario Editor section in the User's Guide.

@ IPGMovie - ‘track’ online
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Figure 5.71: A Road with activated Markers and Movie Objects
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Save the TestRun and the road file. Save the road file in the Scenario editor. This will
save a file with a .rd5 ending. Callit My_Road.rd5 .

Compare TestRuns:

Compare your TestRun My_TestRun_ScenarioEditor with the predefined TestRun
Step4_FrictionStripe (located in Product Examples > Examples > BasicFunctions >
Road > _QuickStartGuide ) or have a look at the TestRun Final_Road in the same fold-
er to see how various geometry objects and environment setti ngs can change the
road network and surroundings.

After having built a road, it is now time to look at the Maneuver definition in further detail.

click in Selection mode. The figure below shows which parameters can be set.

% Marker: Driver speed e B O
Offset ml | 364.679 [Startpoint =
Speed limit Start =]

Unit [kmih ]

Speed tkrnih] | 100

[~ Walid for all lanes

Figure 5.72: Driver speed parameters

for beautification purposes. The driver will not react to these, as they can only be detected
by Traffic Sign Sensors. For signs that have an influence on the driver’s behavior, markers
must be chosen.

c Please note that Traffic signs allow the user to add traffic signs to the road network ONLY

5.4.2 Defining the Maneuver

For the examples in this chapter the previously built TestRun My_TestRun_ScenarioEditor
or one of the solutions Step4_FrictionStripe or Step5_Road (including environment chang-
es) is required.

Save the TestRun My_TestRun_ScenarioEditor . Alternatively, use one of the pre-
defined TestRuns Step4_ FrictionStripe or Step5_Road and save it as
My_TestRun_ScenarioEditor so that your TestRun is up to the current status.

Based on this TestRun, the maneuver definition will be explained and extended.
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The Maneuver GUI

In the CarMaker main GUI, click on Parameters > Maneuvers .
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Figure 5.73: The Maneuver GUI in CarMaker

The figure above shows the Maneuver GUI:

» Field (A): In this section a list of all the maneuver steps, that will be carried out consec-
utively, is shown. When one step is selected, more information regarding it's parame-
ters becomes visible on the right-hand side.

« Field (B): In this section the longitudinal and lateral dynamics are specified. These
define how the vehicle is controlled. The longitudinal and lateral control of the vehicle
are defined completely independent of each other.

« Field (C): Here the user can set a description for each maneuver step and define end
conditions. The end condition can be a time or distance that, when reached, terminates
the simulation.

* Field (D): The “Minimaneuver Commands” field is a feature for experienced CarMaker
users. Advanced maneuver definitions can be individually programmed and integrated
ion this field. As this field is optional, it will remain empty in this example.

Limiting a Maneuver Step with DrivMan Jump

Up until now, the maneuver step in the TestRun has always been the same: a single maneu-
ver step, driving from standstill, 9999s long.

In this chapter the maneuver step duration is to be limited not by time, but rather by a marker
that will redirect the driver to another maneuver. This means that as soon as the vehicle
passes said marker, a new maneuver step is initiated and carried out until it's end-condition
is fulfilled.
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In the following example, a marker is placed shortly before the braking area. When the vehi-
cle reaches this marker, a braking maneuver will be initiated so that the driver begins to
brake while coming onto the slippery friction stripe. The field called "Target label" defines
the maneuver step to which the driver will jump after passing the marker.

Set a Marker on the braking area: On the left-hand side of the Editor, under the tab
labelled Traffic , click and hold the Marker icon. In the dropdown-menu, select the
option called DrivMan Jump , click on the vehicle dynamics platform (Link 1) and click
again to place the marker.

In the right-hand tab, edit the offset to 110m and the target | abel to Braking (this
refers to the second step in the list of maneuver steps).

@ Marker: Drivian jump €8 R

Object 55
Offset [m] 110  |Start point |
Target labe| Q-E'i'fél'c'i'hg
[ Walid for all lanes
Figure 5.74: Marker settings
Now a marker has been set 10m in front of the friction stripe on the vehicle dynamics plat-
form that refers to the maneuver step 1. Currently only one maneuver step (step 0) is

defined. So if the simulation is started now, it will be aborted as soon as the driver reaches
the marker because he will be referred to a non-existing maneuver.

The second maneuver step "Braking" needs to be defined.

Define the second maneuver: In the CarMaker main GUI, open Parameters > Maneu-
ver and highlight the last line in the list (  END) by clicking on it. Now select New to
insert a second maneuver step under the first one.

Write "Braking" in the  Description , as well as the Label and change the longitudinal
dynamics to manual by clicking on the small arrow in the corresponding field.

In order for the driver to suddenly brake, change the values of both the clutch and
brake to 1. This means that after the marker, the driver will quickly press and hold
both pedals until standstill.

Change the Duration to 999s to make sure the driver reaches a standstill before the
maneuver ends.
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TestRun with Main Focus: Scenario Editor

| CarMaker - Maneuver

Maneuver Close
Mo Stat  Dur Long Lat  LabeliDescription — Specification of M Step
==== Glohal Settings / Preparation ==== " | Label Braking

V] 0.0 9999 Driving from standstill .
£19599.( 999 [Braking] Braking DEscatnon Jraking
End Condition fin

2109980 i
Duration (time/dist) 999 5 | m Ac| st

— Longitudinal Dynamics - — Lateral Dynamics
*|Manual (Pedals, Gear) &/ IPGDriver

Walue Start dt +- | | Track Offset [m] 0
Clutch | 1 0.2

Gas 0 0.2
Brake 1 0.z
BrakePark 0 0.2

Gear 0o 0.0

value = 0.1; +-=value is offset

=1 =10=11=]
EEREN

Driver Parameter...

— Minimaneuver Commands

9 Mew | a3 Copy | (4 Paste | 9% Delete | =5 Import |

Figure 5.75: Defining the braking maneuver

Make sure that "TestTrack" is the active Route, save the TestRun and simulate.

o km/h A200
839 o

ERIDELIES T

Figure 5.76: The new maneuver step displayed in IPGMovie

Now the vehicle stops after it has reached the Marker and the driver started braking. Due
to the slippery friction stripe, the braking distance is higher than it would usually be. Try
varying the coefficient of friction on the friction stripe to see changes in the simulation.

Adding an Open Loop Maneuver Step

By inserting an open loop maneuver, several maneuver steps can be used during the same
simulation.

CarMaker Quick Start Guide Version 9.0.2



Creating Your First TestRun 84

TestRun with Main Focus: Scenario Editor

In this example, the dynamic test platform will be used to perform a sinus steering maneu-
ver.

Insert an new maneuver step: In the Maneuver GUI, click on the last maneuver step
(“END”) and then click on “New" at the bottom of the list.

Select and define the new maneuver step:

Label: Sinus steering

Description: Sinus steering

Duration: 3s

Longitudinal Dynamics: IPGDriver

Lateral Dynamics: Sinus, Amplitude = 50 deg, Period = 1s, # Periods = 3

CarMaker - Maneuver =0l
Maneuver Close
Mo Start Dur long Lat LabelDescription [~ Specification of M Step

==== Glohal Settings / Preparation ==== 4| Label |Sinus steering
1] 0.0 9539 Driving from standstill Descrintion E-Sinus pryepep
| 189980 989 GBCP [Braking] Braking P | g —

210898.0 3 Sinus [Sinus steering] Sinus ste End Condition [
| 3110010  ====END==== Duration (timefdist | 3s | m Adjust

— Longitudinal Dynamics — Lateral Dynamics

&/ IPGDriver *|Sinus
Speed ki) | Start 1] oo
 Manual Gear Shifting Amplitude [deg][ 50
[~ Manumatic Period 4 [s]| 1
# Perinds [ 3

(optional, overrides |
global driver parameter) Phase offsst [deg]; 0

v Smooth Transition
[~ Value is Offset
[ Steer by Torque

Driver Farameter..,

— Mini C d

7 Mew 5 Copy | [ Paste | %€ Delete | |5 Impart |

Figure 5.77: Open loop maneuver step

In the Scenario Editor, select the Marker and insert "Sinus steering" for the Target
label so the driver jumps to maneuver step 2, instead of 1.

Save the TestRun.
In the CarMaker main GUI, set simulation speedto  realtime .

Save and start the simulation, watch in IPGMovie and pay attention to the box Maneu-
ver in the CarMaker main GUI.

In the Maneuver box of the CarMaker GUI, all maneuver steps are displayed. During the
first part of the overall maneuver, which lasts up to the marker, the first maneuver step is
highlighted. As soon as the sinus steering phase starts, the third maneuver step is highlight-
ed.
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TestRun with Main Focus: Scenario Editor

This very simple example shows how to insert an open loop maneuver and then check
which maneuver step is currently running.

Adding a Closed Loop Maneuver Step with IPGDriver

The previous simulations were all open loop maneuvers since at some point the vehicle
came to a standstill or reached the end of the road. During a closed loop maneuver
IPGDriver continues driving an unlimited amount of laps of a specific Route. Note that the
Route needs to be a circuit so that a closed loop maneuver is even possible.

IPGDriver is a model developed by IPG that acts and reacts exactly as a real driver would.
The virtual driver is composed of a controller that urges him to follow the course and a
speed controller that regulates the velocity.

In the Scenario Editor, define a new Route by clicking the "Route" icon. Select the
predefined Path on the right lane on the first Link (Link 0) and co nfirm by clicking
again. Now select the Path that goes across the junction and accordingly, select all
Paths necessary to drive around the long turn. The last Path segment to be added to

the Route should be the Path that takes a right turn over the first junction. Double
click to confirm the Route. Name it "ClosedLoop".

IPGDriver will now recognize that the last point of the Route lays on another point of
the same Route whereas he will continue to drive this Route endlessly.

Save the TestRun, open the Instruments and start the simulation.

| CarMaker - Scenario Editor

=T IR ¥ -1 21

Paramelers} Object List

Search by ID: | 2374

g | Filter Al -

[Z1 Ego Vehicle & Traile
Egovehicle 0 (7

[ Traffic ohjects

. L Traffic object0

I Junctions

. ElJunction 0 (55)

| Edunction 1 (300

ErLinks

 ELinkD (0

| Link1 (74

P BRLink2 (139)
! HLink3 (215
{ BFLink4 (311)
[ Routes
EFRoute 0 (397
B Route 1 (416)

Figure 5.78: Closed Loop Route

The vehicle now continues driving. Observe the speed using Instruments. In the maneuver
GUI a target speed can be set for each maneuver step individually. The driver will try to
reach and keep this speed, all while considering the vehicles physical limits and aiming to
stay on track. Try entering a target speed and watch how the driver handles these guide-
lines using Instruments.

This shows two things:

e The maximum speed that the driver is to aim for can be defined separately for each
maneuver step.

» The driver stays on the track and identifies the ideal trajectory automatically.
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TestRun with Main Focus: Scenario Editor

Other Options for the Definition of a Maneuver Step

So far, only IPGDriver and a very simple sinus steering have been used in the maneuver
steps. These are among the most important options used in CarMaker. However, there are
various other options available.

Duration of the Maneuver

Specification of Manewuver Step
Lakel
Description
End Condition

Duration (timeldist) 9999 s m

Figure 5.79: Defining the duration of a Maneuver Step

Previously it was discussed how a maneuver step can be restricted by a marker that forced
the initiation of a new maneuver. This is by far not the only possibility for implementing end
conditions.

In the field labelled End Condition, other parameters can be defined to abort the maneuver
step. By right-clicking in the entry field, a list of all User Accessible Quantities in CarMaker
is presented. Any of these can be chosen to be combined with a logical operator in order to
become an end condition. Logical operators can be smaller as (<=), larger than (>=) or
same as (==). Furthermore, it is possible to define more than one condition at the same
time. Quantities can be combined using logical AND (&&) or OR (||) operators.

Specification of Manewuver Step

Label

Description

End Condition Carv==50/3.6 && DM.GearMo==3
Duration (timeldist) 9999 s 250 m

Figure 5.80: Defining the “End Condition” Parameter

Longitudinal Dynamics

L ongitudinal Dy e
*|IPGDriver
Speed [kmih] 100
[v Manual Gear Shifting
[~ Manumatic

(optional, overrides
global driver parameter)

Driver Parameter...

Figure 5.81: Defining the longitudinal dynamics

To control the longitudinal dynamics, e.g. the speed and/or longitudinal acceleration of the
vehicle, several options are available:

IPGDriver: Fully automated control of the vehicle speed and acceleration by the IPG
driver model.

Speed Profile: This option enables the use of speed measurements.
Speed Control: This option represents a simple speed controller.
Manual: Enables direct control of the pedal positions.

Stop Vehicle: Stops the vehicle. This option is especially designed for engineers work-
ing on active park assistance systems.
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TestRun with Main Focus: Scenario Editor
» Drive Backwards: Same option as IPGDriver, but backwards.
» |PGDriver + User Driver: Activates a user-defined driver model.

Lateral Dynamics

— Lateral Dynamics
*|IPGDriver

Track Offset [m] 0

Driver Parameter...

Figure 5.82: Defining the lateral dynamics

The vehicle’s direction can be defined using several options:

e IPGDiriver: Fully automated control of the steering wheel.
* Sinus: Sinus input on the steering wheel.

» Sinus Sweep: Sinus input on the steering wheel with different amplitudes (specifically a
start and end amplitude that can have a linear or non-linear course).

» Steer Step: Steer step input on the steering wheel.
» Follow course: This option is a steering wheel controller like IPGDriver, but simplified.

The TestRun altered in this chapter can now be compared to the predefined TestRun
Step6_Maneuver (located under Product Examples > Examples > BasicFunctions > Road
> QuickStartGuide).
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What is a Data Set?

Chapter 6
Vehicle Model Parameterization

6.1 What is a Data Set?

Instead of using the term Vehicle Model, CarMaker tends to refer to Data Sets. This is
because technically, CarMaker possesses only ONE vehicle model. This model has defined
and fixed masses, DOF, spring/damper elements, etc. What happens then in CarMaker is
that the model is parameterized with various Data Sets according to the user’s needs. The
Data Set contains the values necessary to parameterize the model, for e.g. the weight of
the masses, the stiffness of the springs, etc.

In CarMaker, the Vehicle Data Set can be accessed via the CarMaker main GUI by either
clicking directly on the field labelled Car in the main GUI, by clicking on Parameters > Car
or by using the shortcut Ctrl + f.

6.2 Creating a New Vehicle Data Set

Apart from the large variety of predefined vehicle models available for use in CarMaker, the
user often needs his own, individual model. There are several ways to generate a Vehicle
Data Set from scratch that fulfills the user’s exact needs. CarMaker offers a few tools that
support the user in building his Vehicle Data Set that can also be used in combination.

In general, there are three approaches to parameterizing a Vehicle Data set from scratch:

» Using the Vehicle Data Set Generator to generate a Data Set based on a few basic
specifications like vehicle class.

» Using the Vehicle Data Set Generator to create a basic Data Set and then specifying
relevant components in further detail manually.

» Configuring an entire Data Set manually with the help of a request form.

Furthermore, CarMaker offers the option to import existing vehicle data for single vehicle
components.
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Creating a New Vehicle Data Set

6.2.1 Using the Vehicle Data Set Generator

Open a new Testrun and open the Vehicle Data Set. Click on File > Generator .

| o) CarMaker - Vehicle Data Set Generator

Vehicle Data Set Generator  Generate Close
Basic Seﬂingsw Advanced Setings |
v Yehicle Data Set !Compact.car
|v Vehicle Graphics |Compacttel
— Vehicle Class T vehicte Par ers — =
~ Small Car Unloaded weight ' 13200 kg
« Compact Car Vehicle length | 43500 mm
e ar Vehicle width [ 17900 mm
" Luxury Car Vehicle height | 14550 mm
I Delivery Van Wheel base | 2635.0 mm
 Compact SUV Track width front | 1551.0 mm
i Full Size SUV Track width rear | 1549.0 mm
Rear overhang | 8450 mm
— Tire
Tire size| 205 «|f| 55 <R[ 16 o
|v Generate Tire Data Set Tire Data Generator

Figure 6.1: Vehicle Data Set Generator

The Vehicle Data Set Generator is a tool that automatically generates a plausible vehicle
data set, based on the most important data necessary to characterize a vehicle.

Furthermore, the user can directly select a vehicle class, for e.g. Compact Car in order to
assign the typical values for this kind of car.

Select the Vehicle Class "Compact Car".
In "Vehicle Data Set", write the name of the vehicle: "My_Car" and click on "Gener-

ate".
Close the Generator.

Now, the values written in the Vehicle editor have changed. Using the Vehicle Generator
has implemented a new vehicle data set which can now be worked with.

In the Vehicle editor, click File > Save to save your vehicle.

From now on, the new values are not only displayed in the editor, but also saved to the cor-
responding file.
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Vehicle Submodels

Using the Import Feature

The import function allows the user to replace certain vehicle components with those of
another data set. In the Vehicle Data Set via File > Import the dialog displayed in the figure
below opens up.

Im CarMaker - Vehicle Data Import

Vehicle Data Import mport | Close
— Parameters to Import
[ Assembly [ Powertrain [ Buspensions
[ Configuration [~ Engine [~ Spring
[~ Engine Mount [ Clutch [~ Front
[ Body [ Gear Box [ Rear
[~ Chassis [~ Driveline [~ Secondary Spring
[~ Powertrain [ Differential Front [~ Front
[~ Trim Load [ Differential Rear [ Rear
[ Body [ Differential Center [~ Damper
[~ Structure [ Differential HangOn [~ Front
[~ Quter Shell [ Starter Motor [~ Rear
[ Aerodynamics [ Electric Motaor(s) [ Buffer
[~ Steering [~ Planetary Gear [~ Front
[ Tires [~ Control Unit [ 'Rear
[~ Brake [~ PTControl [ Stahilizer
[ Sensors = [~ Front
[ Slip Angle [ TCU [ ‘Rear
[ Inertial [~ Mcu [~ Kinematics
[ Object [ BCU [~ Front
[~ Free Space [~ Power Supply [ ‘Rear
[~ Traffic Sign [~ Wheel Bearing
[~ Line [~ Front
[ Road [~ Rear
[~ Collision |~ External Forces
[ Object by Lane
[ Global Mavigation
[ Radar
[~ Camera
[~ Radar RSl Legacy
[ Radar RSl
[~ Ultrasonic RS|
[~ Lidar RSl
[~ Mehicle Control
[ Additional

Figure 6.2: Vehicle Data Import

By activating the separate boxes the user can choose which specific components of the cur-
rent vehicle model should be replaced by those of another vehicle. After clicking Import a
browser opens where the vehicle from which the information is to be imported can be
selected.

Vehicle Submodels

This chapter describes the parameters of a vehicle data set that need to be specified. The
following sub-sections refer to the various tabs of the Vehicle editor.
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Configuration

Vehicle Model Parameterization

Vehicle Submodels

- Vehicle (Frl): Allows the user to move the origin of the default coordinate system of
the vehicle. (on tab Assembly > Configuration)

- Description: A short description of the vehicle can be given here, that will be shown
in the file browser where a vehicle can be selected.

(o CarMaker -

Engine

Body

mGrnpmc

Mount

Chassis
Powertrain

Trim Load

1 Info

Vehicle Data Set: MyCar.car

Vehicle Data Set File w

ISSEMHN} Budy] Suspensicns] Steermg]T\res] Eraka] Powertrain l Sensars | Vehicle Cantrol ] Addmona\]

Reference frame  Position x/y/z [m]
saicn vshicls(Fri) | 00 00] 00

Overall mass [ka) 1320.02
Description

Generated - not validated - Compact Car

FileCreator CarMaker/Vehicle Data Set Generator 2020-06-19 15:24:35
driveline front drive

engine power 107.0 kW (146 PS) at 5666.0 rpm

max. torque 247.0 Mm at 1833.0 rpm

unloaded weight 1320.0 kg

length x width x height 4350.0 mm x 1790.0 mm x 1455.0 mm
wheel base 2635.0 mm

track width front 1551.0 mm

track width rear 1549.0 nm

rear overhang 845.0 mm

tire 205/55 R16

Engine Mount

| CarMaker - Vehicle Data Set: Examples/DemoCar

Figure 6.3: Configuration definition

Config-
uration

Mount
Body
Chassis
Powertrain

Trim Load

1 Info

msraphic

Engine

Vehicle Data Set File w

lﬁﬁﬂm“w} Budy] Su.ﬁpensmns] Sleermg]T\ras] Erake] Powertrain l Sensors | Vehicle Control ] Admlmna\]

— Frame Engine (FrEng)

Positionx/y/z[m] 0.0 00 o0
Orientation x/y/z [deg] 00| 0.0 00

Mounting: | Generalized JointForce

Fnr:el" Fur:evH Force z" Torgue x || anquev‘

Mode: #| DVA

Stiffness [M/m] 50000.0 Dampinag [Ns/m] | 500.0
Amplification [ 1.0 Amplification (] [ 1.0
[~ Length 10 [m] ]

CarMaker Quick Start Guide

Figure 6.4: Engine definition
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Vehicle Submodels

The CarMaker multi-body model also includes a separate engine body that is elastically
mounted on the main body. The position can be defined, as well as the location of the joint
(or joints) between engine and main body. The joint can be change to a flexible mounting
consisting of spring damper elements which can be characterized in the lower part of the
dialog.

Body

- Hitch: Position of the hitch if a trailer is being used. (on tab Assembly > Body)
- Jack: The four positions of the jacking points
- Virtual force: Point of attack of a possibly defined virtual force.

The exact description of these fields can be found in the User’s Guide.

B CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set Fie w | close |
nssemhw} Budy| Suspensmns] Steering | Tires | Brake | Powertrain ‘ Sensors | Vehicle Control | Add\lmna\]

Config- Position x/y/z [m]

uration Hiteh [ 04 0.0 04

Engine Hitch System 3

Mount ¥ = e

Jack FL | 3048] 0772] 0288
Body JackFR 3.048) -0.772] 0.288

JackRL. | 1277] 0767, 0288
Chassis JatkRR 1.277] -0.767]  0.288

i

Virtual force [ 247] 00] 0582
Powertrain

Trim Load

1 Info

E}Graphic

Figure 6.5: Body definition

Chassis

In this tab, the below listed masses including their center of gravity and inertias are defined.
Again, the definition takes place in the design position, according to the frame defined in
the tab Assembly > Configuration.

e Wheels: Unsprung spinning masses.
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* Wheel carriers: Unsprung masses that do not rotate.

Powerirain.

Vehicle Data Set

‘on CarMaker - Vehicle Data Set: Examples/DemoCar.

94

Vehicle Submodels

File =

lﬁﬁﬂm“w} Budy] Su.ﬁpensmns] Sleermg]T\ras] Erake] Powertrain l Sensors | Vehicle Control ] Admlmna\]

Config- Positionx/y/z [m] Mass [ka] M. of inertiaxfy iz [kom?] >
yaln Wheel carrier FL 340 078 ; 180 02 02 02
Engine Wheel carrier FR 18.0 0.2 0.2 02
Ll Wheel carrier RL 130 0.1 0.1 0.1
Body Wheel carrier RR £ ] U 13.0 01 041 01
Wheel FL 3.40f 0789 0.29 25.0 0.4 12 0.4
& = Wheel FR 3.40 —0.739‘ 0.29 250 0.4 12 0.4
B | ihesi RL 0863 0772 029 250 0.45 07 045
Wheel RR 0.863 —0.772‘ 0.29 250 0.45 0.7; 0.45
Powertrain
Trim Load
1 Info
msraphic

Figure 6.6: Chassis definition

Here the reference frame, position, orientation and mounting frame of the optional power-
train masses are defined. Depending on the model, different mounting frames are available.
A detailed description of the available frames can be found in the User’s Guide.

Vehicle Data Set

File =

lﬁﬁﬂm“w} Budy] Su.ﬁpensmns] Sleermg]T\ras] Erake] Powertrain l Sensors | Vehicle Control ] Admlmna\]

| CarMaker - Vehicle Data Set: Examples/DemoCar = B

Close |

s

Config- Ref. frame Position x/ v/ 2 [m] Orientationx/y/z[deg]  Mounting Mass [ka]
atien — Drive source 0
Engine Engine [0 wf| oo[ oof oo | oo oo o0 [FEng.l [ 00 b
LIRS Gearbax FiD | oo oo oo0| oo oo 00 |FEng.l| 00 b
Electric motor ~ FID | oo oo oo oo oo oo [fa L[ U0 ¥
Body 1 1 -
Gearbox M FrD | oo] oof oo | oo] oo o0 |FA L[ 00
= Tank FID | oof oo/ oo| oof oo o0 |Fr1A =B
Chassis »
~—— Drive source 1
i Electric motor ~ FID | 0of oo 0 oo oo o0 mA L[ 00 »
Gearbox M FrD | oof  ogf o o0o0f oo o0 A o[ 00 »
— Drive source 2
Trimload || Eectic motor  FiD | ool oo o[ 0o oo 00 A S [ 00 ¥
Gearhox M FID | 0of oo 0| oo oo o0 |Fr1A =B
— Drive source 3
Electric motor ~ FiD | oof oo 0 oo oo o0 mA L[ 00 »
Gearbox M FrD | oof  ogf o o0o0f oo o0 A o[ 00 »
—— Power supply
LV hattery 0 FiD | oo] oof 00| o0o0f oo o0 A L[ 00
LV battery 1 FID | oof oo/ oo | oof oo o0 |Fr1A |
HV battery 0 FrD | oo] oof oo | oo] oo o0 |FA L[ 00
HV battery 1 FID | ool onf oo | oof oo o0 A L U0
1 Info
msraphic

Figure 6.7: Powertrain definition

The arrow to the right of each position definition allows the user to jump to the correspond-
ing tab in the Powertrain section of the Vehicle Data Set.
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Trim Load

« Trim Loads: Additional loads that can be fixed to the frames A and B or the Engine
frame. These are available by activating the checkbox in the corresponding row. An
individual name can be set, too:

|| CarMaker.- Vehicle Data Set: MyCar.car EE
Vehicle Data Set Fie v | ciose |
Aﬂﬂm“v] Budy] Suspensions l Steering ‘ Tires ] Braks. l Powertrain l Sensursl Wehicle Control ‘ Additional ]
Fi
Config- Ref. frame Position x /y /z [m]  Mass [ka] M. of inertia % / y / z [kgm Mounting
Urstiot ¥ |MyloadNot FiD | 20 04/ 06 800 | 00 00| 00 [FriA o
Engine || ~|WyloadNo2 FiD | 10 03] 06 €00 | 00 00| 00 [FriA 4
Mount — [Thm Load:2,|| FiT ‘ 0 ‘..‘ o oo oo o o0 [FriZ ﬂ
[T i) i 0 ] L L FriA -
Body 0 |00 e |
] [illi 0. FrA ﬂ
Chassis ; - . ,—‘ j
=
Powertrain =
I - &
Trim Load ~ Close
; I™ Reference
= I~ Bodies
[~ Marker
i
= I Powertrain
¥ Trim Loads
(|
-
-
=
1 Info 5
Z1Graphic I

Figure 6.8: Trim Load definition

Please note that besides this, mass definitions can also be set in the powertrain section
for several drivetrain components.

6.3.2 Body

| CarMaker - Vehicle Data Set = ¢
Vehicle Data Set File w close |
Assemb\v} Eﬂﬂvl Su.ﬁpensmns] Sleermg]T\res] Erake] Powertrain l Sansms] Vehicle Control ] Admhuna\]
4
m Vehicle Body: &| Flexible Edit
v Manual body split
Outer Shell Positionx/y/z [m] Mass [ka] M. of inertiax/y/z [kamd ﬂ
—— | BotyA [ 243 0.0 06 | 1301.0  470.0] 1500.0] 1600.0
Aero- I
dynamics | | B2 E [ 243 uu} 06 | 8505 2350 750.0] BOOD.D
—— | JointA-B | 243] 00| 0.6
Stiffness
Mode: #| Characteristic Value
WRctanonX(Torsion) 73&!&1@@Y(Bending) Joint Body A - Body 8
Stiffness (Mmideg] | 17436.0 | 55807.
Angle [ Torque [ [ Angle| Torque [
Ideg]|  [Nm] Ideg]|  [Nm] | | By A
; i ; (b Ratation X
5 — i
Amplification [] | 10 | 10
Damping
Damping [Nmsfdeg] | 87179 | 27904
1 Info Amplification (] 1.0 1.0
msraphic

Figure 6.9: Structure definition
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Vehicle Submodels

In this tab the user can choose which vehicle model is adequate depending on the Vehicle
Body:

* Flexible body

» Rigid body: Simple vehicle model without flexibility

According to the model that has been chosen, various parameters must be defined for each
body (A: front; B: rear):

» Position of the mass(es)

» Weight and moments of inertia of the mass(es)

» Optionally: Stiffness of the vehicle body joint, linear or non-linear

» Optionally: Damping of the vehicle body joint

The masses are defined in the so called design position. This is a fictitious state where no
forces and weights are applied.

Outer Shell

?" CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File w ‘ Close |

Assembly ‘ Budy| Suspensicns] Steering | Tires | Brake | Powertrain ‘ Sensors | Vehicle Control | Addmona\]

LA

3D Ohject | .
Picture  |Compactfcl i

Structure

i)

T

I

Aero-

I
e

cO——0"

i

Bounding Box Positionx/y !z [m]
Rear lower left point 0.0] 0.895 0.288
Front upper right point 435 -0.895 1.455

1 Info

msrapmc

Figure 6.10: Outer Shell definitions

The object file used by IPGMovie can be selected under 3D Object. This file can be created
by the user himself with the help of a CAD software, or one can be bought online. The file
must be in .obj, .kmz, .dae or .3ds format.

File definition guidelines:

* ONLY polygons and triangles, NO splines or free forms.

+ No more than 50,000 nodes.

* If this option is available while generating the file: generate the normal for all points
» Colors: Generate the corresponding material file.

Under Picture, a picture in the PNG format can be chosen to be displayed in the CarMaker
main GUI and in the vehicle editor as preview to the 3D object. The user can also create an
own picture by taking snapshots of the 3D-object by the help of the button next to the file

browser.
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The Bounding Box parameters define the a bounding box for the vehicle, the bounding box
will be shown in the graphic showing the picture.

Aerodynamics

"o CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set Fil w Closs |

Assemb\v} Bﬂﬂ!ll Suspensmns] Steering | Tires | Erake] Powertrain ‘ Sensors | Vehicle Control ] Add\lmna\]

Structure Interface Fositionx/y/z[m]
Marker IEC 00 06
Outer Shell Genter of pressure | 2044 | 00| 0728
Aero. Aerodynamics T o0 Model w
dynamics Model #| 1D Look-Up Table =
Reference area [m7 I_i'ﬁf Crosswind build-up
Reference length [m] | 4.35  Kind of build-up: | Step
Aerodynamics Characteristics tD[] eS[] cLf]

_tau] ] cS[ oL cRM[ cPm[ cvm[T
Mdegl] E| ©  H M H HJ

-180.0 045 0.0/ 0148 00 0002 00
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-140.0] -0.96) -0.806| 0.276| -0.174 -0.208| 0.183
1200 -0.743) -1.287| 0.285] -0.378) -0.218| 0.191
-100.0) -0.255| -1.445| 0.258| -0.483) -0.085| 0.075
900 0.0 -1.334 0.235 0453 0.0/ 00
-80.0] 0.24] -1.356| 0.259 -0.455 008 -0.07

-70.0| 0.467) -1.284| 0.276 -0.408) 0148 043 L

-60.0) 0.648 -1.123| 0.285| -0.33 0.9 -0.167 0.3/4\

-50.0] 0.758) -0.904| 0.285 -0.234] 0.197| -0.173 i o
T VANV AR

-40.0 0. -0.66) 0.276) -0.143] 047 045 = Ak o
= -30.0| 0.736) -0.425 0.257) -0.071) 0.123| -0.109 \;)/
3 ‘ -25.0| 0.684| -0.319) 0.245| -0.045| 0.096 -0.086 A2

200/ 062]-0.226) 023]-0.025 0.07] -0.063); 05

msraphic ‘

cRM [] cPME] cYM [

Figure 6.11: Aerodynamics definition

The aerodynamic model applies additional forces and torques depending on the vehicle
speed and wind direction at the Marker.

An explanation for the various coefficients can be found in User's Guide and Reference
Manual.
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6.3.3 Suspensions

CarMaker Quick Start Guide

Spring

o CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File Close |
Assemb\” Budy] Suspensiuns] Steermg]T\res] Eraka] Fowertrain l Sensors | Vehicle Control ] Addmona\]
m me' Raar‘ M
4 =
Secondary Stiffness Mode ; 10D Look-Up Table
Spring Stiffness [M/m] T
Compress Force | Force [N]
Damper
P [m] N
0.0 00 20000-
Hatzer 01| 23544
1.00 235440 4 6
Buffer 1
s - (g
Stabilizer Amplification ] | 10 032 n| 0z 04 o0& 08 |
[ Length 10 [m] 14 |
Kinematics
Compliance
Wheel
Bearing
External
Forces

Figure 6.12: Spring definition

In this tab the user can independently define the spring stiffness and free length of the front

and rear axle.

Secondary Spring

o CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File Close |
Assemb\” Budy] Suspensiuns] Steermg]T\res] Eraka] Fowertrain l Sensors | Vehicle Control ] Addmona\]
Spring Frunt| Raar‘ |
4 =
[ — Stiffness Mode: ¥| 10 Look-Up Table
Sprng Stifness (/m] G
Damper Travel tz Force |1 soopdk Foree (M)
i ml |
-1.0 -5000.0 3000
BunEe 01 -8000
0.0 oo - :nuu | Wheel travel tz m]
Buffer 1 0.1 500.0 -1 08 Ol 02 08 1
1.0 50000
i 1 -3000
Stahilizer L
Amplification [-] 1.0 -5000-
Kinematics
Compliance
Wheel
Bearing
External
Forces

Figure 6.13: Secondary Spring definition

The Secondary Spring tab allows the user to define a spring force that describes the force
generated by the suspension bushing torsion.
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Damper

o CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File Close |
Assemb\” Budy] Suspensiuns] Steermg]T\res] Eraka] Fowertrain l Sensors | Vehicle Control ] Addmona\]
Spring Frunt| Raar‘ \L}f
ReConiany Damping Mode; | 1D Look-Up Table
Spring Damping [Nsim] 0. Push
Velocity Force | Force [N]
Damper
sl ]
0.0; 0o 7004
S 01| 17850 o]
1.0] 88412 1
Buffer 1 3007
| IR —— Meocky i)
Stabilizer R EIRTT 02 04 06 08 1
|| Amplification [] [ 10
Kinematics Damping [Ns/m] 5000 ¢ Pull
Velocity Force | Force [N]
Compliance [mis] N J 1
— 0.0; 0.0 2000
Wheel 0.1 337.54
Hearing 10| 24844
(| 1000+
External |
e | [ N \elocity [mis]
— S owz oo 02 ' 04 05 ' 08 i
Arnplification [] [ 10
[~ Dampertop mount Bamping [Ns/m] 1600,0 Sfiffn [Mirr} [ 10000000

Figure 6.14: Damper definition

Here the damper characteristics can be defined independently for the front and rear axle.
Push and pull domain are separately parameterized.

Buffer

| CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set Fil w Closs |

Assemb\v} Budy] Suspensiuns] Sleermg]T\ras] Erake] Powertrain l Sensors | Vehicle Control ] Admlmna\]

Spring Frnnl| Rear‘ M
3 -
Secnr!dary Stiffness Made: ¥/ 1D Look-Up Table
Sering Stifiness [W/m] o0 Push
Compress Force | A4 Foree [N]
Damper
[m] N oo
0.0 00 siin]
0.005 28.01 E
01| 73518 S
Buffer 1 0.015 14472 3000+
Stabilizer Amplification [] | 1.0 e R 063 008
| Length &0 [m] \ 0022 I parallel
Kinematics Stifness [N/m] G Pull
Compress Force | A4 Foree [N]
Compliance [m] M| o]
—_— 0.0 00 il
Wheel 0.005 144.72 1
Bearing 0.01 654.22 10000
External 0.015 22180 ennu:
Forces | 0_1_1_2_ 6684.3 4% | 2000 " Compression [m]
Ampiification [] | 10 00fappp) 0005 0015 0025
Length &0 [m] \ -0.078 I parallel

Figure 6.15: Buffer definition

The buffer limits the wheel travel and is defined using the parameter length tz0.

If the wheel travel reaches the given distance (tz0), the buffer acts like an additional spring
with the parameters set in the tables.
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Buffer 1

| CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File close |
Assemb\v} Budy| Suspensiuns] Steering |T\ras | Erake] Powertrain l Sensors | Vehicle Control ] Admlmna\]
Spring Frnnl| Rear‘ M
= fiffriess M | 1D Look-Up Tat
S Buffer 1 Mode: &| £ 1DL [
Spring Nt NI ’_
Compress Force | A Foree [N]
Damper
[m] (10 [
Buffer ] 70.0 10000+
- N 20001 . Compression [m]
Stabilizer MEiMmaaEtn 1.0 EXTIN LT 003 005 007
i 0.0 I parall
Kinematics il /| 0000 Pull
Compress Force | 1ao0ndk Feree [N
Compliance [m] m R
! 14000+
Wheel ] 10 b
Bearing T 0 munu:
6000
External f!
Forces N 2000+ . Compression [m]
Al 008y, 005 0015 0.025
[ 008 [ parall

Figure 6.16: Buffer 1 definition

Optionally, an additional buffer can be added within either a parallel or series connection.
To parameterize this second buffer, the same parameters are used as for the primary buffer.
Internally, both buffers are merged to one with the same characteristics.

Stabilizer

| CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File Close |

Assemb\” Budy| Suspensiuns] Steering |T\res | Erake] Fowertrain l Sensors | Vehicle Control ] Addmona\]

Spring Front| Rzar| L
]
Secondary Stiffness Mode: ¥/ Characteristic Valug
Spring Stifness (/m] [ 150000
P Force | Forca [N]
Ratl m] | e
[ 1 8000
Buffer i
4000
Buffer 1
2000
Compression fm]
|t oy pn i
— E] n_l 02 04 06 08 i
Arnplification [] | 10 | 200,
Kinematics
Compliance
Wheel
Bearing
External
Forces

Figure 6.17: Stabilizer definition

The stiffness of the stabilizer is entered in N/m (approximation of virtual spring on small dis-
placements). Optionally, you can parameterize it in Nm/rad.
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Kinematics
| CarMaker - Vehicle Data Set: MyCar.car
Vehicle Data Set File » | close |
Assemb\” Budy| Suspensiuns] Steering |T\res | Erake] Fowertrain l Sensors | Vehicle Control ] Addmona\]
Spring Fruntl Raar‘ \L!f
Secondary Kinematics ambedded  Model w
Spring Model #| Linear 2 DOF Edit
Static Compr. It Steer
Hamiper [m] [mim] Ieriten] (i)
Translation t 0.0 0.023 | -0.31
Buffer Translation ty 0.0 001 oo
Translation &z 0.0 10 1| -0.033
Buffer 1 Static Compr. Ihpoe Stear
[rad] [rad/m] (tadim] [radim]
Stahilizer Rotation rx | 0.013 ‘ 0.241 i -0473
Rotation ry | 0.0 -0.049 o} \ -1283
W Rolation | -00] 0131 il 50
i Static Compr. Oppos Steer
Compliance [m] [mim) [y [mimj]
Deflection ISpring 0.0 -10 ‘ 00
Wheel
Bearing Deflection IDamp 0.0 -1.0 | 00
Deflection 1Buf 0.0 -1.0 | 00
External Deflection IStabi 0.0 10 | 00
Forces

Figure 6.18: Kinematics definition

CarMaker offers a kinematics model where it is not necessary to parameterize the geome-
try of the vehicle axle. For CarMaker, the only important information is the positions of the
wheels according to the wheel travel, steering rack displacement (for a front axle only) and
the movement of the opposite wheel (in case of a rigid rear axle).

In the Model option of the kinematics tab, following kinematic characteristics can be chosen:

Mode Description Axle

Linear 1 DOF Linear uni-dimensional kinematics. The kinemat- |rear
ics only depend on the wheel travel.

Linear 2 DOF Linear two-dimensional kinematics. The kinemat- |front
ics depend on the wheel travel and the steering
rack displacement. This mode can be used to
parameterize a steered front axle for an indepen-
dent wheel suspension.

Linear two-dimensional kinematics. The kinemat- |rear
ics depend on the wheel travel and the movement
of the opposite wheel. This mode can be used to
parameterize a rigid or semi rigid rear axle.

Linear 3 DOF Linear three-dimensional kinematics. The kine- front or rear
matics depend on the wheel travel, the steering
rack displacement and the movement of the oppo-
site wheel. This mode can be used to parameter-
ize a steered rigid axle or semi rigid front axle.
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Mode Description Axle

External SKC file | Non-linear kinematics. The kinematics are param- | front or rear
eterized by the kinematics tables written to an
external file.

In this case the values of each variable are
defined for numerous steps of the wheel travel
(e.g. from max. to min. bouncing, at step size
5mm) and optionally by the steering rack displace-
ment or the wheel travel of the opposite wheel.

External MBS Non-linear kinematics. The kinematics are mod- | front or rear
File eled by a multi-body system.

The values tx/ty/tz and rx/ry/rz define the translations and rotations of the wheel in the three

directions:
Model ®| Linear 3 DOF
Static Compr. Oppos. Steer
[m] [mim] [mim] [mim]
Translation 0.0 0.023 0.0 -0
Translation ty 0.0 -0.01 0.0 -0.014
Translation &z 0.0 1.0 0.0 -0.033
Static Compr. Oppos. Steer
[rad] [radim] [radim] [radim]
Rotation nx 0.013 0.241 0.0 -0.473
Rotation ry 0.0 -0.049 0.0 -1.293
Rotation rz -0.0 0.131 0.0 50
Static Compr. Oppos. Steer
[m] [mim] [mim] [mim]
Deflection [Spring 0.0 -1.0 0.0 0.0
Deflection I[Damp 0.0 -1.0 0.0 0.0
Deflection [Buf 0.0 -1.0 0.0 0.0
Deflection IStahi 0.0 1.0 0.0 0.0
Figure 6.19: Translations and Rotations
Parameter Description Unit (Compress) Unit (Steering)
X wheel base variation M/Myheel travel M/Mgteering rack travel
ty track variation M/Myheel travel M/Msteering rack travel
tz wheel travel variation M/Myheel travel M/Msteering rack travel
(it is of course
always 1!)
rx camber variation rad/mwheel travel rad/msteering rack travel
ry spin angle variation rad/Myneel travel | "@d/Msteering rack travel
rz toe variation rad/ Mwheel travel rad/ msteering rack travel
ISpring Spring length variation M/Myheel travel M/Msteering rack travel
IDamp Damper length variation M/Myheel travel M/Msteering rack travel
IBuff Buffer length variation when | m/Myneel travel M/Msteering rack travel
activated
IStabi Stabilizer length or angle M/Myheel travel M/Msteering rack travel
variation (according to the or or
unit you have written the sta- rad/Myneel travel | Fad/Mgteering rack travel
bilizer stiffness)
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The columns represent the following options:

Column Description

Static The values in this column indicate the design static values, i.e when
the wheel travel is null.

Compress The values in this column give the variation of a parameter (e.g the
camber angle rx, in rad), per meter of wheel travel.

Steering The values in this column give the variation of a parameter (e.g the
camber angle rx in rad), per meter of steering rack displacement. This
column is used only for a front axle (Mode Linear2D).

Opposite The values in this column give the variation of a parameter (e.g the

camber angle rx in rad), per meter of wheel travel of the opposite
wheel.

The axis are oriented as follows:
» X: Forward

o Y:Left

e Z:Upwards

To parameterize an axle, only the left side needs to be implemented, since CarMaker
assumes symmetry and automatically mirrors the values for the other side.

A non-linear kinematics description is more accurate, but according to the users needs, a
simple, linear 2D-model is often be sufficient. A detailed explanation of the non-linear kine-
matics can be found in the User’'s Guide, as well as in the Reference Manual.

"o CarMaker - Vehicle Data Set: MyCar.car
Vehicle Data Set Fils w close |
Assemb\v} Budy.| Suspensiuns] Sleermg] T\res.| Erake] Powertrain ‘ Sensors | Vehicle Control ] Add\lmna\]
Spring Frnnl| Rear‘ M
o
Secondary Model; #/| Linear Frame Fri
Sering i ity itz dre iy drz
[rmit] [min] [min] [radirg) [radin] [radin]
Damper Force X 0.0 0.0 0.0 0.0 0.0 0.0
Foree Y 0.0 0.0 00| DU| 0.0 0.0
Buffer Force Z 0.0 0.0 0.0/ 0.0 0.0 0.0
dix diy diz drx dry drz
Buffer 1 [miNm] [miNm] [miNm]  [radiNm]  [radiNm]  [radiNm]
Torque X | 00| 00| [ 00| 00| 0.0
Slabiir Torque ¥ [ 00| 00! 00! 00| 00| 0.0
Torque Z | 00| 0.0 0.0 0.0 00| 0.0
fmemetics it dty it dre dry drz
[min] [miN] [min] [rad/N] [rad/n] [rad/i]
Force opposite X 0.0 0.0 00| 00| 0.0 0.0
Force opposite Y 0o (1) 00| 00| 0o (1)
Wheel Force opposite Z 00 0.0 0.0] 00| 00 0.0
Bearing '
dtx dty diz dre dry drz
External [miNm] [miNm] [miNm]  [radiMm]  [radiNm]  [radiNm]
Forces Tarque opposite X | 0.0| [ 00/ 00| 0.0| 00
Torque opposite Y | 00| 00| [ 00| 00| 0.0
Tarque opposite Z | 0.0| 0.0 00| 00| 0.0| 00

Figure 6.20: Compliance definition

The compliance description is optional. Following models can be activated:
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« Linear description of the compliance model: To activate this model, either
CoeffConstrFrl (coefficient defined in the vehicle frame) mode or CoeffConstrFr2
(coefficient defined in the wheel carrier frame) mode must be selected.

* Non-linear compliance model: To activate this model, the user has to write the compli-
ance table in the same file as the one used for the linear kinematics. An explanation for
the non-linear compliance model is provided in the User’s Guide and Reference Manu-
al. The compliance triggers additional movements of the wheel, depending on the forc-
es applied at the wheel center.

The parameters in the tables of the editor are coefficients that define the variation of the
wheel position in meters, rad per Newton (when a force is applied) or Newton-meters (when
a torque is applied) at the wheel center and possibly at the wheel center of the opposite
wheel.

Wheel Bearing

| v CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set Fie w | close |
Assemhw‘ Eludy| SHSPE"SiHHSI Steering | Tires | Brake | Powertrain ‘ Sensors | Vehicle Control | Add\lmna\]
Spring rmm| Rear‘ \ﬁ
ey v Whee| Bearing Friction
Spring Friction Coefficient [ 0003
- Bearing Radius [m] i 0.03
Al Amplification £l ! 0

Buffer

Buifer 1

Stabilizer

Kinematics

Compliance

Wheel
Bearing

External
Forces

Figure 6.21: Wheel Bearing definition

This option activates/deactivates the consideration of the friction in the wheel bearings.
Upon activation, further parameters can be visualized.

The wheel bearing friction is characterized by a single constant coefficient that defines the
friction force on the bearing. The bearing radius enables evaluation of the friction torque on
the bearing based on the friction force.
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Vehicle Data Set

Assemb\v} Budy| Suspensiuns] Steering |T\ras | Erake] Powertrain l Sensors | Vehicle Control ] Admlmna\]

Fil w Closs |

Shrng External Forces
Model #/
Secondary
Spring Spring
Model | MyModel
Damper &ty
Buffer Damper
Model | MyModel
Buifer 1
s Buffer
Stabilizer
Modsl #|
Kinematics
Stabilizer

Compliance Model #/

Wheel
Bearing

External
Forces

Components

MySuspEF_Spring Model w

MySuspEF_Damper Model w

pedded Model w || L

B

Edit

Edit
Mode| w
Edi

Mode| w

!

Figure 6.22: External Forces definition

These options are only useful when the CarMaker kinematics model is extended, e.g. when
modeling an active stabilizer.

6.3.4 Steering System

| CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set

Steering
Mode| g Static Steer Ratio (GenAnagle)

Assemb\v} Budy| Su.ﬁpensmns] SIEEFiﬂ!!I Tires | Erake] Powertrain l Sensors | Vehicle Control ] Admlmna\]

Fil w Closs |

e Modsl w Q
Edit

— Steering Gear Ratio
Steering i
Pt Bl | Mods: &) 1D Look-Up Table: Ratio

Me Pinion angle Ratio
[deg] fradim) |-/
-180.00, 7500
-90.00 8000
- -60.00 8500
-30.00 90,00
-20.00 10000
0.00, 10000

Ratia [radim]

__Finian angle [deg]

-0 50 160
il

Figure 6.23: Steering system definition

In this window, the relation between the steering wheel angle or steering wheel torque and
the steering rack displacement is defined. This relation can be linear (Mode Static) or non-
linear (Mode Dynamic).
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The overall steering ratio, e.g. the ratio between the steering wheel angle and the wheel
angle is calculated in CarMaker by multiplying the steering ratio Rack to steering wheel with
the kinematics parameter rz (angle variation of the wheel at the z axis) in the Steering col-
umn of the kinematics description.

Additionally, an extended steering model called Pfeffer with Power Steering is available.
This model provides a highly detailed mechanical model of the steering column, intermedi-
ate shaft, torsion bar and steering rack, including damping and friction effects. The power
steering can be either hydraulic or electric.

6.3.5 Tires

In this tab, the default tire set used in combination with the vehicle is selected. Please refer
to section 6.6 'Creating a New Tire Data Set’ for more details on supported tire models and
their parameterization.

6.3.6 Brake System

| v CarMaker -Vehicle Data Set: MyCar.car

Vehicle Data Set Fie w | close |
Assemhw‘ Eiudy| Suspensmns] Steering | Tires | Emkel Powertrain ‘ Sensors | Vehicle Control | Add\lmna\]
Brake Modsl v || ¢
Model | Hydraulic
General‘ CummlH syslam|
System Model w |
Model ¥| Pressure Distribution |
Mode: #| Pedal Force
L
Pedal Actuation to Pedal Force [N] 500.0
Pedal Force to phC [hariN] [ o4
Response time [s] I 0.005
Build-up time [s] E
Pressure to Brake Tarque [Mmibar] Frant Rear
Left [ B25| 4125
Right | B.257 4125
Parkbrake Torque atWhee! [Nm] Front Rear
Left 00| 14908
Right | 0.0| 14808

Figure 6.24: Brake system definition

The user can decide between two hydraulic models:

» PresDistrib: This is a simple model that converts the force at the brake pedal to a pres-
sure in the master cylinder and then to a braking torque at each of the four wheels. The
parameter Pedal Actuation to Pedal Force defines the force required by the driver to
push the brake pedal to the maximum.

» External File > HydESP: This model can be used if an ESP controller model is to be
simulated. With this hydraulic model, the hydraulic part of the brake system can be
parameterized as well. This is specific to the ESP assembly.
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6.3.7 Powertrain

Model

! L_M CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File Close |

Assemb\” Budy| Suspensicns] Steering | Tires | Erake] Powertrain ‘ Sensors | Vehicle Control I Addmona\]

Powertrain o0 Mol w || 7
Model & Conventional Eif
m Pre-Configuration &
Drive
Source
Driveline
::::; General Information = Powertrain: Conventional
Powertrain: ~ Conventional
Bagiiar Engine: Look-Up Tahle RL Powertran Control
bl Starter. Starter
Clutch: Friction
Gearbox Manual
Driveline: Front drive
PT Cantrol. Generic
ECU. Basic
TCU:
MCu: Basic =
BCU
Power Supply: - RR
A Driveline: Front drive
E—— i
Integration Substeps [ g-ij

Figure 6.25: Powertrain Model definition

The option Powertrain - Model selects the kind of torque generation. Conventional would be
a common combustion engine, whereas OpenXWD disconnects the gearbox output from
the wheel in order to insert for e.g. a generator. This model can even be used to replace the
whole engine and drivetrain. The options GT_SUITE and AVL_CRUISE offer an interface
to co-simulation with an external drivetrain modeler.

The option Driveline - Model selects the kind of transmission: front, rear, or any kind of 4WD.
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Vehicle Data Set

Assemb\” Budy] Suspensicns] Steermg]T\res] Eraka] inemainl Sensors | Vehicle Control ] Addmona\]

File

Powertrain fbedied Model w M
Model &/ Conventional 4
General fntine Starter
Engine Motor Clutch Gearbox Tank
Ganera\" TurqueH Fuel Ccnsumption" Turbocharger || Intake Manifold || Eodies‘
Mapping Model. g 10D Look-Up Table: Drag and Full Load
Driveline
Drag Power Full Load Power
Power tot. Speed| Torque " lot.Speed| Torque ™ | 5 Toraue ]
Supply [rpmj|  [Nm] J frpml|  [Nm]
i 451 64 -4.312 451 64 0.0
e 60218 -4.312 60218 61.895
75273 -7.187 75273 11341 150+ Exponent 1|
1017.9 -9.719 1017.8| 18094
12831 -12.251 12831 2223
1466.4| -14.002 1466.4| 23804 0.
1649.7| -15762 1 1649.7| 24541 e 7
1833.0] -17.502) 18330 2470 - - e o “‘:D-n[n iy
37485 -35801) 37495 2469117
i = | sp
Amplification | 1.0 Amplification | 1.0
I Torgue correction depending on environment conditions
St ] 101325 Fressure corrsction coefMoient [ ]

Figure 6.26: Engine definition

The user can define the torque characteristics of the engine. In the menu Engine Model, the
type Look-Up Table and in the menu Engine Mapping the type 1D Look-Up Table: Drag and
Full Load can be chosen.

This option lets the user parameterize the full load power characteristic, as well as the neg-
ative torque of the engine when slowing down.

Fuel Consumption

| CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File Close |
Assemb\” Budy] Suspensicns] Steermg]T\res] Eraka] inemainl Sensors | Vehicle Control ] Addmona\]
Powertrain mbedded Model w |[#
Model & Conventional Edit
General ﬂ%ﬁ' Clutch | Gearhox Tank |
General | Tarque ‘ Fuel Consumption || Turbocharger || Intake Manifold || Eodies‘
¥ Fuel Consumption
Drivefine Mode: #| Specific
Pawer Rot. Speed|  Torque| Consump. 25 Toraue [Nm]
Supply [rpm] [Nm]| [okwh]
500.0 12.0 600.0
Control ®
Unit 10000 10.0: 600.0 * : -
10000 30.0 500.0 1604 : : s *
1000.0, 500 400.0 H $ 5 2 .
1000.0 66.0 360.0 H b4 . g L]
1000.0 95.0 300.0 o . 4 3 ¢ .
H .
10000 120.0 270.0 : - . : *
15000 50 6000 4 i
15000, 200 5000, N 4o oo
Amplification 1] o |
Fuel
Fuel capacity [I] 50.0
Initial filling [%] 80.0
Fuel density [kg/l] 0.75
Heatvalue [kWhikg] 113

Figure 6.27: Fuel Consumption definition

Optionally, the user can also determine the consumption characteristics of the drivetrain.
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Gear Box

Here you can parameterize the gear ratios. Nine different gearbox models are available.
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| CarMaker - Vehicle Data Set: MyCar.car = ¢

Vehicle Data Set Fils w Closs |

Assemb\v} Budy] Su.ﬁpensmns] Sleermg]T\res] Erake] Pﬂlﬂﬂﬂfﬂiﬂ} Sansms] Vehicle Control ] Admhuna\]

embeddad MQ

Powertrain
Model & Conventional

General Engine Sn‘I'::i:rr m Gearbox Tank

General || Torsional SpnngH Convertst Factors H Duak-Mass F\-,wh-e-a\|
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Figure 6.28: Clutch definition

| CarMaker - Vehicle Data Set: MyCar.car
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Driveline: Front drive

Figure 6.29: Gear box definition
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o CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File Close |
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Powertrain mbedded Model w |[#
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e External Torgue off
C‘l’;:i{"' " External Torque to Differential
" External Torgue to Wheels

Driveline: Front drive

Figure 6.30: Driveline definition
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In CarMaker you have the possibility to choose, if your car is front, rear or all wheel driven.

You also have the option to select a shiftable all wheel drive and to determine if you want
your driveline to be considered flexible or stiff.

Differentials

| CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File close |
Assemb\v} Budy] Su.ﬁpensmns] Sleermg]T\ras] Erake] Powertrain ‘ Sensors | Vehicle Control ] Additiona ]
Powertrain embeided Model ¥ | [ §
Model & Conventional Edit
General General ront Axie Rear Axle | Diff. Center ‘
Drive Differential " Drive Shafts ‘
Source
Coupling Model: mbeddad  Model ‘w
Model & Edit
Ezlﬂe'; Inertia in kgm 0.001  Transmission [] 3126
L Inertia out (kgm 0.001 Efficiency | 1.0
Cllijmi{t!l Inertia Cage [kgn] 00
n

According to the selected transmission mode, various differentials need to be parameter-
ized. The differential models are the same. Default Mounting is left to right, other options

are for very specific use.
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Vehicle Submodels

If the user requires a very simple differential coupling model, as is common on most Euro-
pean cars, Coupling Model = not specified can be defined.

Modeling torque vectoring is possible by choosing the option Coupling Model = Torque Vec-
toring. Then, the torque distribution can be manipulated by DVA (direct variable access).

6.3.8 Sensors

[ CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File » ‘ Closs |

Assemb\y‘ Bndy| Suspensimns] Steering | Tires | Brake | Powertrain ‘ SEHsnrs| Vehicle Cantrol | Addmona\]
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S R
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__byLane
Global — All Object Sensors
Nawvigation Obsemvation radius [m]| 5000 Positionxiyfz[m] | 0.0 0.0 0.0
Radar Orientation x/y/ z [deg] ’— 0.0 0.0
Field of view h /v [deg] [ 16.0 4.0 (max 180)
Camera Range min/ max [m] 150.0
Updats [Hz] - Cycla offsat[] | 603 0
Target selection 2| Nearest
Radar RSI Calculation class 2| NearestPoint
Ultrasanic Visualization color 2| Pink
RSl Body mounting ;’:FMF(
Lidar RSI |~ External sensor motion ™ Traffic object quantities

Camera RS|

Figure 6.32: Sensor definition

The sensor model can place different sensor types on the car:

» Slip Angle Sensor: as reference where the side slip angle should be measured

» Inertial Sensor: sensor to measure accelerations and translations at certain points on
the car

» Object Sensor: sensor to detect obstacles in the environment

» Free Space Sensor: sensor to detect occupied and free space in the surroundings,
considers traffic objects only

» Free Space Sensor Plus: sensor to detect occupied and free space in the surroundings,
considers whole 3d geometry (works on GPU)

» Traffic Sign Sensor: for traffic sign recognition
» Line Sensor: sensor which detects road markings

* Road Sensor: sensor to determine at a predefined preview distance important road
specific attributes

» Collision Sensor: recognizes collisions with traffic objects

» Object by Lane Sensor: detects objects specifically on the individual lanes relative to
the ego vehicle

» Global Navigation Sensor: simulates the positions of satellites and a receiver build in
the vehicle

* Radar Sensor: physical sensor model for obstacle detection

» Camera Sensor: generates a camera specific object list based on ground trouth infor-
mation
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Radar RSI Legacy Sensor: used for sensor component development in CarMaker 8
Radar RSI Sensor: used for sensor component development in CarMaker 9
Ultrasonic RSI Sensor: used for sensor component development

Lidar RSI Sensor: used for sensor component development

Camera RSI Sensor: raw signal interface to image data provided by IPGMovie

Vehicle Control

|« CarMaker -Vehicle Data Set: Examples/DemoCar

Vehicle Data Set File ‘ Close |

Assemb\y‘ Budy| Suspensicns] Steering | Tires | Brake | Powertrain ‘ Sensars |Vehicle Control I Addmona\]

Control

ekl | Contrere |
Model ®| Acceleration Control + ACC 1

Control = Q

Model 1 Acceleration function ¥ ACC

Control Acceleration confrolier factor P | O UD,{

Model 2 Acceleration controller factor [ ] | 10

Control Referenced object sensar ;RadarL

Moseh 3 Brake threshold [ | 02

Control Initial time distance [s] i 18

Model 4 Minimal distance [m] | 20.0

Control Minimal acceleration [misd i 25

Model 5 Maximal [mis3] | 10

Control Distance controller factor kd -] n Bﬁ!j

Model 6 Distance controller factar kv [-] | 20

Control Velocity controller factor kv [-] i 13.0

Model 7

Control

Model 8

Control

Model 9

Figure 6.33: Vehicle Control selection

In the Vehicle Control tab you can select controller models like driver assistance systems.
A maximum of ten Vehicle Control models can be used in one vehicle. Available example
controllers are the following:

"Acceleration Control + ACC"
Example for an active cruise control including an acceleration controller to transfer the
target acceleration to a gas / brake pedal position.

"Generic Longitudinal Control"
The example longitudinal controller comes with an autonomous emergency braking
assistant and a forward collision warning algorithm.

"Generic Lateral Control"
The example lateral controller consists of a lane keeping assistance system and a lane
departure warning.

Additional

The field Additional Parameters gives room for additional, optional parameters.
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Save as a New Data Set

6.4 Save as a New Data Set

After you have finished parameterizing your Vehicle Data Set, you can save it independent
of the TestRun. This gives you the possibility to use this Vehicle in other TestRuns.

To save a Vehicle Data Set: In the CarMaker main GUI, click  Parameters > Car to open
the Vehicle editor.

In the Vehicle editor, click on File > Save

'w CarMaker - Vehicle Data Set: MyCar.car

Vehicle Data Set File w Close |
MNew

.ﬂ\ssembl\rl Bﬂdlfl Suspensions] Steering | Tires | Brakel Fowertrain | Sensors | Wehicle Control Opeh Ctrl-o
Save Ctrl-s

Import Crl-j

Vehicle Body: X| Flexible - -
Generator Ctrl-g

Save as ... Q
oy

v Manual body split
Outer Shell Positionx/yfz [m] Mass [kg]l M. of ineria x/y/z [kamd ﬂ
Body A [ 2.47] 00[ 0592 [ 11517 | 41479 14207 15307
Aero- I I
243 0.0 0.6 650.5 2350 750.00 800.0
dynamics | | 20%B !___...' ___! L | | | !
—— | JointA-B | 2.4?| 0.0/ 0592
Stiffness
Mode: | Characteristic Value
_ Roigtien X {Torsiony. _RotationY(Banding) | yqint gody - Bady 8
Stiffness [Nm/deg] | 17436.0 | 55807.0

Angle | Torque [ | Angle| Torque |
[degl| [Nm] | || [deg]| [Nm]

Body A

. Retatian X

Rotation ¥
a5

Amplification [ | 1.0 | 1.0 fody 8
Damping %
Damping [Nmsideg] | 871.79 | 2790.4
1 Infa Amplification (] [ 1.0 1.0
E}Graphic ‘

Figure 6.34: Vehicle Data Set

Type in the name of the new Data Set you are saving, e.g. “My_Car” > OK.

The new data set is now saved and can be integrated in other TestRuns.

6.5 Creating a New Trailer Data Set

CarMaker also provides a trailer model that can be parameterized in the same manner as
the vehicle model.
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Creating a New Tire Data Set

For further information regarding the trailer parameterization, please refer to the User’s
Guide or the Reference Manual.

Creating a New Tire Data Set

Analogously to creating an individual Vehicle Data Set, the user can also create his own
Tire Data Set. CarMaker provides a variety of tire models:

» Real Time Tire (RTTire), based on the TYDEX format
» Pacejka (MF-Tire)

e MF-Tyre | MF-Swift

* Michelin TameTire

» FTire provided by cosin

» IPGTire, for MotorcycleMaker only

Please note section 6.3.5 'Tires’ in the Release Notes for the exact version compatibility.

Overview of Tire Models

RTTire

TYDEX is a common format used to save measured tire characteristics. With the help of a
tool, the TYDEX file is converted into binary and, at the same time, an Infofile that points to
the binary file is generated.

Finally, the Infofile is uploaded in the CarMaker GUI.

As soon as the characteristic curves of the tire (e.g. from measurements or the tire manu-
facturer) are present, the user can generate the corresponding RTTire file for CarMaker on
their own.

Pacejka Tire
CarMaker supports the standardized Pacejka format, as well as the ADAMS Property file.

In the first case, if the user has the Pacejka parameters, they merely need to be written in
the corresponding parameter fields of the Tire dialog. Via this dialog, the parameters can
also be imported from a .tir file.

MF-Tyre / MF-Swift

These tire models (formerly known as TASS Delft Tire) are supported by CarMaker, the
libraries are directly integrated in CarMaker, a separate license from TASS International is
needed for the version 7.3 and for some advanced functionality. Input are the Magic Param-
eters similar to the standard Pacejka model (ADAMS property files are accepted, t00).

Michelin TameTire

CarMaker provides an interface to the thermo-mechanical tire model by Michelin. The
library is directly integrated in CarMaker, a separate license from Michelin is needed. Input
are tire property files from Michelin.
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FTire provided by cosin

The FTire model from cosin can be co-simulated with CarMaker. For this, the FTire library
is dynamically linked to the CarMaker application. A full FTire installation including a license
file is required besides the CarMaker installation and license.

Tire Model Exercises

Open any random example TestRun (since this makes no difference for the aim of
this exercise) and select any car, e.g. the  DemoCar. Click on Select in the Tire field in
the CarMaker main GUI. Click on the tire MF_205 60R15 V91 and then Edit.

This is an example of a Pacejka file, in which the user can directly write the values of his
parameters.

In the CarMaker GUI, click on Select in the Tire field again, but this time click on the
tire MF_205 60R15 V91r and then Edit.

This is an Infofile that points to an ADAMS property file (see tab Model Parameters > Import
Adams Property File).

Open the ADAMS property file: Use a text editor to open the file from your CarMaker
project folder under Data > Tire > Examples > TirePropertyFile >
MF_205_60R15_V91.tir.

This is the same Pacejka data set as previously opened, but this time it is written in the
ADAMS format.

Please note that an internal mechanism can erase the instability at standstill caused by the
Pacejka model.

The changes made in this section must not be saved.

Each CarMaker example vehicle contains a suitable tire data set. Tires only need to be
selected in the main GUI, if the user wishes to change the tire configuration for a TestRun.
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Chapter 7
CarMaker for Simulink

7.1  Starting CarMaker for Simulink

Open CarMaker using the Windows Start Button and create a new project: CarMaker
GUI > File > Project Folder > Create Project and toggle the option CarMaker for Sim-
ulink Extras . Click on OK to finish creating the project folder.

o CarMaker 9.0 =
il | Application Simulation Bardmeter Hins Help a41PG

D ot - Select
- IVING
Trailer: -
Select

Bpén
T e

PBroject Folder I" Create Project.. =

Data Poo Update Project hre: ) o CarMaker - New Project
Encrypt Data Select. :
- |load: Okg New Project

Fo
Project Folder
|CACM_Projects\PROJECTHNANE |

Storage of Resulis

= Included Features
Perf:  &/max Mode: ] collect anly
[~ Sources / Build Environment
Status:
Buffer, [~ Sources: Extra Models
FMI Examples
auit Gli-q Time l ;C — ‘: —
v Carlaker for Simulink Extras
Distancs: we | siap [ avot | || [Samakertor simuink Exras | setectal
i _ | B Sactal|
[~ Concerto Wark Environment Default

Figure 7.1: Creating a new project with CarMaker for Simulink Extras

Now the project folder contains an additional folder called src_cm4sl which provides the
interface to Simulink.
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Close the CarMaker GUI and open Matlab. As working directory , select the folder
src_cmdsl of the project.

In the tab on the left that displays the contents of the working directory, right-click
on the file called cmenv.m and run the script. This option ensures the connection
between CarMaker and Matlab.

Open the generic.mdl model.

Now, Matlab should have opened, followed by the Simulink environment and the Simulink
model generic.mdl. A successful start-up procedure leads to the following window:

fone BiE 4 B E o e o] B Loan]

E = S ] [T] New Variabi Analyze Cos = = >3 B it
= OF L3 [Ciendres db (R selemvanse AR S al | FH @ rreterences O3 | () .4 Btk
2 ) openvariabs ~ {7 Runand Time - = Request Support
New New New  Open |\ [Compare Import Save g Simuink  Layout [ Set Path Add-Ons  Help
Scripgt Live Script  * - ‘Deta Workspace [/ Clear Workspace « [ Clear Commands ~ = - ~  [ZlLeamnMATLAB
FiLE VARIABLE cone SIMULINK ENVRGNMENT. RESOURCES =
< E B/ ] sre_cmasi -le
ent Folde Command Window @ | Workspace [
Name £ Name £ [value g
[ ACC.mdl Third Party Support License -- for use only to Swgport products interfac
[ AccelCtil_ACC mdl software under terms specified in your company's ressgicted use license
L app_tmp.c
& BodyGtrl.mdl >> cmenv
o
#] BodyCtrl_params.m CarMaker directory: /fs/opt/ipg/carmaker/linux64-9.0pre28
] CM_Main.c addpath /fs/opt/ipg/carmaker/linux64-9.0pre28/Matlab Choose the SrC_Cm4SI
L] CW_Vehicle.c addpath /fssoptsipa/carmaker/linux64-9.0pre2s/Matlab/R2017b
&) cmenv.m addpath /fs/opt/ipa/carmaker/Linuxsd-S.0pre2s/MMasL folder of your new
- EEEET N oddpath /fs/opt/ipg/carmaker/linux64- 9.0pre2s/MMASL/R2017b
*a generic_uservehicle.mdl addpath /fs/opt/ipg/carmaker/linux64-9.0pre28/TMasL 1 -.t
("4 HydBrakeCU_ESP mdl addpath /fs/opt/ipg/carmaker/linux64- S.0pre28/TMASL/R2017b pI'OJe ”
€] HydBrakeCU_ESP_params.m addpath /fs/opt/ipg/carmaker/linux64-9.0pre28/CMAsL
Do addpath /fs/opt/ipg/carmaker/linux64-9.0pre28/CMASL/R2017b
L] 10vec.h addpath /fs/ul/SolutionsEngineering/TestUmgebung/work. fsc/Quickstartguide/CMIG/ <
L) makefile defs Initialize CarMaker for Simulink.
L] makefile-targets Done.
) Makefile P 5 generic - Simulink third party suppornt use —alx

" PTBatteryCU.mdl
‘ PTControl.mdl
% PTEngineCU. mdl
%4 PTMotarCU.mdl

%4 PTTransmCU.mdl E—
4 SingleTrack.mdl -
) SingleTrack_params.m © [Palgeneric » v
& SoRABS.mdl
) SonABS_params.m oy CarMaker 8.0pre28
] startup. dict
% TractCtrl. mdl = Generic Car Model
5 Userec i B P
[ Userh It already contains averything to run a simple CarMaker simulation,
[ UserBrake.mdl =) Build your Simufink mode around it
% UserPowerTrain. mdl —
=

[ UserSteer.mdl
[ UserSteerTorque. mdl
[ UserTire.mdl

) UserTire_params.m

Open Cartjjilr GuI

»

Ready 100% odeds

generic.mdl (Simulink Model) A [« [ Il [« [T

Additional options used Simulink representation Link to the CarMaker GUI.
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applications. open the CarMaker/GUI.

Figure 7.2: MATLAB window with Simulink model generic.mdl
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Troubleshooting

Sometimes, the file type .mdl is not associated with Matlab. A new dialog appears which
asks to open the file with one of the following programs:

Wie soll diese Datei gedffnet werden?

. Office XML Handler

Paint

V Wi lmproved - A Text Editor
i

E VLC media player

Windows Media Player
™ word
Figure 7.3: Open with... dialog window

The Matlab executable must be found and then the execution can be confirmed.

Start-up confirmation

Matlab and CarMaker for Simulink work together by extending Matlab’s search path, so it
knows where to find the CarMaker for Simulink blockset and auxiliary commands. The Mat-
lab search path is extended by the execution of a small script called cmenv.m, which is
located in the mdl subdirectory - src_cmd4sl - of the CarMaker project directory. The script
may be executed manually, but there is also a way to invoke it automatically each time Mat-
lab is started or a model is loaded.

The most important rule is: Always keep the cmenv.m script in the same directory as the
Simulink model. Whenever a Simulink model which contains the CarMaker subsystem
block from the CarMaker for Simulink blockset is loaded, cmenv.m will be executed auto-
matically. This default behavior should be sufficient for most uses of CarMaker for Simulink.

The cmenv.m script should generate a message similar to the one below in the Matlab con-
sole window:

CarMaker directory: c:/IPG/carmaker/<architecture>-<version>

addpath <Drive>:/IPG/carmaker/<architecture>-<version>/Matlab

addpath <Drive>:/IPG/carmaker/<architecture>-<version>/Matlab/vx.x-r20xxx
addpath <Drive>:/IPG/carmaker/<architecture>-<version>/CM4SL

addpath <Drive>:/IPG/carmaker/<architecture>-<version>/CM4SLVX.x-r20xxx
addpath <Drive>:/path/tolyour/project_dir>/src_cm4s|

Initialize CarMaker for Simulink.

Done.

7.2 First simulation with CarMaker for Simulink

The generic.mdl example is intended as a start-up example model and provides a basic
CarMaker subsystem (similar to the stand-alone version) without any additional control
blocks. More details on this system will follow in the next section.
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Make sure any previously open CarMaker GUIs are closed.

Double-click on the “Open GUI* block in Simulink and the CarMaker for Simulink win-
dow pops up:
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Figure 7.4: CarMaker GUI called up from MATLAB

The same GUIs as in the previous chapters, containing information on loading a TestRun,
changing a vehicle, etc., will open.

Load the TestRun Product Examples > Examples > BasicFunctions > Driver > Han-
dlingCourse.

The environment is very similar to usual. Even within Simulink, no special Simulink model
needs to be prepared.

When the model “Generic* is loaded, the simplest vehicle model (this time it's a model, not
a data set!) is selected, which is in fact the counterpart of the model available in the stand
alone version of CarMaker.

Now CarMaker for Simulink is ready to work!

In the following section, the basic differences between CarMaker stand-alone and CarMak-
er for Simulink are presented.
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Description of the CarMaker Environment in Simulink

7.3  Description of the CarMaker Environment in
Simulink

CarMaker for Simulink is a complete integration of IPG’s vehicle dynamics simulation soft-
ware into the MathWorks modeling and simulation environment Matlab/Simulink.

Thus, in CarMaker for Simulink, the user is able to extend the vehicle model itself.

The highly optimized and robust features of CarMaker were added to the Simulink environ-
ment using an S-function implementation and the API functions that are provided by Matlab/
Simulink.

CarMaker for Simulink is not a loosely coupled co-simulation but a closely linked combina-
tion of the two best-in-class applications, resulting in a simulation environment that assures
both good performance and stability.

Because of this integration, it is now possible to use the power and functionality of CarMak-
er in the intuitive and full-featured Simulink environment. Furthermore, using CarMaker in
Simulink is no different than using standard S-function blocks or built in Simulink blocks. The
CarMaker blocks are connected the same way other Simulink blocks are connected and
existing Simulink models can now easily be added to the CarMaker vehicle model with lit-
erally a few clicks.

Integration does not, however, mean a loss of functionality, seeing as all the features that
make CarMaker the premier software in its domain have been included, and can now be
used together with Simulink’s rich tool set. The CarMaker GUI can still be used for simula-
tion control and parameter adjustments, as well as defining maneuvers and road configu-
rations. IPGControl can still be used for data analysis and diagram plotting. IPGMovie can
still be used to bring the vehicle model to life with realistic animation and rendering of the
multi-body vehicle model in three-dimensional space.

In short, CarMaker for Simulink is not a stripped down version of the original, but a complete
system that can become a part of any Simulink simulation quickly and easily. The next steps
will show just how easy it can be.
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Advantages and Disadvantages of using CarMaker for Simulink

CarMaker for Simulink

CarMaker -

Advantages and Disadvantages of using

Feature CarMaker running in Simulink | Comment

standalone

Simulation Speed Very fast. Slow, especially with addi-| The simulink environment
tional models. needs a lot of processing

power. The best perfor-
mance is reached when the
simulink model "generic.mdl"
is used. Even then, there is a
big difference in simulation
speed.

Even little add-ons to the
model can lead to perfor-
mance loss.

Flexibility Full flexibility. Limited flexibility, every| The c-code offers the oppor-
implemented model will be | tunity to use parts of the sim-
simulated by Simulink even ulation only when they are
when it is not needed. needed (e.g. additional sub-

models, dynamic traffic
objects).

Exchange of models | Easy, all global Very easy due to the graphi- To use the interfaces of the

variables cal interface, but only the stand alone version, c-code

accessible in
the c-library are
available.

interface variables and User
Accessible Quantities are
available.

knowledge is required.

Manageability

Very good. C-
Code is ideal to
be structured.
Creating libs
and objects,
you can also
share models
easily.

Very good up to a middle
diversity level.

From there on models
become harder and harder to
manage.

The c-code is mostly well
arranged and is better to
understand than the complex
simulink models.

Graphical modeling

Less comfort-
able, only using

Very easy.

Especially for beginners and
people without c-code knowl-

RealTime- edge, it is a lot easier to
Workshop. extend CarMaker in Sim-
ulink.
Value for Money Very good. Same as stand alone + addi- Both variants are available in

tional costs coming with Mat-
lab/Simulink.

the CarMaker/Office pack-
age. For the Simulink version
you need Matlab and Sim-
ulink which cost a few thou-
sand Euros in addition.
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Chapter 8
Features of the CarMaker for Simulink

blockset

The CarMaker for Simulink blockset can be found in the Simulink library browser, under
Blocksets and Toolboxes. It is possible to double click CarMaker for Simulink or simply type

>> CarMaker4SL

in the Matlab command window.
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8.1

Figure 8.1: Simulink library

General Information

The CarMaker for Simulink blocks of the CarMaker subsystem are directly fed through and
run with a fixed step size of 1ms, independent of the rest of the model.

CarMaker for Simulink blocks do not have continuous states in the Simulink sense of the
word. They have internal state variables but these are integrated using CarMaker internal

8.1.1 Block Properties
solvers, independent of Simulink.
8.1.2  Modeling Principles

The CarMaker for Simulink simulation model consists of a subsystem containing a chain of
individual blocks. When Simulink executes CarMaker, all blocks of the CarMaker block
chain must be executed exactly once and in order. Algebraic loops involving individual
blocks of the CarMaker block chain are not permitted.
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There are two possibilities for replacing existing CarMaker functionalities by Simulink
blocks:

» Overwriting signals
» Disabling unneeded internal CarMaker functionalities using special parameters

It is not recommended to:
* Replace, remove or reorder CarMaker blocks

For further detail, please refer to the following demonstration examples and their descrip-
tions.

Purpose of the Sync_In and Sync_Out Ports
The Sync_In and Sync_Out ports are an important concept for CarMaker for Simulink.

« They guarantee the proper order of execution for the CarMaker blocks.

* They let the user choose exactly when a CarMaker dictionary variable is accessed with
a Read CM Dict or Write CM Dict block. E.g., this way it is possible to read the most up
to date value of a variable (and not the value calculated in the previous cycle) or over-
ride the value of a variable only after it has been calculated internally by CarMaker.

Utility Blocks

In the following sections the most important elements of the CarMaker for Simulink library
are introduced. A complete description of all CarMaker for Simulink blocksets can be found
in the Programmer’s Guide.

CarMaker GUI

The CarMaker GUI block is used to connect the Simulink model to a running CarMaker GUI
process. If no running process is detected, it will prompt the user to open a new CarMaker
GUI and manually reconnect the undetected CarMaker GUI or cancel the connection
attempt.

Double clicking on the CarMaker GUI block can also be used to switch between models,
e.g. to activate a certain model in case several models have been loaded in Matlab. The
active model is the one that will be simulated when the Start button in the CarMaker GUI is
clicked. Please also note that the simulation must be started this way, via the GUI.
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CarMaker Dictionary Blocks

CarMaker Dictionary Blocks

Read CM Dict

The Read CM Dict block reads a variable in the CarMaker dictionary and provides its cur-
rent value on the block’s output port. The variable doesn’t need to be defined with a Define
CM Dict block in the model; any existing dictionary variable can be read.

Block Parameters: Read CM Dict - %
Read CarMaker Dictionary Variable(s) (mask) (link)
Copy the value(s) of the specified variable(s) of the CarMaker data

dictionary to the block's output port(s). Separate the names of the
variables with commas.

Parameters

Variable Name

Show Sync Port

Figure 8.2: Read CM Dict block parameters dialog

Enter the name of the variable in the block’s parameters dialog. In the model, the name will
be displayed inside the block’s symbol.

When a non-existing dictionary variable is defined as a parameter of a Read CM Dict block,
Simulink will report the following error at the start of the simulation:

Variable abcde’ not in dictionary.

Write CM Dict

The Write CM Dict block writes the current value at the block’s input port to a variable in the
CarMaker dictionary. The variable doesn’t need to be defined with a Define CM Dict block
in the model; any existing dictionary variable can be overwritten.

| &, Block Parameters: Write/ CM Dict
Write CarMaker Dictionary Variable(s) (mask) (link)

Copy the value(s) of the block's input port to the specified variable(s) of
the CarMaker data dictionary. Separate the names of the variables with
commas.

Parameters

Variable Name

Show Sync Port

oK Cancel Help

Figure 8.3: Write CM Dict block parameters dialog

Enter the name of the variable in the block’s parameters dialog. In the model, the name will
be displayed inside the block’'s symbol.

When a non-existing dictionary variable is defined as a parameter of a Write CM Dict block,
Simulink will report the following error at the start of the simulation:

Variable abcde’ not in dictionary.

CarMaker Quick Start Guide Version 9.0.2



Features of the CarMaker for Simulink blockset 126

CarMaker Dictionary Blocks

8.3.3 Define CM Dict

A Simulink model can define its own variables in the CarMaker dictionary, because there
might be signals that are to be monitored with IPGControl or accessed using Direct Variable
Access. Furthermore, only signals defined in the CarMaker dictionary can be saved as part
of the CarMaker simulation result file.

The Def CM Dict block defines a variable in the CarMaker dictionary.

When a dictionary variable is defined in a Simulink model, it is recommended to prefix its
name with the model’s name or other convenient abbreviation. This makes it easier to iden-
tify the model’s variables in the dictionary with tools like the CarMaker GUI or IPGControl.

Example: A dictionary variable xyz defined in a Simulink model called MyModel should be
given the name MyModel.xyz or MM.xyz.

It is important not to define a dictionary variable with a Define CM Dict block that is already
defined somewhere else. Currently no error message will be issued in this case.

i@ Block Par
Define CarMake

ary Variable (mask) (link)

Define a new variable in the CarMaker data dictionary.
Parameters

Variable Name

Unit

Strictly monaotone
Type Doubled -
DVA write access | Mone -

Mumber of states (0=no states)
a0

First state (if number of states I=0)
0

Initial value
0

|L| ; Cancel . _ﬂel_p

Figure 8.4: Define CM Dict block parameters dialog

Enter the name of the variable in the parameters dialog. In the model, the name will be dis-
played inside the block’s symbol.

The variable may also be given an unit. This is recommended, but optional. IPGControl pro-
vides a list of the units used in CarMaker. Specifying a unit serves as a kind of documenta-
tion for the variable and allows IPGControl to display it on one axis with other dictionary
variables of the same unit.

If the variable’s values are strictly monotonic, increasing over time, the Strictly monotone
checkbox should be selected. Again, this is an information that tools like IPGControl can
use for proper display of the values.

The variable’s type can be chosen according to the user’s needs and the range of values of
the variable. Possible types are floating point types and integer types. When in doubt, it is
advised to use Double.
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For discrete variables (any of the integer types) with values starting at 0 and a reasonably
low upper limit (e.g. an indicator light that is either on or off), it may make sense to specify
the number of discrete states of the variable. For the indicator light there would be two dis-
crete values (0=off, 1=0n). Again, this information serves mainly IPGControl, which displays
variables with a limited number of states in a special, space saving way. Specifying a value
of 0 in this field means that no special state info is available. For the Double and Float type,
the value of this field is ignored.

Dictionary Initialization

When CarMaker for Simulink has been started, but before the first simulation is run, the
CarMaker dictionary does not yet know of any additional dictionary variables that will be
defined in the model. To make these variables known to CarMaker for Simulink at start-up,
a file called startup.dict can be created in the model directory (src_cmd4sl folder), that
describes the variables’ properties.

The file is in ASCII format and may contain empty lines, comment lines starting with a hash-
tag and lines defining dictionary variables. Each line containing a variable definition con-
sists of five columns, separated by tabs and spaces:

e Column 1: Name of the variable.

* Column 2: Unit of the variable. A minus sign (-) means that the variable has no unit. The
unit is used only for display purposes, in tools like IPGControl. CarMaker for Simulink
uses Sl units internally and doesn’t convert units automatically.

* Column 3: Variable type. Following types (and their corresponding C-type) are allowed:

double double
float float
ulongunsigned long
longsigned long
ushortunsigned short
shortsigned short
ucharunsigned char
charsigned char

¢ Column 4: Number of states.

» Column 5: Special properties. Again, these are only for display purposes. If the variable
is monotone and increasing, the user must specify "M", otherwise "-".

Examples:

PT.GearBox.GearNo - long 0
PT.Engine.rotv rad/s float 0 -
Car.Distance m float 0 M

For more information refer to the documentation of the Define CM Dict block.
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Chapter @
How to Extend the Simulink Model

This chapter will give a short yet intensive insight into the Simulink implementation of Car-
Maker. Basic Matlab and Simulink knowledge is a requirement.

9.1 Overview of the CarMaker Simulink Structure

Double-click the CarMaker block.

CM_FIRST DrivMan YehicleConiral PG Vehicle CM_LAST

Figure 9.1: General structure of CarMaker in Simulink

This is the general structure of CarMaker in Simulink. CarMaker’s Simulink representation
consists mainly of a Driver/Driving Maneuver, Vehicle Control and Vehicle model.

The rest (IPGRoad, etc.) is contained in the CarMaker library for Simulink.
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Double-click the DrivMan block.

Orivklan SST
Drividan Key.
DrivMan UserSignall
Drivhtan UserSignalt
Drivhlan UserSignalz
Orivhhan UserSignals
Orivhlan UserSignald
Orivhtan SelectorCirl
Orivhlan Gearlo
Drivhlan Brake
Drivhtan BrakePark
Drivhtan Cluich
Drivhlan Gas
Orivhtan Sieering Ang
Orivhlan Sieering AngVel
Drivhtan Stesring Anghce
Drivhlan Sieering Trq

Drivhdan Out

There's rarely a reason to averride DrivMan signals.
Use the VehicleControl interface for this purpose.

Figure 9.2: DrivMan block in Simulink

Two details can be recognized:

» The green block on the left is an S-function. This means that the full functionality is
masked behind this level.

« Output of the S-function is a multiplexed signal that contains all information regarding
the interface of the S-function.

Return and double-click the Vehicle block.

(2 } "‘-—=1I "'{STOPI
Vhel.Model. Source L—l

VehicleSoaurce_Bulllin

Syne_Out
Vel Wheel In

Vhel Mise
CarAndTralier PowerTrain
D,
VhelCirl Brake
i
VhelCilPT

Figure 9.3: Vehicle block in Simulink

Here, a more detailed segmentation can be found. The Simulink block representation ends
with an S-function each time.
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Example

9.2 Example

9.2.1 Contents

» Calculate a new variable.
« Link the variable to CarMaker’s User Accessible Quantities.
» Observe the changes using IPGControl.

90.2.2 Create a new Simulink Model

Open the Simulink Model “Generic.mdl".
Save it as “My_Model.mdI".

Open the Generic.mdl model and then from this model, open the model My_Model.mdl.

9.2.3 Prepare the extension

Sometimes the calculation of additional variables takes place independent of the vehicle
behavior. But most times, some information regarding one or more state variables of the
vehicle is required to generate the necessary information.

For example, if the user wants to calculate the current engine power, information regarding
the engine speed and torque is required.

Multiplying both and using the factor Watt to Horsepower will deliver the current engine
power in the unit Horsepower.

Now navigate to the mdl folder of the project directory, open “My_Model.mdI“ and double-
click the CarMaker block.

N It doesn’t matter in which subsystem the change takes place. Simulink offers subsystems
—(9)— only for graphical purposes. At simulation time, sub-systems do not exist.
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Switch to the CarMaker > IPG Vehicle > PowerTrain subsystem.

1
Syne_In

2
Vhel Wheel PT

3
WhelCirl PT

PawerTrain

When raplacing the entire powertrain,
be sure ta disable the IPG powerlrain modal by using the p

Sync

PT IF ignition
PT IF Oy it

BT IE ()

BT IS Gaartln

BT IE Enging. sot,
PTIE Trg Sup

BT E Teg v
PTIE e z

BT IE Tog E

=

BT 1€ 0N maan
BT IE WET o

PT IF WFI oty

PT |F \WFI Tegy BAW

PT IF WFI Tegy Drive

PT IF WF) Tey Supg WG

BT |E WEL Teg

PT IF \WRI mt

<Your madel here=

PT IF WHI oty

PT IF WRI Tey BN

maodel Model Manager off in the vehicle GUL

PT IF WRI Try DOrive

PTIF WRI Try S WE

PTIF WHI Tey

PT IF WRI Tey may

PT IF \WRE m1

BT |E WS o,

BT IS WRE T B2W
PTIEWRS Tig Dova

BT |E WHE Trq Suppawic

BT |E WAS Ty Crokal

PT IF WRR Trq_BrakeReq_mex

PowerTrambUpd

Figure 9.4: Powertrain Subsystem

Now, information from the powertrain component “Engine” will be accessed.

9.24 Connect Inputs

The most important values of the simulation are the signals and busses between sub-mod-
els. If possible, these signals should always be used to get information regarding the simu-

lation.

Sometimes additional information is required, that is displayed in IPGControl as a User
Accessible Quantity, but may not be available as a Simulink signal.

In this case the information can be accessed using a CarMaker4SL block Read CM Dict.
More information on the CarMaker’s Simulink blockset can be found in section 'Features of
the CarMaker for Simulink blockset’ on page 122.

With this block the user can access all User Accessible Quantities offered by CarMaker.
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Example

Take a multiplication block and link the engine speed signal “PT.Engine.rotv* to one
entry.

S <Your modal hers
Vhel Wheel PT

Sync_Out

VhelCirl PT

Power Train

PowerTrainUpd

When replacing the entire powerlrain,
be sure to disable the IPG powerlrain model by using the powertrain
madel "Madel Manager off' in the vehicle GUL

PT IF WRR Trq_BrakeReq max

Figure 9.5: Multiplication Block

Now, a signal can be read from CarMaker in order to receive the engine torque. Since the

engine torque is not directly available as a Simulink signal, the same values have to be
gained from CarMaker, as are available in IPGControl.
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Open the CarMaker for Simulink library (see  section

'Features of the CarMaker for
Simulink blockset’ on page 122 ).

Library: CarMakerdSL
File Edit View Display Diagram Analysis Help

o HEE-9-
CartakerasL |

@ [Pa|CarMakerasL b

Q CarMaker 9.0pre12
Gopright c) 1P Automativs GroH
]
L] <
B 1l CM
= “azg 4
(] i Hodl e pon Carbiaker GUI
Configuration
DifroCMDEl  RusdCMDE  WisOMOW  SgnalAcuss
‘Raad CM Paramatar. Vool Inal Cig
Tl Object PGRosds oo
e

. Tire STI
Body Frama

ADASRP Recave ADASRF Send

Please note:
e “The CM Var blocks are for Usa with Simulink Codar only
r Smutaion in
Plagin
o IS .
B FomClier | ToCHVa
» | |&

Ready

99%

Figure 9.6: CarMaker for Simulink Library

Import a “Read CM Dict” block to the model, and define its prop

erty as
“PT.Engine.Trqg" in order to read the torque from CarMaker.

Library; CarMakerdSL
Eile Edit View Display Diagram Anaysis Help

= ol = . G
B EE-o-
o Carbaker4sL |
[ @® |[FaCarllakerdSL b
e ey CarMaker 9.0pre12
Your modei s g QU
el Wheel BT THmrE ] it i b
wE
Elreq SuppoBamBy =]
PTIF Mg SuppoPoyifs = e
Tar? eec NS
- = e =i CM
Lo
TS O
= s Tamaar ‘Opan Cariaker GUI
[or |zhh:=w ey BralaReq
PowerT T PowsTranup
Sy Define CM Dict Wrkta GM Dict Sinal Access
s
Tiehuen
. Vehice il C1g
be sure to disabla the IPG powerlrain modal by using the pawertrain
model Model Marager of'in the veficla GUL B

IPGRoads.

Tre Tira STI

Figure 9.7: Read CM Dict

In CarMaker, the power is given in Watt. To monitor it in Hp, a gain block must be inserted
for the conversion. The gain block is to have a value of 1/735.5. Now, define a new quantity
to calculate the engine power and plot its value in IPGControl.

CarMaker Quick Start Guide Version 9.0.2



9.25

How to Extend the Simulink Model 134
Example

Add a “Define CM Dict” block to the model and define its property as “Engine.Pow-
er’.
Add a “Write CM Dict" block to the model and define its property as “Engine.Power":

“. Library; CarMaker4SL
Eile Edit View Display Diagram Anaysis Help

E‘{_‘ Rl mﬁ% >~ @~
GCarMaker4SL |

© [Facarmakerssi »

Q CarMaker 9.0pre12

Copyria () PG Automsta G
o
=

[~ e
S o Saip ™M
= it ol Tt Open Gattakr U1
Cortoumaen
TRosd G Dt ® Sonal Aoz

Raad CM Paramater Vehicie Iniial Cla

Write CMDict  Define CM Dict

Read CM Dict

Figure 9.8: Engine Power

Now switch to the CarMaker GUI and load the TestRun  Product Examples > Examples
> VehicleDynamics > _QuickStartGuide > Step4_VehicleDynamics . Open IPGControl
and start the simulation.

The engine variable that was just created can now be observed in IPGControl.

Demonstration Examples

CarMaker comes with a number of example models demonstrating various applications,
features and modeling techniques. All examples can be found in the src_cm4sl folder of the
CarMaker project directory.

These examples include:

* The Simulink model
* Matlab parameter files and scripts
» Configuration files, e.g. TestRuns, vehicle data, tire data, etc.

A detailed description of all models and the special blocksets used can be found in the Pro-
grammer’s Guide, section "CarMaker for Simulink".

Please note : The examples intend to demonstrate how to make use of a particular interface
of CarMaker for Simulink, but not to provide an elaborate application or a full fledged
replacement for a particular CarMaker subsystem.

All examples can be used with the Matlab versions supported by CarMaker. An overview of
these versions can be found in the CarMaker Release Notes (CarMaker GUI > Help >
Release Notes).
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Chapter 10

Additional Information About CarMaker

10.1

10.2

What are the Differences between each
CarMaker Version?

First, a distinction must be made between the two general types of CarMaker versions:

» CarMaker/Office: Purely software simulations.
e CarMaker/HIL: CarMaker software adapted for Hardware In the Loop simulations.

CarMaker is a virtual vehicle environment. It can be used “as is“, without any additional soft-
ware. This version of CarMaker applies to CarMaker Office, as well as CarMaker/HIL.

CarMaker can also be used in connection with Simulink: In this case, the CarMaker models
are integrated in the Simulink environment. When the simulation is started, Simulink is the
simulation software and uses the CarMaker library to perform the calculations. This version
applies only to CarMaker Office.

Alternatively, extra models can be built using Simulink (in the CarMaker environment), by
generating C-code correspondent to the model with the Real Time Workshop, and integrat-
ing the resulting library in CarMaker in the C level. This version applies to CarMaker Office
and CarMaker/HIL.

Typical Tests

The following table is a list of the most important pre-defined TestRuns that display other
capabilities of CarMaker. These can be found in the Product Examples.

It is advised to load TestRuns that seem interesting and helpful to see and understand how
they are built. The column labelled path indicates in which sub-directory a TestRun can be
found:
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Typical Tests

Topic Path Comments
Real Tests | ./Examples/VehicleDynamics/ These TestRuns show you how to build common vehicle
dynamic tests including slalom, lane change and steady
circle tests. Pay attention to the definition of IPGDriver,
especially to the maximum values of longitudinal and later-
al acceleration and to the road definition.
Real Tests | ./Examples/VehicleDynamics/| These tests show the influence of control systems such as
StabilityControl/ ABS or ESP. Pay attention to the road definition “Override
Attributes for each road segment), and the maneuver def-
inition (manual control of the pedals).
Using real|./Examples/BasicFunctions/ Usage of real measurements. Pay attention to the follow-
measure- | Maneuvers/RecordAndReplay/ | ing menu: CarMaker GUI > Parameters > Input from File.
ments You can check the content of the input file by clicking on
Content (Box Input File).
Drive ./[Examples/Powertrain/Driving- These tests include popular drive cycles, such as FTP,
Cycles Cycles/ NEDC short and NEDC long. Pay attention to the maneu-
ver definition (Input From File) and the vehicle’s powertrain
configuration.
Traffic Envi- | ./Examples/BasicFunctions/Traf- | Show how to simulate traffic objects and define an overtak-
ronment fic/ ing maneuver. Pay attention to the traffic (Parameters >
Traffic), and maneuver definition.
Driver .JExamples/DriverAssistance/ These tests show special assistance systems: ACC, lane
Assistance keeping and parking assistance systems. Pay attention to
Systems the sensor definition (Parameters > Vehicle > Sensors).
Vehicle fea- ./Examples/BasicFunctions/DVA/ These tests present some of the special features of Car-
tures InteractWithModellnterfaces/ Maker’s vehicle model, like flexible body, Pfeffer steering
.JExamples/BasicFunctions/Vehi- model and sensor definitions. Pay attention to the vehicle
cleModel/Steering/ parameterization (Parameters > Vehicle).
.JExamples/BasicFunctions/Sen-
sors/

Driving as ./Examples/BasicFunctions/Driv- Show how to simulate reversing, turning on intersections,
usual er/ race conditions, etc. Pay attention to the settings in
IPGDriver.

Road fea-|./Examples/BasicFunctions/| Show how to realize comprehensive road configurations
tures Road/ including real measurements, 3D tracks and special

bumps and markers.

Simulation|./Examples/BasicFunctions/| Special maneuver definitions including the minimaneuver
specific | Maneuvers/MinimaneuverCom-| command language, DVA commands and RTExpressions.
functions mands/ Pay attention to the Minimaneuver Commands in the

.JExamples/BasicFunctions/| maneuver definition.

Maneuvers/SpecialManeuvers/

.JExamples/BasicFunctions/DVA/

.JExamples/BasicFunctions/

RTEXxpressions/
Testauto- ./Examples/BasicFunctions/Tes- | Using the TestManager functionality to create a test series
mation tAutomation/TestManager/ including parameter variations, criteria evaluation, etc.

See CarMaker GUI > Simulation > TestManager.
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10.3 Feature List

DVA: How to Manipulate the Variables Online

CarMaker allows the user to check the values of specific variables online, e.g. to plot a dia-
gram directly during the simulation. These variables are called User Accessible Quantities.

The UAQs are useful, not only to be read, but also to be written during the simulation: This
is called Direct Variable Access.

It's a unique and powerful feature of CarMaker that allows influencing the simulation online,
e.g. to trigger exceptional actions, such as an accident or a failure in the vehicle that blocks
the steering system.

The DVA functionality is also programmable.

The DVA GUI is accessed via CarMaker GUI > Application > Direct Variable Access.

i # CarMaker - Direct Variable Access

Direct Variable Access Close |
Quantity Value Unit G1 G2 Mode Duration [ms] MNew Value
&|DM Brake [ 0- o vame| | s000 [ o7 set|
&[Cary [ 0 mis {0 aTE] | _|
] | LR Valie] | Set
£1 | L i | | e
3 | {1 e | [ s
3| | LI Waie] | [ =
] | LR ] | Set
£1 | L i | [ s
3 | {1 e | [ s
¥ | LW il | £l

Set Group 1 | Set Group 2 | Release all |

Figure 10.1: DVA window

Model Check: How to Check the Vehicle Parameterization

ModelCheck is a tool used to plot diagrams from the CarMaker TestRun definition that are
standard in the automotive domain.

The ModelCheck GUI is accessed through the CarMaker GUI > Simulation > ModelCheck.
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o CarMaker - Model Parameter Check

Model Parameter Check
| B ModelCheck.txt - KWrite
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Figure 10.2: ModelCheck GUI

Test Automation

CarMaker offers many solutions for simulation test automation. The descriptions of these
tools are documented in the User’s Guide and Reference Manual.

» Test Manager

The Test Manager functionality enables the user to define a series of TestRuns, where Car-
Maker automatically starts the next TestRun when one is finished. If the Storage of Results
option is set to Save all, a series of tests can be started and left alone, so that the user
doesn’t need to do anything and can later come back to the finished simulations and ana-
lyze the results right away.

Variations of quantities and parameters in a TestRun are easily conductible and it is possi-
ble for the user to integrate individual scripts for controlling the execution of the TestRuns.

e Script Control

ScriptControl, next to other functionalities, mainly enables automation of all actions that are
usually manually conducted via the GUI. As it is based on a script language (tcl/tk), closed
loops can be defined to load tests, save results or define counters.

- DDE
ScriptControl can also be controlled by DDE channels.
* Matlab

Last but not least, SciptControl can be controlled via Matlab.

IPGDriver: Driver Model

* Standard Driver
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The standard driver model is the one that has been used during the previous chapters. It is
much more than a simple speed and steering wheel controller.

The driver can shift gears, decide when it is reasonable to shift sooner in order to have more
power at the end of a curve and looks ahead to predict speed and course.

* Race Driver

The race driver teaches himself the limits of the vehicle in order to optimize its trajectory by
driving multiple courses of a specific Testrun with a specific vehicle. Each lap he increases
his maximum lateral and longitudinal accelerations and saves them as Driver Knowledge.

Input From File: Integration of Measurements to the Simulation

This feature enables the definition of the maneuver based on measurements that the user
has performed.

This can be very useful for comparing simulation results with measurements. The input for
the simulation can be directly transferred from that of the real measurement, this way the
boundary conditions are similar, and the results can be easily compared.

As an example, see the TestRun Product Examples > Examples > BasicFunctions >
Maneuvers > RecordAndReplay > MeasurementReplay where a braking maneuver is ana-
lyzed. The measured positions of the pedals during the maneuver are used as input for the
simulation and then braking distance, longitudinal acceleration and a few more quantities
of the simulation results can be compared with the data from the measurement.

Obstacles on the Road Surface
The CarMaker road model features a set of obstacles that help to alter its surface:

* Beams

+ Waves

« Cones
 Friction stripes
* Mesh

« CRG

e Lateral profiles

Examples to these obstacles can be found under Product Examples > Examples > Basic-
Functions > Road.

Simulation of Wind Effects

It is also possible to simulate wind effects. Find the appending example under Product
Examples > Examples > BasicFunctions > Driver >SteeringByTorque.

Traffic Simulation

It is possible to simulate the presence of additional vehicles on the road, in both directions.

Furthermore the driver can be influenced to slow down due to velocity signs that are also
displayed in IPGMovie.

See Examples to the topic traffic environment in Product Examples > Examples > Basic-
Functions >Traffic.
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Secured Files: How to Exchange Data Sets Safely

Using CarMaker, data sets can be converted into binary files. Other users will not be able
to read the values defined in the file, but use them for simulations with CarMaker.

IPGControl

IPGControl is a tool used to plot diagrams of any of the UAQ (see definition in Product
Example > Examples > BasicFunctions > DVA) online.

IPGControl also works offline.

IPGMovie

IPGMovie is CarMaker’s online animation tool.

IPGMovie also works offline.

Online Capabilities
It is always possible to online check how the simulation is running.

E.g. if the animation in IPGMovie reveals that a mistake has been made while choosing the
vehicle, the simulation can be immediately aborted, the correct vehicle or TestRun can be
loaded and the simulation is ready to start again. The user does not need to wait for the end
of the simulation in order to make changes in case there has been an error.

3D road

The CarMaker road model is three dimensional.

The user can create own roads without having data prior to simulation, thanks to the Sce-
nario Editor that allows free design of road networks and surroundings. On the other hand,
if the user does have data regarding the road, it can be used to model the course in Car-
Maker. This allows the user to perform simulations in reality and the virtual CarMaker envi-
ronment simultaneously for comparison.

Integration of External Models
CarMaker delivers several interfaces that help integrate external models:

* Simulink: In Simulink, CarMaker models can be modified and it can be used to read
and write values.

e C-code: The user can program individual codes, or interfaces with his own tools.
* AVL Cruise
» Sherpa Engineering thermodynamical engine model

Post processing

» Besides the IPG specific ERG result file format, CarMaker can generate output data
files in MDF and ASCII format, too.

» MATLAB: CarMaker has an interface to MATLAB which helps analyze the results. You
can load the CarMaker results in Matlab.

» EXCEL: Results can be exported directly from IPGControl to an Excel sheet.
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Documentation of CarMaker

For further information on CarMaker and it's functions, please refer to the other documen-
tations User’s Guide, Reference Manual and Programmer’s Guide.
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